Shop Learn
Forum update progress report - Page 11 — Parallax Forums

Forum update progress report

18911131416

Comments

  • evanhevanh Posts: 11,068

    I'd like to see an effort to have fall-backs from needing any javascript.

  • Wuerfel_21Wuerfel_21 Posts: 1,739
    edited 2021-02-02 12:57

    Oh ye, the editor doesn't hate me no more.... _RET_ <- there, no problem.

    Stuff like the code button behaviour seems like it'd be trivial to fix, as opposed to the endless issues of the WYSIWYG box, everything else is CSS. I think this one doesn't do syntax highlighting, right?

    if {errno} printf("gonk");
    

    Then agiain, that just means we can add it in from scratch in a non-ludicrous way.
    Oh, there is... must look into it later, am on phone RN.

    Oh, and the "save draft" button is still gone and we now need the "preview" button back

  • VonSzarvasVonSzarvas Posts: 2,395
    edited 2021-02-02 13:34

    @Wuerfel_21 said:
    ... and we now need the "preview" button back

    Preview button to the left of the "Post Comment" button ?

    Those two buttons could be floated up under the comment box.

  • It's there now, all good (or did I just somehow miss it last time)

  • @Wuerfel_21 said:
    It's there now, all good (or did I just somehow miss it last time)

    missed it :)
    I think it's too far down on mobile view, so easier to miss.

  • yetiyeti Posts: 781

    Can we please get a preview in the "INBOX" editor too?

  • VonSzarvasVonSzarvas Posts: 2,395
    edited 2021-02-02 14:15

    Hi everyone- just to be clear on expectations....

    As it's not practical for me to reply to each idea (and somewhat cluttering too!), and as this thread seems like the perfect log (ie. no need to maintain another list for community ideas), then I'd like to say thank you all for posting the ideas here!

    I will set some time aside on the coming weekend (and future weekends) to go over all the posts in this thread, and implement what I can. As each update is completed, I'll drop a post to list the items covered (similar to as I have been doing). Some things will need to wait for a system update- others might be possible sooner, and I will try my best for you all.

    Perhaps we could ask @Wuerfel_21 to update the thread title to something like "Forum update progress report", as I feel we are beyond breakage (did we even have any unexpected downtime or data issues?). Anyway... "progress" sure motivates me more !

    For the next few days I will be shut off in a small room making PCBs :) Look out for imagery at the Zoom forums!

  • @VonSzarvas said:
    (did we even have any unexpected downtime or data issues?)

    I mean we did have the images disappeararing at one point? (And sometimes also the attachments)

    I'll rename this thread and also make a separate one for editor testing so as to not clutter this one.

  • @Wuerfel_21 said:

    @VonSzarvas said:
    (did we even have any unexpected downtime or data issues?)

    I mean we did have the images disappearing at one point? (And sometimes also the attachments)

    OK, sure, there was a display poop for some moments before the relevant plugin was enabled. Hardly a breakage.. nothing was missing or lost :)

    Appreciate the new title- I feel positively energised to make progress!

  • Wuerfel_21Wuerfel_21 Posts: 1,739
    edited 2021-02-02 16:07

    Unrelatedly, there seems to be some JS dumbery going on with the fonts, which causes some fonts to change a second after loading. You can see it on the thread lists, the font just stops being bold for some reason. It also adds some attributes to the <html> element, idk? Kinda distracting, but not super important.

  • Oh, and another thing: This editor has tables again, but the CSS for them is still borked. I posted some working table CSS here some pages back.

  • TonyB_TonyB_ Posts: 1,728
    edited 2021-02-02 18:18

    @VonSzarvas said:
    Today we try a new editor plugin.

    BTW, if there is a silent majority that would prefer we revert to the WYSIWYG editor, let us know. One thing is sure, that we would see improvements over time with that too.

    I can post replies with quote using Firefox 3.6.28 (from 2010) on Win98SE (from 1999), so I'm happy with the new editor. The Edit button also works, which it hasn't done for the last two or three years. My only complaint is the Edit box is not tall enough.

    The WYSIWYG editor did not work at all.

  • Questions:
    1. How are posts stored internally?
    2. Are old posts stored with their corresponding BBcodes, or with HTML tags that convert back to BBcodes for editing?
    3. If the former, what happens when you try to edit an old post that has BBcodes?
    Thanks,
    -Phil

  • Yes, old BBcode posts stay as BBcode when you edit them. This same editor supports either (and a bunch of other formats).

  • Probably good to put this here, too: Thanks to this editor not being obsfuscated nonsense, I was able to figure out how to fix the code block insertion behaviour

  • While we’re piling things on Vinsvarvas’s plate, notifications appear to be borked on mobile. Loving the new editor btw!

  • Owie ouch, that's no good.


    It seems the tables got silently fixed

    Thing Status
    Tables (in posts) are cool
    Tables (in preview) the CSS doesn't seem to apply on those
  • Testing BBcodes: [b]Boldface?[/b] Nope!

    @Wuerfel_21 said:
    Yes, old BBcode posts stay as BBcode when you edit them. This same editor supports either (and a bunch of other formats).

    Well, this didn't work with new BBcodes. So how does the editor discern what's old and what's new?
    -Phil

  • So how does the editor discern what's old and what's new?

    It just remembers which format a message was written in.

    note that if y'all really want tags, you can actually use some HTML tags, such as <b>,<strong>,<i>, etc

  • Wuerfel_21Wuerfel_21 Posts: 1,739
    edited 2021-02-02 21:29

    CSS tweak for making subscript/superscript actually work. There's a dumb rule that applies the same text settings to a bunch of tags, breaking sub/sup

    sup {
        vertical-align: super;
        font-size: smaller;
    }
    sub {
        vertical-align: sub;
        font-size: smaller;
    }
    
  • Cluso99Cluso99 Posts: 17,773
    edited 2021-02-02 22:00

    When editing old posts with BBS tags, you can add new BBS tags.
    Just experimenting with the new bold etc icons here (thanks for adding these icons back - makes it easier - I’m on an iPad atm)

    Bold
    Italic
    Strikethru

    BTW haven’t noticed the lags since the last update. Fingers crossed.

    @VonSzarvas Thanks for your perseverance :sunglasses:

  • Wuerfel_21Wuerfel_21 Posts: 1,739
    edited 2021-02-02 21:57

    Relatedly, CTRL+C and CTRL+V this to make the <kbd> tag look cool instead of look not at all

    kbd {
        background-color: #CCC;
        border-color: #000;
        border: 1px;
        border-style: solid;
        padding: 1px 4px;
        border-radius: 3px;
        box-shadow: 1px 1px 0px 1px #222;
        margin-right: 2px;
        display: inline-block;
        line-height: 1;
        min-width: 21px;
        text-align: center;
    }
    

  • Neat!

    CTRL+A and CTRL+X

  • evanhevanh Posts: 11,068

    @Cluso99 said:
    BTW haven’t noticed the lags since the last update. Fingers crossed.

    Yeah, it's the new editor, it's good. I just tried it out now and was able to reply to another post with lots of chopped up quoting without any scripting enabled. Big improvement!

  • There should probably eventually be a sticky that explains all the non-obvious features (like super/subscript, tables, escaping, etc)

  • @Wuerfel_21 said:
    There should probably eventually be a sticky that explains all the non-obvious features (like super/subscript, tables, escaping, etc)

    Or they could be put in the edit menu, next to B, I, and S.

    -Phil

  • Cluso99Cluso99 Posts: 17,773
    edited 2021-02-05 13:11

    Just had a new freeze with extremely unusual results that may shed a light on to what is happening.

    I was just posting a post (what else). It was under 15 lines and contained a link to another thread in case it's relevant.

    Then every few seconds I received a popup saying the website was non-responsive and did I want to wait or close the page. Of course I had my typing so I wanted to wait. I must have received dozens of popups over the next 10 minutes or more, each time answering wait. And the screen (tab) was locked. so I couldn't do my famous copy of the text for posting later :(

    Finally it cleared, and the post was successful.

  • @Cluso99 said:
    Just had a new freeze with extremely unusual results that may shed a light on to what is happening.

    I was just posting a post (what else). It was under 15 lines and contained a link to another thread in case it's relevant.

    Then every few seconds I received a popup saying the website was non-responsive and did I want to wait or close the page. Of course I had my typing so I wanted to wait. I must have received dozens of popups over the next 10 minutes or more, each time answering wait. And the screen (tab) was locked. so I couldn't do my famous copy of the text for posting later :(

    Finally it cleared, and the post was successful.

    Thanks, will investigate the link idea.
    Assuming this was the post, but otherwise please correct me:) https://forums.parallax.com/discussion/comment/1516334/#Comment_1516334

  • RsadeikaRsadeika Posts: 3,565

    I was also doing a post, about fifteen minutes ago, and experienced exactly the same thing that Cluso99 described. It also occurred yesterday, late afternoon, when I was on my RPi using Chrome, I thought it was an issue with Chrome.

    Ray

  • Cluso99Cluso99 Posts: 17,773

    @VonSzarvas said:

    @Cluso99 said:
    Just had a new freeze with extremely unusual results that may shed a light on to what is happening.

    I was just posting a post (what else). It was under 15 lines and contained a link to another thread in case it's relevant.

    Then every few seconds I received a popup saying the website was non-responsive and did I want to wait or close the page. Of course I had my typing so I wanted to wait. I must have received dozens of popups over the next 10 minutes or more, each time answering wait. And the screen (tab) was locked. so I couldn't do my famous copy of the text for posting later :(

    Finally it cleared, and the post was successful.

    Thanks, will investigate the link idea.
    Assuming this was the post, but otherwise please correct me:) https://forums.parallax.com/discussion/comment/1516334/#Comment_1516334

    Yes, that was it

Sign In or Register to comment.