Shop OBEX P1 Docs P2 Docs Learn Events
Dracblade SBC with Catalina C, PropBasic, CP/M, MP/M, TRS80, wireless network, - Page 9 — Parallax Forums

Dracblade SBC with Catalina C, PropBasic, CP/M, MP/M, TRS80, wireless network,



  • Cluso99Cluso99 Posts: 18,069
    edited 2010-01-22 06:22
    Drac, you have really made some great progress here. Congratulations!!!

    Links to other interesting threads:

    · Home of the MultiBladeProps: TriBlade,·RamBlade,·SixBlade, website
    · Single Board Computer:·3 Propeller ICs·and a·TriBladeProp board (ZiCog Z80 Emulator)
    · Prop Tools under Development or Completed (Index)
    · Emulators: CPUs Z80 etc; Micros Altair etc;· Terminals·VT100 etc; (Index) ZiCog (Z80) , MoCog (6809)
    · Search the Propeller forums·(uses advanced Google search)
    My cruising website is: ··· MultiBladeProp is:
  • Dr_AculaDr_Acula Posts: 5,484
    edited 2010-01-22 07:37
    @mikediv, I'm just zooming on on the transistor on those latest photos and if that is a 2n2222 then it would be correct, ie it is facing backwards to a 547 but the pins go EBC instead of CBE so that would be correct. Great news to hear it is working so far.

    So... waiting on the rest of the chips?

    @ cluso - thanks for the comment. I think there will be some real synergies with catalina, the ramblade and the dracblade code. (I posted a freebie board off to RossH today. He has some great ideas re using the LCD display for debugging)

    I'm pondering another run of boards and thinking, given the difficulties of switchers, whether it is worth putting in slots for linear regs as well - then you can choose either?

  • mikedivmikediv Posts: 825
    edited 2010-01-22 20:36
    my board is 100 percent complete.. I was going to add the last edge connectors but figured I wanted to just get it working I can load spin files no problem , but when I try to load a program called """"Main_Dr_Acula """
    The program will hang at the start """""#define CPU_Z80 "" and say Expected "." or end of line """" I can get no further some of the other spin files files will load just fine I dont know what order they are in but DracLCD and DracBlade load inot ram or eprom

    CLusso Thank you but I am embarrassed to say I am not sure what you are referring to???? the only programs spin I have are the ones I got from this file""PropArchive-Nov-30-2009""" It has the MainDrac and DracLCD and Timing and some other files I do not know what to do in what order to get CPM to boot or even find out if the SD card portion of my board is working so any help guys I will be very thankful

    Oh one more thing if you guys look at my board I installed a giant LED for the debug led the one near the DC power connector as soon as I turn my board on this LED is lit is that correct?

    DR_A I do have the correct transistor it came in today with the rest of the chips but to honest the 2n2222 is working fine so I just might leave it alone
    2272 x 1704 - 1019K
  • Toby SeckshundToby Seckshund Posts: 2,027
    edited 2010-01-22 20:56

    Are you trying to use the proptool to compile? That will just crash out on the conditional defines etc.

    Or on BST under TOOLS-Compiler Options you have to tick,

    Eliminate unused spin ...

    Generic "safe" opt ...

    Non-Parallax compatable extentions

    ( I think )

    Style and grace : Nil point
  • mikedivmikediv Posts: 825
    edited 2010-01-22 22:33
    Toby yes you are quite right I have been using the prop tool 1.2.7 I have never used BST

    Toby I just tried BST but now I get the error msg compile error "#Else """" when I try to load "Main_DRAcula_Spin" I am assuming this is the first program I should load since it says DRAcula Main right?

    Post Edited (mikediv) : 1/22/2010 10:40:22 PM GMT
  • Dr_AculaDr_Acula Posts: 5,484
    edited 2010-01-22 23:42
    Cool. A giant debug led. Don't tell humanoido, he will want to drive it with a valve or something.

    Leave the 2n2222 as it is - we had crossed posts and your latest photos are perfect.

    Ok, BST takes a tiny bit of setting up. See the screen shot below which is the same as what Toby said. Anyway, it is the settings I've got.

    Also watch changing to other spin programs. It remembers the new one and sometimes you are in the wrong folder. Ok for now as you only have one folder but it can get confusing if you have multiple versions.

    What I'm doing is keeping all my files including BST itself in one folder, then when I do a major change, copy the whole lot including BST into a new folder. I double click on BST to get things going (not on the Spin programs, as that is linked to the Prop Tool).

    So hopefully that will compile.


    Post Edited (Dr_Acula) : 1/22/2010 11:48:57 PM GMT
    1018 x 742 - 131K
  • mikedivmikediv Posts: 825
    edited 2010-01-23 01:07
    Ok DR_A I got BST to work and load mainDRacula Spin I loaded it into eprom I have an VGA and the SD card 1 gig loaded with all the files but after loading my board does nothing ,, nothing at all is there a way I can check the VGA and the SD card or am I missing somehting
    What should I load first into my Drac board and what should I see on the screen thank you
  • Dr_AculaDr_Acula Posts: 5,484
    edited 2010-01-23 01:36
    Ok, let's build this up in stages. First thing to test is the vga display is working.

    See the attached. This is a binary of the HELLO WORLD from Catalina (Thanks RossH!!!) If you double click on it then it should load up the Proptool (not BST) and you should be able to download it. Either load ram or load eeprom - it doesn't matter.

    If that works then try Test Suite (you might need to close the prop tool down then double click test_suite.binary)

    That will test the keyboard works.

    Let me know how both those tests go. If they work we can move on to the sd card.

  • mikedivmikediv Posts: 825
    edited 2010-01-23 02:45
    Gee sorry to be such a pain Doc , I downloaded both files loading them with BST hello world loads and does nothing zippo when I load the other testsuite the only thing that happens is all th eLEDS on my keyboard flash on and off I see nothing on the VGA monitor for either program but the test suite blinks the keyboard leds like I said ,, what should I be checking is there a simple VGA progrma I can load to see if the VGA circuit is working. one other thing if I try to load
    hello world with the prop tool it give me an error ans says no com port 2 or somehting like that, but if I close that and hit F7 it finds the board with no problems also BST works just fine???
  • YodaYoda Posts: 132
    edited 2010-01-23 04:26

    I would look in the propeller tool samples directory. There are several vga demos and keyboard demos there. You will have to probably modify what pins are used to be compatible with the dracblade. The C program is not the way to do bring up. It brings in too many components. Your description sounds like it might be in the memory subsystem or it could even be the driver Drac wrote for Catalina. You need to eliminate as much as you can and check out each section. You are on the right path, make sure the VGA is working , then the keyboard. You can find sample test programs for the uSD in the forums to test that as well. You probably will have to adjust pins as well in the code. Then that leaves the external RAM subsystem. I don't know if Drac has written any test/verification programs for that but with the schematic you can probably write some simple spin programs to exercise the latches and the RAM - you might need a scope, logic analyzer, or even a voltmeter to see if things are being outputted to the correct pins and you can write an address and read it back and see if you get the same answer.
  • Dr_AculaDr_Acula Posts: 5,484
    edited 2010-01-23 04:47
    Hmm - first is it actually downloading? one other thing if I try to load
    hello world with the prop tool it give me an error ans says no com port 2

    Thanks ++ for contributions from others. FWIW the VGA & keyboard pins are exactly the same as the prop demo board, so any prop demo programs can be used to test this.

    If you double click hello_world.binary, it should come up in the prop tool

    Then click Load Ram

    This should say "Loading Ram" for about 5 secs, then very briefly should say "verifying ram"

    if that works...

    Then try eeprom

    It should say Loading ram, then verifying ram, then programming eeprom then veryifying eeprom

    If that is working then that tests the eeprom and the ram.

    Then there is a step that most of us leave out describing, but sometimes you have to write a tiny spin program to turn a particular pin high for 1 sec then low for 1sec and test that works. There is a demo program for that in the propeller documentation and it might be worth picking a few random pins and see if you can get them going on and off.

    But if a program goes through ok, and nothing on the vga, then probably the vga bit isn't working. Can you take some closeup photos round the vga plug and resistors?


    Post Edited (Dr_Acula) : 1/23/2010 4:53:50 AM GMT
  • RossHRossH Posts: 5,344
    edited 2010-01-23 05:01
    Hi Dr_Acula,

    I just posted (in the Catalina thread) a new HiRes VGA driver for you to try. Let me know if it works.


    Catalina - a FREE C compiler for the Propeller - see Catalina
  • YodaYoda Posts: 132
    edited 2010-01-23 05:02

    What I was trying to point out is that if you use a C program, you are bringing your external Ram into play probably. You want the test programs to be in spin and not executing outside of the prop until you have verified all those subsystems, ie, keyboard, vga, and uSD. Your hello world program may not verify just the vga as it could even be in your catalina driver. Eliminate as much external connections that you can and test one thing at a time.
  • RossHRossH Posts: 5,344
    edited 2010-01-23 05:21
    Hi Yoda,

    I was not trying to intervene in your discussion with Dr_Acula - my post about Catalina and VGA is just a coincidence of timing.

    I agree with you that eliminating as much uncertainty as possible is a Good Thing when debugging.


    Catalina - a FREE C compiler for the Propeller - see Catalina
  • Toby SeckshundToby Seckshund Posts: 2,027
    edited 2010-01-23 09:11
    As Dr_A says the cct is much the same as a demoboard so all the latches and external ram could be removed and some standard OBEX items used to test basics first.

    With my copies I have found that with only the Prop and EEPROM fitted it gives a "blue screen of almost death" moaning about not mounting the SD, but it is a VGA sceeen to show that bit works. It also shows that the Prop is running and if a F11 was used that the EEPROM is good.

    With the SD in (pre loadedwith the files) the mount moans should go away and be replaced with some about loading the Z80 bits and bobs but fails due to no "external ram" being found. This is hidden behind a "Press spacebace for next instuction" error message, on my bits, as I do not always have the debug second serial out.

    If all seems good but the VGA refuses to show check for the connections to the 15 way VGA conector, a lack of V or H syncs will leave the monitor in snooze land. I also have a hatred of the 5 Volts connection to it's PIN9. This serves no purpose to a prop system (yet) and is a potential problem with non-spec connecting leads etc ( it allows P+Pray on PCs )

    Style and grace : Nil point

    Post Edited (Toby Seckshund) : 1/23/2010 9:21:10 AM GMT
  • mikedivmikediv Posts: 825
    edited 2010-01-23 15:48
    Thanks guys ,, Dr_A yes it does exactly that , I with BST I can load Eprom and Ram and it goes through showing ram or erpom is loading then it says OK or done so the programs defiantly run or at least get downloaded to ram or eprom
    Yoda thank you I did want a very basic program ,, Doc I did not realize the VGA pinouts where the same I did try and use some of the demo programs form the prop tool library ,, I will take you advice and try and do simple
    dira outa and see if I can control the pins,, I have changed the Eprom and the prop ship I will try and get you a good shot of the VGA area and post it back I have been trouble shooting it all night though and even going right to the prop pins for the VGA following your schematic
    when I load a VGA program it does not seem to do anything on the pins but like I said test suite program will blink the keyboard LEDS on and off

    Guys I can not thank everyone enough for all the help I am dying to get CPM to work I have been drooling over this since you guys started posting... Oh Dr_A I forgot to tell you the other day I received a very damaged and resealed envelope it look liked someone beat the heck out of it the only thing inside was an SD card socket it looks like you can put a smaller sd card into this full size sd card, it also has print all over it to the effect customs " damaged or lost item blah blah blah I saved it in case you need it but I am assuming this was my original board??? It just came last wed there was no board in it just the sd card do you want me to mail it back to you????

    I never got a chance to thank you for sending my another board out right away while we waited to figure out what happened I think everyone should know how well you treated me and got me a new board out right away thank you
  • Toby SeckshundToby Seckshund Posts: 2,027
    edited 2010-01-23 17:39
    Dr_A was going to send me a board as a "sorry" when it turned out that the reason that my Mk1, rippoff of his design, didn't work. It turned out that I had copied the original archive's cct diagram from his original musings (onto the works A3 laser), he had then tidied up a load of things around the '138 chip which left me trying Mk1 ccts with Mk2/3 software.

    Everybody helped me suss it all out then, so I feel your pain ...

    Style and grace : Nil point
  • Dr_AculaDr_Acula Posts: 5,484
    edited 2010-01-23 23:38
    Re the letter arriving many weeks late and broken. ? opened by customs or something. You may as well keep it and save the postage.

    Re yoda "What I was trying to point out is that if you use a C program, you are bringing your external Ram into play probably.'

    The C program doesn't use the ram (yet). We are getting close to testing the ram but haven't got there yet.

    I chose the C program because it seems the simplest program that prints something to the screen without doing much else. In particular, there are all sorts of VGA drivers in the obex but many are not "complete" - you have to send them characters or something. The C progam is complete - you run it either on the demo board or this board and it prints white on blue on the screen.

    If that isn't working then either the prop isn't downloading and running, or the VGA driver is not working somehow.

    So - first step is to see if an even simpler program can run. One that just changes one pin on the prop. I'm not going to have access to a prop for the next 12 hours, but one would need something "complete". I think but am not sure that there is a walk through example of that in the prop manual.

    That will prove the prop is working.

    The comment about 5V to that vga pin is interesting and it would be worth checking the 5V reg on the board is working, but I presume it is as an F7 is recognising the prop, and the F7 data has to go back and forth through the max232 and the max232 is run from 5V and we know that all the voltages on the max232 are correct (PM a few days ago)

    So if the pin on/off code works then something is wrong with the vga.

    I presume the monitor works on other computers etc?


    Post Edited (Dr_Acula) : 1/23/2010 11:48:01 PM GMT
  • mikedivmikediv Posts: 825
    edited 2010-01-24 00:29
    Success !!! Hello world and Test suite as well as a few program I have written myself

    all work fine Guys I ended up pulling the inductors both of them I changed the regulators to LM7805 and LM340 and made some changes to the power supply the inductors even though on my scope the signals looked fine must have been causing problem becuase the voltage was 3.01 and 5.00 now they are 3.3 and 5 so I guess that little change was causing my grief,,, OK working is a relative term now I need to test out the SD card and get CPM to work can anyone tell me where to go from here,,
    And thanks everyone I know I have been asking for a lot of hand holding..

    Oh Duh I forgot the biggest change was moving to an XP machine from Vista and using a real RS-232 port ,, To be honest I do not think its Vista per'se but my Vista I have a Dell mega desktop with 4 gig or Ram and all the bells and whistles and Vista has been nothing but trouble on this machine I upgraded from XP and should have just done a clean install so for now I will just use the XP machine

    Post Edited (mikediv) : 1/24/2010 12:36:46 AM GMT
  • Dr_AculaDr_Acula Posts: 5,484
    edited 2010-01-24 00:52
    Ok, this is great!

    So you have a keyboard and display.

    next is the sd card. Format it as fat 16 (plain FAT - not fat 32) - - right click on the drive when it comes up and one option is to format. Then copy over all the .dsk files and the myname.txt file. I think you already have those.

    The fire up BST and compile the Main program and it should boot up and give you at least something on the display - either a success or fail on the sd card as that is the first thing it does.

    (As an aside I am redesigning the board - almost the same except a little smaller, and slots for 7805, LM1117 and the switchers. So you can use one of three types of regulator. LM340 looks popular, I'll see what the pinout is for that too)

  • mikedivmikediv Posts: 825
    edited 2010-01-24 01:19
    OK I downloaded maindracula with BST then reset my board I have the SD card in with the files we talked about it comes up and says Zicog with Dracbalde D9f-19200 baud D9M=baud. F12=network

    c=c.dsk all the way to h=h.dsk
    then it says read boot code from sd card
    start Z80
    passed loading Zicog
    then af=2000 bc=2a68 and so on then under that it says
    all the way to E9F3
    then it says
    Unimplemented instruction one before location PC, any key to continue
    if I hit keys it keeps saying stuff and hit any key finally after doing it 3 times I think the screen goes blank and nothing?????
    DR_A what should I compile ?? not clear I also tried loading a Dracfile that said terminal that worked as well but where do I get to the CPM part???

    I just tried different files it now says loading Sram
    read boot code from SD card and store at $FF00
    starting Z80 emulation
    passed loading Zicog
    spacebar for next instrution but no matter what I do hit space bar enter it just does nothing its like its locked up at that screen???

    Thank you

    Post Edited (mikediv) : 1/24/2010 1:47:09 AM GMT
  • Dr_AculaDr_Acula Posts: 5,484
    edited 2010-01-24 01:29
    CP/M is on A.DSK but it is not loading.

    The zicog loads first, then a tiny program loads which then loads CP/M.

    I think the zicog is crashing and this might be due to the ram not working.

    I need to think of a way to test the ram (without having a board in front of me - I'm at work at the moment).

    What you need is code to write one byte to ram then read it back. I think the remnants of this code might still be in there, but commented out. When I get a moment I'll see if I can download the source and suggest a couple of lines to try.

  • mikedivmikediv Posts: 825
    edited 2010-01-24 01:47
    DR_A please no rush I can certainly wait and do not want to be a pain I am only posting my progress but please do not feel you have to answer if you are busy I waited this long its exciting I am getting close but no big hurry sir
    I edited my post above

    DR_A I am going to quit for tonight you are working and I am going to bed,,, stinks getting old, ?I think you are correct it looks like the 75HC138 might be giving me problems I will get back at it tomorrow but like I said please do not feel obligated to help me when you are busy take your time you are doing me a favor and I very much appreciate it

    Post Edited (mikediv) : 1/24/2010 1:57:17 AM GMT
  • Dr_AculaDr_Acula Posts: 5,484
    edited 2010-01-24 02:20
    Quick check - as part of the bootup is one of the messages
    "Boardname = ALPHA"
    or are you getting
    "Myname.txt not found"

    Second thing - when it boots up, does the diagnostic led come on? (that will test that at least one latch is working and the 138 is working)

    Next - we need a little test to see if the ram is working. Ok, in BST in the main program is a subroutine about 2/3 of the way down
    PRI LoadSRAM |  r 'i, j, r, b1, b2

    look through that for a line
      buff[noparse][[/noparse]0] := $C3                                        'jmp to $FF00 at $0000 (faster)
      buff := $00
      buff := $FF
      RamLatches.DoCmd("W", @buff, 0, 3) ' write 3 bytes in buff array to address 0

    after that line, add the following (line it up vertically under ramlatches otherwise it won't compile right)
    vgatext.hex(buff[noparse][[/noparse]0],2) ' this should print C3
    buff[noparse][[/noparse]0]:=1 ' this changes it to 01
    vgatext.hex(buff[noparse][[/noparse]0],2) ' this should print 01
    RamLatches.DoCmd("R", @buff, 0, 3) ' read 3 bytes in buff array to address 0
    vgatext.hex(buff[noparse][[/noparse]0],2) ' this should print C3 again

    which should give something like this
    Loading Zicog

    64K CP/M Version 2.2 (ZiCog, BIOS V1.27_Zi04, 8 HD, 10-Sep-2009)

    (the C301C3 has no spaces and nothing before the Z80 of the next line, this is for debugging and the aim of this is to see if you get C301C3 or (error) C30101)


    Post Edited (Dr_Acula) : 1/24/2010 12:52:50 PM GMT
  • Toby SeckshundToby Seckshund Posts: 2,027
    edited 2010-01-24 11:30

    I have put together 3 "copies" of the DracBlade.

    On the first one I used three latches, missing out the LCD one, and when the cct was fired up from plugging in the PSU about half of the time I got the loading messages up to the "Press Spacebar ...". On the second "debug" '232 there may be better explainations but that didn't excist. If the reset button was pressed the loading would compete correctly every time. We suspected the PSUs as I had linear 5 V going to linear 3.3 V regs.

    On the second version I got even more minimal, only two latches were fitted as 64KB was ok for the CP/M. The PSU section was slightly changed so that both the regs came off of the incoming 9 V directly. The "Spacebar ..." problem has never happened on that board. We put it down to the PSU.

    On the third "spread out for access" one I put more of the original cct onto it. All four latches and access to the second '232 bits (ttl levels). Again the regs were not cascaded but again I get the occational "Spacebar ..." which is cured by the reset button.

    I haven't nailed down what causes it but it all comes on with the third latch. I removed it, and with tied-down address lines, the "Spacebars ..." go away. As the reset button cures it I haven't looked into it since. I do not think that Dr_A has had any of these teethings on his official boards.


    I am still toying with the SDRAM notions

    Style and grace : Nil point
    640 x 480 - 53K
  • Dr_AculaDr_Acula Posts: 5,484
    edited 2010-01-24 13:31
    I'll be interested to see whether mikediv gets C301C3 or C30101 with that code.

    Toby, you might be onto something there. Your boards have something in common with mikedivs in that they are using linear regulators. And you certainly had different responses with cascaded vs paralled regs.

    I've only ever used switching regs (mainly as I noted how hot the regs got on Cluso's board) - and haven't had problems like this.

    I'm wondering about voltage dips from the sd card causing brownout on the supplies? I think the specs say up to 200mA peak current. There would be some experimentation we can do adding in 1 sec delays after any sd card access.

  • Toby SeckshundToby Seckshund Posts: 2,027
    edited 2010-01-24 15:09
    It's certainly a possibility. I have always loaded the cct with plenty of caps, big and small. I did some crude delay experiments, at power up, to see if the regs just needed a while to settle properly, but nothing finer than that on individual resource demands.

    I am indecisive on the ram playtime. It will start out as 64KB and then I was hoping to use a mixture of the SD cards, first three pins and second '232 pins, eventually to get 1 or 2 MB. Not that I have a single use for all that memory but there would be no point in ending up with less than your 512KB (apart from lower chip count)

    Old FPM dram will be simpler on setup, but need refreshing to be contiued. I wonder if there is suficient time to be stolen from the H syncs. Whilst on that subject I was looking into reduced pins on the VGA. Leaving two for the syncs (just to leave a stable pic) one more would give B+W but two could give the white on blue. I tried cheating the H sync signal onto the low level blue resistor. It looked ok (ish) on the 'scope but the monitors clamps spoilt it. A monostable would work, but that's another chip ...

    Newer SDRAM can be set up to get on with it within itself (I think) but has enough wordage,in the data sheets, to confuse the stupid. There was an artical on Bascom AVR but it didn't just bit bang it all obviously, it ran an extra library (which I don't think was on the old version I have access to). More brain torment. I read somewher that although the RAS and CAS still have the title xxSTROBE they are no longer strobes, as in latch loading, if that is true then the DATA,ADDR LOW, ADDR HIGH multiplexing is a dead duck.

    Ironing 0.8mm is a pain, it took about four goes to get anything remotely acceptable. Thinner paper and a cooler iron was required. Still the clothing catalog that seems to have suitable paper does have 1200+ pages, so lots of experiments there.

    Style and grace : Nil point

    Post Edited (Toby Seckshund) : 1/24/2010 3:17:09 PM GMT
  • mikedivmikediv Posts: 825
    edited 2010-01-24 20:43
    Thank you all again. Well just came in my lab and got ever thing ready for some more debugging , turned on my Drac Board and WALLA it booted up right into CPM I even ran WS I can do PIP , Copy, DIR, WS I tried Sbasic but it did not want to run

    Then I got stuck in ED and rebooted a few times finally the 3rd time I am back to hit space bar for next entry or something like that . Bottom line it stopped working until I did a cold reset ,, So I guess I have somehting buggy going on but at least I know it will work
    DR-A I ended up using the files from the same directory that BST and MainDRacula resided I think initially I had mismatched files ,, I am goign to set about debugging but I have to say I hate intermittent problems ..
    But I see light at the end of the tunnel and want to say a huge thank you, Toby I still think there may be somehting buggy with my 75HC138 circuit and maybe even in the caps becuase it almost seems like something is getting saturated and then it stops working
    I thought maybe power but the 5 and 3 volts have been rock steady and I have used heat sinks on both regulators so I am not sure where to suspect at this point
  • Toby SeckshundToby Seckshund Posts: 2,027
    edited 2010-01-24 21:06

    It sounds suspiciously simular to my problem. Incidently the third incarnation didn't work the first time I powered it up.

    I set about looking to see if the problem was that the ram and latches are further away on the "spaced out". I stuffed some NOPs into the latch routines and the beasty fired up. Great, then I took the NOPs back out again to be certain that this was the problem and the little ******** still worked, and still does now. Hey-Ho.

    I tried WS but it didn't run and I just lost interest, I must look into these things, after I break it trying to nail some SDRAM to it's tail.

    PS the official exclaimation for the working DracBlade is "YIPPEE!"

    Style and grace : Nil point
  • Dr_AculaDr_Acula Posts: 5,484
    edited 2010-01-24 22:43
    Great news.

    re "becuase it almost seems like something is getting saturated and then it stops working"

    One thing to look at would be the regulators overheating and going into thermal shutdown mode - and this could explain why it worked on first bootup (because it was cold). Just check the temp with a finger - warm is ok but hot is not. Maybe a heatsink on each regulator?

    There are also delays you can add to various bits of code eg in the Dracblade.spin you can add more nop instructions.
    read_memory_byte        call #RamAddress                ' sets up the latches with the correct ram address
                            mov dira,LatchDirection2        ' for reads so P0-P7 tristate till do read
                            mov outa,GateHigh               ' actually ReadEnable but they are the same
                            andn outa,GateHigh              ' set gate low
                            nop                             ' short delay to stabilise
                            mov data_8, ina                 ' read SRAM
                            and data_8, #$FF                ' extract 8 bits
                            or  outa,GateHigh               ' set the gate high again
    read_memory_byte_ret    ret
    write_memory_byte       call #RamAddress                ' sets up the latches with the correct ram address
                            mov outx,data_8                 ' get the byte to output
                            and outx, #$FF                  ' ensure upper bytes=0
                            or outx,WriteEnable             ' or with correct 138 address
                            mov outa,outx                   ' send it out
                            andn outa,GateHigh              ' set gate low
                            nop                             ' no nop doesn't work, one does, so put in two to be sure
                            nop                             ' another NOP
                            or outa,GateHigh                ' set it high again
    write_memory_byte_ret   ret

    Are you consistently getting the diagnostic led coming on when you read or write from the sd card?

    Re wordstar not working - maybe a bad/corrupted version?
    Re sbasic - it does take a while to compile but what source code are you compiling and what command?


    Post Edited (Dr_Acula) : 1/24/2010 11:07:59 PM GMT
Sign In or Register to comment.