Shop Learn
Propeller Tool font — Parallax Forums

Propeller Tool font

bte2bte2 Posts: 150
edited 2015-01-06 06:15 in Propeller 1
Hi all, I was wondering- every once in awhile, the font in Propeller Tool gets corrupted somehow so as to be unreadable. For the life of me I cannot remember how I fixed it other than to say that uninstalling and reinstalling Prop Tool is NOT the answer. I'll post a pic.

Increasing and decreasing the size using "Text Bigger" and "Text Smaller" don't do it. Restarting the computer (including turning it all the way off) didn't do it.

Uninstalling and reinstalling Propeller Tool doesn't fix it.

Anybody have any ideas? Thanks -bryan


  • bte2bte2 Posts: 150
    edited 2015-01-06 06:07
    I searched before I posted but it came up with similar issues suggested after I did. I will try some of the things mentioned in the other threads. Sorry but I did search first.
  • bte2bte2 Posts: 150
    edited 2015-01-06 06:15
    FWIW, I searched my Parallax folder for *.ttf files. I double-clicked on the font file and there was an 'install' button on the sheet. Clicked install and it seems to have worked.
  • yisiguroyisiguro Posts: 52
    edited 2019-12-24 11:58
    Through several experiments, I found that that is sensitive to region of Windows: Propeller Tool ( or, Windows font mapper ) do not fetch requested font ( i.e. Parallax ) but substituted font ( e.g. MS UI Gothic, in my region ) when creating logical font, even if Parallax.ttf is installed correctly in system.

    According to Widows SDK, specifying DEFAULT_CHARSET to iCharSet parameter of CreateFontA(), for example, to create logical font, causes unexpected behavior when system locale's character set differs to font's character set. Parallax font is ANSI character set, maybe. If so, iCharSet parameter is to be set to ANSI_CHARSET.
  • RaymanRayman Posts: 11,962
    All fixed?
    Maybe you need administrator privileges to install the font...
    Perhaps installing the prop tool as admin would have worked...
  • Four year old thread......
  • It is a slow day today for the Propeller.

    Of course there are other things to consider.

    Mascot asleep.
  • yisiguroyisiguro Posts: 52
    edited 2019-12-24 23:46
    Reading recent discussion, I tried installing Propeller Tool with CodeWeaver's CrossOverMac ( that is based on Wine project ) on my Mac, and then same font problem occurred, i.e. Parallax font was substituted by MS UI Gothic. CrossOverMac can construct local environment per application basis, so, that is not serious and I needed replace MS UI Gothic with Parallax font. Font Replacing is one of special features of Wine. But Windows does not have such feature, so I had to find out why Propeller Tool Editor does not display Parallax font. Thanx.

    By the way, is Propeller Tool not included in Parallax Open Source repository ?
  • IIRC Propeller tool is based on a bunch of proprietary libraries - no source release anytime soon.

    As for the Parallax font, for me it always works in PropTool, but when using it in other programs, certain font sizes will have extremely messed up kerning. I recall hearing of a modified version of it that fixes that?
  • "is Propeller Tool not included in Parallax Open Source repository ?" I said earlier,

    but it mightbe coming something in the future:

    "For now, this repository serves as a place holder for future source and a repository of current releases and issues.

    Updated 12/15/2020"

Sign In or Register to comment.