Shop Learn P1 Docs P2 Docs
BS2Px24 code load problem (found discussion from 2014, are there any updates?) — Parallax Forums

BS2Px24 code load problem (found discussion from 2014, are there any updates?)

Ok, it was nice to see that I am not the only one that runs into weird problems. I'm bread-boarding a circuit for a remote control project. I'm using a BS2Px24 stamp, 2.5.4 editor and a Parallax USB to 232 adapter. The basic problem is that when I run > ident, the editor scans and finds the stamp just fine, returns "COM6, BS2Px, version, yes, yes" However, when I try to upload the program to the stamp, it starts to scan the ports and very quickly throws up an error window, "stamp not found". Power supply is at 5.00 volts, I have tried 3 different BS2Px24 stamps, 2 different computers running the 2.5.4 editor and test programs down to as simple as just a pin configuration; same results every time. EXCEPT twice, after the power had been off for a few minutes, the program loaded, ran and terminated normally. These things were seen by folks in 2014, but there did not seem to be an ultimate solution found. Does anyone have any ideas, have there been any new developments?

Comments

  • YanomaniYanomani Posts: 1,518

    Hi @overthehillgeek

    Welcome to the forums!

    Though I don't have any experience with the Basic Stamps, I'm sure you'll find a helpful and knowledgeable community here at Parallax forums.

    As for the specific problem you're facing, It'll be good if you can provide the most detail as possible, including, e.g., operating system and version, if you're sure you've checked the proper connection and state of the battery (ies), and any other info you fell apropriate.

    Sample of a related post/thread I was able to find (query google with site:forums.parallax.com AND "stamp" AND "USB" AND "2014"):

    https://forums.parallax.com/discussion/158702/stamp-detected-but-not-responding-check-power-error

    Hope it helps

    Henrique

  • Hi @overthehillgeek

    In the Basic Stamp editor com port settings, does it help if you unselect all the com ports except the actual port you are using. And untick the BS1 search option.

    Also, as Yanomani said, most the time this issue is related to power supply. Typically a low voltage, noisy voltage, interference from some other component, or some sort of intermittent connection. Not knowing anything about your setup, you might try adding a 10-100uF capacitor directly across the VIN (or VDD if you are using that) and VSS pins of the Basic Stamp module at your breadboard.

    Which reminds me... Are you connecting power to VIN or VDD on the Basic Stamp ? As I recall, if your supply is "only" 5V, then it should be connected to VDD instead of VIN. Leave VIN unconnected in that case. Maybe double check the Basic Stamp datasheet for your module as I don't have that to hand. ie. don't trust my dusty memory entirely :)

  • Hi VonSzarvas, Hi Yanomani:
    I've played with the port settings. I changed the USB port to several different COM ports, tried latency compensation from the default 16 ms thru 250 ms. I've tried setting the time outs to, as high as, 1000 ms. I've tried forcing the port selection and leaving it in the "Auto" mode. Everyone seems to come back to power supply problems. I using a small switcher supply set for exactly 5.00 volts. I thought of the possible noise problem and, since I'm working on a large solderless bread-board, I stuck 1000uF electrolytic caps at every jumper junction and at the ends of the power bus and .1 uF caps bypassing all of the chips in the circuit. But, you know what? VonS.; your question about the Vin / Vdd just turned on a light bulb in my old gray head. I need to go check, but if I fed 5 Volts from the bus into the Vin, instead of the Vdd, that would put that little LDO regulator on the stamp in the circuit and it might not pass power from the 5 Volt bus to the 5 Volt chip! The strange thing is that the stamp actually ran the program on a couple of tries.
    Thanks, guys. I have got to go check to see where I put power to the Stamp.

  • Well guys, that wasn't the problem. I thought that I might have wired the 5 Volt supply to feed the Vin instead of the Vdd pin, but it was wired correctly. However, I have concluded a little experiment that makes me believe that all 3 of the BS2Px24 stamps are bad. That includes the new one that I had to cut the sealed anti-static bag open to get to. I dug around in my junk and found an old "Board of Education" and tried all 3 stamps and got the same results. I couldn't load the program. To cap the experiment off, I put a BS2P40 on the BOE, (back end hanging off the board). Of course, I had to change the Stamp Editor over to the BS2P files, but I was able to load and run all the example programs. Moral the story is that the editor and interface work just fine. Whatever is wrong lies with the BS2Px24 stamps. I don't understand how all of them, including a new one, could be toast. I think that somewhere I have an old project, a digital lock for a gas valve. I think that I used a BS2Px24 in that and it was in service and working when I took it out. I guess tomorrow, I'll try to find that and scavenge the stamp out of it. Well, the saga continues.

  • Hey guys: FYI I'm sure, now, that those three stamps, including the new one are bad. I went rummaging and was able to retrieve an old, defunct project where I had used a BS2Px24 and stuck that one in the BOE. The program loaded and ran without changes and with no problems. I can't explain the anomalies; Two of the stamps had been used before, but were stored in anti-static foam. and I can conceive that they may have taken a static hit, somehow. But, another was still in a heat sealed anti-static bag and also seemed to be blown. And, to compound the confusion, during the dozens of attempts, one or two of the bad stamps actually did load and run properly.

    "When you have eliminated the impossible, whatever remains, however improbable, must be the truth": Sir Arthur Canon Doyle as Holmes

  • YanomaniYanomani Posts: 1,518

    Hi @overthehillgeek

    Thanks for the updates.

    Trying some blind diagnosis technics: just skipping static-zapping events for a while, and when moisture-related damage/shorts can be ruled-out, electrolytic capacitors dry-out events becomes my next preferred choice. I'm just unsure if there are any of them involved in the power supply path.

    Also hope you have some spare USB cables, just in case...

    I was about to question the USB-to-RS232 adapter you're using, since I'm still unsure if you had any chance for testing it, independently.

    Running out of ammo, here... :pensive:

Sign In or Register to comment.