Shop Learn
Unable to open BlocklyProp files — Parallax Forums

Unable to open BlocklyProp files

When trying to open a file the error reads "Unable to load the selected project file. The error reported is " Project file extension is not one of .svg or .svge"

The files that I am trying to open is .svg I appreciate if someone has a solution.

«1

Comments

  • Could you share one of the files ?

    Either zip it and attach here, or email the file to support@parallax.com

  • This file I created it and it runs, but I cannot open this and any files.

  • When I open BlocklyProp launcher in the status box the message states "Waiting to connect"

  • So far I opened your SVG at this site: https://solo.parallax.com

    That worked ok, and I can see your blocks.
    I don't have any hardware with me to try uploading, but will test that first thing tomorrow with the launcher and report back.

    There was a Solo update earlier today, so it might be worth refreshing your webpage (Hold Shift and press F5 at the solo webpage), in-case that fixed whatever was the issue. Or to be even more certain, reboot the PC.

    The latest Solo release is now 1.6.0.2, build 225.

  • One other thing... what version is your Launcher ? Might be worth re-installing it, in case that clears any issues with Windows permissions.

    The Launcher on my computer shows v1.0.1.

  • I just checked the latest Solo version and release date. It is v1.0.1 date Oct 15, 2020

  • VonSzarvasVonSzarvas Posts: 2,453
    edited 2021-08-04 13:20

    Hi @bluejay

    I tried with hardware today and your code imports and runs fine, toggling pin 4 high and low.

    If the launcher reports "Waiting to connect" it can only be that it can't connect to your Chrome browser.
    Maybe your Chrome Browser is not open yet on the webpage https://solo.parallax.com, or some permissions issue, a Chrome update issue or you have multiple versions of Chrome open that are locking the connection. (Sometimes previous Chrome browser sessions can fail to close properly, and get stuck in the background causing hidden problems)

    If you click the "Open Browser: BlocklyProp Solo" button in the launcher, does that help ?

    Also, try clicking the cog icon (bottom right of the launcher), to see if any useful error messages / clues appear.

    In general though, I'd suggest you either reboot the computer and try again, or...

    • uninstall the launcher,
    • reboot the computer,
    • then open Google Chrome, visit https://solo.parallax.com and follow the link at the top of the webpage to download and re-install the launcher

    I really hope this will solve things for you. Otherwise, please let us know some more details about your Chrome Browser version and operating system so that we can try to replicate things.

  • I 1-uninstalled launcher, 2-rebooted computer, opened chrome, and installed launcher. Result is the same problem. Launcher says waiting to connect. The cog icon states "connection: path/ip address: local host port:6009 found port com4. site disconnected.

  • The Google Chrome that I am running is v92.0.4515,131 (official build) (64 bit) (up to date). I am using win 10.

  • @bluejay

    As an experiment, instead of opening a browser window and navigating to solo.parallax.com, try clicking on the "Open Browser" button on the Launcher window. This will open an embedded Chrome browser which will hopefully connect successfully to the Launcher itself. Please let us know if that solves it.

  • I have been opening the "Open Browser" button many times with same problem.

  • Thanks @bluejay.

    Can you try closing that built-in browser and instead, use your normal Chrome browser and navigate to solo.parallax.com, then press Ctrl+Shift+I, then click on the Console tab (in the developer window that appears). There may be some vital error messages that appear there.

  • When I pressed Ctrl+Shift+I the error message displays websocket connection to /ws://local host :6009/failed:(anonymous@index.bundle.ae98995a63eb39932d591.js:1

  • Okay, that's a normal message I'd expect to see in this case. If there are no other error messages, then that's good.

    When you first installed and ran Blockly Prop Launcher, do you remember seeing a firewall blocking message from Windows, or perhaps your antivirus software or other firewall software you have installed? I have a feeling the problem you're experiencing is because your system is not allowing BlocklyProp Launcher to communicate with the browser - it's blocking such communications, thinking that Launcher is some kind of threat.

    Every firewall system is different, but you should be able to explore it and find settings for what it allowed or blocked. Look for the actual Launcher executable name in that listing. In may appears just as BPLauncher.exe or may be a full path like "C:\Program Files\Parallax Inc\BlocklyProp\BPLauncher.exe"

    Verify the the firewall software is allowing BPLauncer.exe to communicate vie Internet protocols.

  • I have windows Defender firewall. Its allowing access to BlocklyProp Launcher. Yesterday I uninstalled the launcher and reinstalled the launcher using Firefox. I was able to open files, however I was not able to run the opened files because no ports was displayed in the port box. Is Google Chrome the only Browser to use with the Launcher?

  • Chrome is the browser we definitely try to fully support; however, we also test against Firefox, Safari, and Brave. Occasionally we find issues on one or more that we have to resolve. I'm not sure what the current state of the app is for other than Chrome.

  • On Windows 10 systems, BlocklyProp Solo is supported in current versions of Chrome, Microsoft Edge, and Firefox.

  • @bluejay We have an experiment for you to try:

    • Close Launcher
    • Navigate to the solo.parallax.com site in your browser
    • Disconnect your network cable or disable your WiFi connection (for safety for the next step)
    • Turn off (or pause) your Windows Defender firewall
    • Open Launcher and see if Solo and Launcher connect
    • NOTE: You won't be able to compile and download in this configuration
    • Re-enable Windows Defender firewall
    • Reconnect network cable/WiFi

    This may help us safely determine if there's still communication being blocked.

  • Executed your instructions without success.

  • Thank you.

    Is it possible you have another firewall (or similar software) that could be blocking Launcher and Solo's attempts to talk to each other?

    Since we haven't been able to solve this, I've looked back at the posts you've done and noticed something I missed before... a "site disconnected" message from Launcher. That means that the site (Solo) must have connected prior to that.

    • Please run Solo on Chrome and Launcher (or Launcher then click BlocklyProp Solo button)
    • click the gear button in Launcher
    • click the Verbose Logging option (ideally before you start or browse to Solo)
    • Watch the log messages
    • Send us a screen capture of the log if possible

    Normally, it'd look something like this:

  • I cannot find anybody to solve my problem with my Parallax Flip, not even Ken Gracey himself which he was kind enough to make an attempt for a solution.
    Ken and an associate was doing a live video conference with my laptop without success.

  • @bluejay, can you post a screenshot of the Launcher verbose logging window? Ideally, you want to capture the events where you unplug the FliP module and then reconnect it again. The Launcher "should" show that it sees the new device. Another thing is are any of the LEDs illuminated or flicker briefly on the FliP when it is plugged in?

  • I cannot take a screen capture on the Launcher. When Istart the Launcher and click on the verbose logging window
    unplug and plug cord to Flip board and open verbose window the following message displays
    Path/Ip address: "local host"
    port 6009
    Verbose loggin: +site connected
    ->site requested port list
    <-sending port list (qty 0)
    user selected preferred port: com4
    site disconnected

  • I have noticed that every time I attempt to open my BlocklyProp files (including using Google Chome), I see that the files names has Microsoft Edge logo even when I try to open with Google Chome. I have uninstalled the launcher and re-installed with Google Chrome and still having problems opening files. I am able to create and run a file, but not able to open files. Perhaps there may be some permission issues.

  • I have seen this before on Windows systems. Project files in Solo have a .svg or .svge file extension. The issue I have run into is that this is exactly what the files look like when you use the File Explorer to list them and the File Explorer is set to hide the filename extension.

    For example, a project file would list as my_project.svg but the actual filename is my_project.svg.html. To get around this, open File explorer, select View from the main menu and then check the "File name extensions" checkbox. With that setting enabled, File manager will now display the full file name.

    The other way to explore this is to open a command prompt, navigate to the folder that contains your project files and then run a directory listing 'dir' to see what extension these file have. They should end with ".svg" or ".svge".

  • I used File Explorer to view files and checked file extensions and result is the files shows .svg extension.

  • I was able to open all my PropBlockly files with no problem before Solo was introduced.
    Is there anybody in the Parallax community that can solve the problem that I am having not being able to open .svg files?
    Is Google Chrome the only browser to use with Solo?
    Why is it that when I create a file using Google Chrome and save it and when I attempt to open it the file, the file(s) in the folders displays Microsoft Edge showing to the left of the file name even though I used Google Chrome to create it?

  • In order to establish another data point, try opening your files here:

    https://phil-pilgrim.github.io/solo/index.html

    I can't help you beyond offering this website, but your success or failure may provide the Blockly boffins a clue as to why you're having a problem.

    -Phil

  • VonSzarvasVonSzarvas Posts: 2,453
    edited 2021-08-17 00:10

    @bluejay said:
    Why is it that when I create a file using Google Chrome and save it and when I attempt to open it the file, the file(s) in the folders displays Microsoft Edge showing to the left of the file name even though I used Google Chrome to create it?

    Sounds like Windows could be configured with Microsoft Edge as the program of choice for .svg file types. That is something you could solve by right-clicking one of your .svg files, choosing "open-with", and then selecting Google Chrome AND also ticking the option to always use this program (ie. Chrome) to open these file types.

    To really solve things, would you will be willing to allow a Parallax engineer to connect remotely to your Windows session, and figure out the issue with you?

  • When Iwent to the site https://phil-pilgrim.github.io/solo/index.html I created a project and able to compile, however unable to run it because thr run box was greyed out and com 4 was displayed with message reading "no devices found. At least it shows file name but not able to save, run or open.
    About a month ago I had my laptop remotely connected with a Parallax Engineer and Ken Gracey without success. They gave up.

Sign In or Register to comment.