Shop Learn
Problem loading F32.hex — Parallax Forums

Problem loading F32.hex

I use CoolTerm for a terminal program for Tachyon at 115300 Baud. I have the distribution archive for Tachyon P1 v5v7. The kernel loads fine using PropLoader. CoolTerm loads EXTEND.FTH with no errors, then loads TV.hex and UART.hex. F32.hex does not load and I don't understand why. "SAVEROM" echos to the screen, then the hex dataloads with one or more lines of hex data (":hhhhxxxxxxx") filling the display lines. After the last line of hex data, things just sort of stop. With TV.hex or UART.hex, each input hex line appears on a separate screen line and the module is saved at the end (and appears in the "lsroms" list. F32.hex does not appear in the list. Any suggestions?


  • The best way to diagnose your problem would be to reproduce the effect you are observing.
    What P1 hardware (board) do you use ?
    Are you sure that what you are trying to load fits the board resources (EEPROM) ?
    Did you maintain exactly the order of the file loading you described above ?

    I'm away from my P1 board today so maybe I could check what's going on tomorrow but I can't promise that for sure.

  • I've tried this with both a QuickStart board and an Activity Board WX using the USB serial port. Both have the same amount of EEPROM. I used PropLoader to load the kernel and CoolTerm to load EXTEND.FTH, then TV.hex and UART.hex all of which worked. Finally, F32.hex failed.

  • fridafrida Posts: 151

    Check if F32.hex has windows line end.
    If not, save it with the windows line end.

    I do not remember now which I had problems with,
    but by saving with windows line end, it worked.

  • That was it frida. It had been saved with Linux (LF) line endings. Changing to Windows (CRLF) line endings fixed the problem. Thanks.

Sign In or Register to comment.