32420 / WX ESP8266 Wifi Module - Can no longer "see" it wirelessly.

I installed a 32420-SIP module onto a USB propellor project board (32810). Was able to connect via WiFi first time. Using SimpleIDE version 1.1.2, downloaded "val from micro host.c" successfully via wiFi and tried to test it. After trying once, was no longer able to see the WX ESP8266 wifi network. The ASC LED is OFF, the DO LED is blinking fast (about 2 Hz) and I cannot communicate to the WX ESP8266 at all. Tried resetting the module (4 resets w/in 2 secs) with no change and ASC LED stays off.
Looked at the DO line with O-scope, see what appears to be bursts of data being sent.

Any suggestions as to how I can recover this WX ESP8266 module?


  • This should probably be in the P1 thread...

    If it worked once, it may be a simple fix... Power cycling doesn't fix it?
  • Are you able to show how you've got the wx module connected to the project board?
  • My wx module experienced the same issue after being given 6v by a bad regulator.
  • The WX module is connected to the propellor board via DIP connector. WX pin DO to P26, WX pin DI to P27, wx RESET to Propellor RESET, wx PWR & GND connected to Propellor PWR & GND. No other WX pins connected.

    Power supplied is: +3.35VDC

    Thanks for responding!

  • VonSzarvasVonSzarvas Posts: 1,808
    edited 2019-08-31 - 19:05:39
    Before you mentioned SIP connector, and now DIP connector.

    I'm going to guess the problem...

    The reset pin on the WX module SIP connector is an INPUT, and is not the one you'd want to connect to your propeller reset pin, or the WX module will get reset every time you try to download something, breaking the connection in a never-ending loop!

    Try disconnecting that cable (wx RESET to Propellor RESET), and then use the reset button on the usb board to manually reset the propeller just before attempting to download code over wifi.

    If that works, then you know this was your problem!

    Once you know it's working manually, then you can still get automatic resets... It can be solved by connecting the Propeller reset to the SIP connector CTS pin instead, and then changing the setting in SimpleIDE to use CTS for reset (instead of DTR). (Hopefully SimpleIDE has that option- most of the loaders do).

    Just to be clear for anyone else reading this later... This all assumes you are working with the WX module that has the SIP connector on the end of the PCB (#32420-S). If you are instead using the dual-row DIP connectors that are on the bottom of the PCB (#32420-D), then a different solution would be needed!
  • Kanthony,
    I had a similar problem, and I eventually solved it. I attach some notes which you might find helpful;

    4. The ASC light should be flashing slowly for an IP (refer to API document). This can be reset by toggling, or by a SPIN program

    • The WX came up with an IP when I initially started it, and then somehow with my experimentation it slipped into a STA(no IP) mode with ASC led off.
    • I did not help matters by toggling the WX board RES pin 4 times in 2 secs – that is why the ASC light was wrongly flashing – as you point out.
    • In my defence, I read the API and it says ;
    • In a situation where there is no wireless connection (STA mode with no IP address) the module can be forced to turn on its AP (SoftAP) interface by toggling its RES pin low/high four times within two seconds.
    • However, I realised this API RES pin is not the RES pin on the WX board, but is actually the PGM pin on the WX board.
    • So I tried toggling the correct WX pin, but I could not reset the WX by grounding the WX PGM pin 4 times in 2 secs using a button (correctly shown in the BS2 learn schematic).
    • To do this toggling more precisely, I wrote a trivial SPIN program to do the toggling through Prop Pin via a 10K resistor to the WX PGM pin – much to my surprise it worked first time and now I have a slow blink STA(with IP) mode and I can continue. You may suggest to other users to do the toggling via a program if it does not work by grounding button.
    • If there is problem with no IP on startup, there may be an issue with the EEPROM Prop program interfering with the WX-connected pins. See the Learn tutorial.
  • Thanks again for the help. In response to using a DIP vs SIP device, my 32420 module is actually a DIP but with a SIP header installed. I'm using the SIP pinouts rather than the DIP pinouts. Also, I was incorrectly using the RST pin to try to reset the device, so I changed to the PGM pin and also used test propellor code to generate the required 4 pulses within 2 seconds on the PGM line, but see no change from the 32420 module (Status = ASC LED OFF, DO LED rapidly blinking). At this point, I've ordered a new 32420 SIP wifi module, and also a Propellor Activity Board WX (#32912) so I can re-test the 32420 module configured as a DIP module.
    At this point I'm going to wait for the new HW and start over.
    Many thanks for your assistance! It was greatly appreciated.
  • DO LED rapidly blinking....
    could be the module is stuck in recovery mode.

    Let us know how you get on with the new hardware. If all is well, it could be worth a try to recover the old module... there's some pdf instructions in the forum somewhere that I created a couple years ago and will still work fine with the modules. Just need some time to hunt for it !

    For now, glad you have some progress and a plan figured out. Good news!
Sign In or Register to comment.