Shop OBEX P1 Docs P2 Docs Learn Events
simple ide question wifi semi solved with a new queston based on the fix. SOLVED — Parallax Forums

simple ide question wifi semi solved with a new queston based on the fix. SOLVED

pilot0315pilot0315 Posts: 858
edited 2024-06-25 05:50 in Propeller 1

Trying something else before sending the question through.

That idea did not work.
So I am back again with the question. Simple ide does not see the prop via wifi.
Using wifi.start routine does not work.
The connect file is directly from the learn files.
Any ideas any one please.
@VonSzarvas

Tried your suggestion. Cannot get into simple ide to change anything.
Thanks.
Martin

«1

Comments

  • In the wifi gui settings, is the reset pin correct?

    Probably dtr with dip module, cts with sip module?

  • @VonSzarvas
    Cannot find a way to get into the gui settings in simple ide.
    Do you have experience with it?

  • @pilot0315 said:
    @VonSzarvas
    Cannot find a way to get into the gui settings in simple ide.
    Do you have experience with it?

    You had it in the "correct address.jpg" screenshot. Open that webpage, the click settings.

  • I will look. Thanks.
    BTW where in the world are you. I am in northen Arizona having a sleepless night. I know we forum folks are around the world.
    Just curious as to your basic location.
    Thanks.
    Martin

  • @pilot0315 said:
    I will look. Thanks.
    BTW where in the world are you. I am in northen Arizona having a sleepless night. I know we forum folks are around the world.
    Just curious as to your basic location.
    Thanks.
    Martin

    I’m in Europe; Hungary to be more precise :)

  • Question solved but leaves a new question.

    @VonSzarvas

    Kool!!

    Thanks for telling me.

    I got it to work but it was by accident.

    I have installed the wx card on the activity board wx without the connections:

    https://learn.parallax.com/tutorials/language/propeller-c/parallax-wx-wi-fi-module-prop-c/connect-wx-wi-fi-module-your

    Works great via wifi. No issues and the wifi card puts out a strong steady signal that I can link to.

    That raises a question. What is going on that it works good this way and not the way in the instructions. I will further test and see if I can come up with an answer.

    Thanks for your assistance.

    Fun to communicate with someone on the other side of the planet.

    Will chat soon.

    Martin

  • Super!

    For those connections- I believe they were relevant to the earlier versions of the Activity Board.

    The newer rev ( B or C onwards I think- identified with the WX logo), have the WiFi module connections built into the PCB, so those jumpers are not required. I guess that's what you have.

    To know which channel is being used for programming, you will see two blue LEDs that mark the channel selection; one is near the USB port, and the other near the WiFi connector. Depending on which serial channel is active, the appropriate LED will be lit. The channel selection is supposed to be automatic, but you can also override it by adding a jumper wire from the SEL socket (just to the right of the Propeller chip), and link that direct to GND or 3V3. I forget the order, but basically one forces USB-Serial mode, the other forces WiFi mode. Sometimes if you are using both USB and WiFi it can be handy to chose the channel yourself. That SEL pin could also be linked to an IO, so you can change the Serial channel in your code- Groovy!

  • @VonSzarvas

    I have not heard the term "GROOVY" in ages. You are making me feel old. 68. I remember those years.
    I will investigate further. Machined custom parts for this robot. Almost done.
    Thanks.
    Martin




  • Wow, looks like you'll need another one of those; start a drag racing competition!
    Love it!

  • @VonSzarvas

    Lots of fun. More stuff to add and change.

    Looks like my wifi modules may be nfg as well as a couple of wx boards. New stuff on the way. Will let you know.
    Again thanks for the help.
    Martin

  • @VonSzarvas
    @"Jeff Martin"

    O.K. with y'alls help I got to join another network. Followed the instructions and got the new address. After reboot. I cannot get the browser to connect via the new address.
    LED'S:
    wx activity green
    DI red
    Assoc blinking blue
    VIN green.
    Cannot start over.
    No changes can be made vial SimpleIde, unless, there is a hidden method. I cannot
    find any way to make changes.
    Attempting, what ever works, to reset the module to zero and start over.
    Cannot get browser access so as to restart with the firmware to attempt an update
    so as to start from scratch.
    Scratching my head with the hair that I still have at age 68. Trying to keep what hair I still have.
    :D:#
    This is a PIA.
    Sorry Jeff, y'all did not put in any instructions for trouble shooting. Searching
    for that on the web and the parallax website as well as in the forums.

    Friendly suggestion.

    I know Parallax is busy. But the company needs to make sure that they
    put in for many of the products or user interfaces "TROUBLE SHOOTING FOR DUMMIES LIKE ME"
    :) for Dummies like me. It would really help.
    Thanks in advance.
    I am going throught the documents and find no trouble shooting or back door methodes to get
    into the module.

  • @VonSzarvas
    @"Jeff Martin"

    Had the device jumped via ahte 10 K resistor to 3.3
    That allowed the module to broadcast and then went through the connect to another network.
    Just now changed that to ground. Now able to see the module.
    DAQ, is the regular way to reset to zero the module?
    I am going to try to reinstall the firmware.
    Am I headed down the right track?
    Also is it really just putting in the new address via the browser to connect?
    Also are there any simple for dummies tricks to get backdoor access to the module when it
    is connected to the other network?
    Also, :/:) Is there a more detailed set of instructions?

    Thanks again in advance.
    Martin

  • iseriesiseries Posts: 1,475

    Wow, I use these modules all the time and they work great.

    Don't bother reinstalling the firmware as this does not erase the configuration.

    I found the two manuals very informative and tells you what's going on. I will say that I don't use the module with an Activity Board.

    (6) ASC “Associate” LED
    In the description, bold is the wireless mode, small text indicates connectivity or lack thereof,
    and after hyphen (-) indicates LED behavior and the timing.
    ● AP (has IP address) [Wirelessly accessible]* - ON constantly
    ● STA+AP (no IP on STA, IP on AP) [Wirelessly accessible]* - OFF 2000 ms, ON 2000
    ms
    ● STA+AP (has IP on STA and AP) [Wirelessly accessible]* - OFF 2000 ms, ON 25 ms,
    OFF 150 ms, ON 2000 ms
    ● STA (has IP address) [Wirelessly accessible] - OFF 4000 ms, ON 25 ms
    ● STA (no IP address) [Not wirelessly accessible] - OFF constantly
    

    Until you get the module connected to your home network simpleIDE will not see it.

    Once it connects to your home network any device on your home network will be able to talk to it.

    Mike

  • I don't understand the 10K resistor to 3.3v. Do you mean you were powering it that way? Do you mean you had SEL connected to 3.3v through a 10K on the Propeller Activity Board WX? Either way, it should be a direct wire, no resistor.

    To recover the WiFi Module from whatever "lost" network state it may be in, you can press and release the Reset (RST) button (on the Propeller Activity Board WX) four times rapidly (all 4 presses/releases in about 1.5 to 2 seconds, if I remember right). The same can be done with the module if it's not in the (Propeller Activity Board WX) by grounding/releasing the /PGM pin four times (which is exactly what the Reset button does).

    This action resets the module back to AP mode, where it disconnects from any network it may have been associated with and turns into it's own access point, sitting at IP address: 192.168.4.1. You can then use a wireless device (like a smartphone, laptop, etc.) that to connect to that AP directly (via your device's WiFi settings) and then open a browser to http://192.168.4.1 and reconfigure whatever network settings you want.

    The manual talks about this on page 6 in the Configuration Pages section:

    "Later, if you have configured your Wi-Fi module to reside on another network, you can make it
    reappear as an access point by rapidly grounding and releasing the /PGM pin four times. If your
    Wi-Fi module is in an Activity Board WX, this can be done by pressing and releasing the RST
    button rapidly, four times. In a breadboard, a pushbutton with one terminal connected to GND
    and the other to /PGM is convenient.

    After your device (computer, phone, or tablet) has joined the Wi-Fi module’s network, you can
    go to its Configuration home page by navigating to http://192.168.4.1."

    One other thing to consider if you've successfully configured the Wi-Fi Module to connect to another network but once there you're not able to contact it from any device on that network- it could be that the network's Wi-Fi Access Point is configured in "isolation mode." It's called different things in different Wi-Fi Access Points, but this isolation mode is usually used to give individual wireless devices access to the Internet through that network but prevents the local devices from seeing each other. This mode is often used on properly-configured public Wi-Fi systems to prevent malicious activity between devices. The Wi-Fi Module, of course, needs to be able to speak with other devices on the network, so it's not compatible on networks using isolation mode, and software like SimpleIDE uses a broadcast message to discover Wi-Fi Modules on the local subnet... the isolation mode will prevent that communication.

  • pilot0315pilot0315 Posts: 858
    edited 2024-06-21 07:23

    @"Jeff Martin"
    @iseries

    Y'all will like this.

    Well I tried my number two module again with the sel to 3.3 connection. Number 1 fails. Number 2 connects momentarily then drops out within less than a minute. The browser that opened gets suddenly after appearing with the Parallax logo gets redirected to this website:
    https://www.msn.com/

    Vraiment Different. Je ne comprend pas.
    I have no clue. This appeared last night and I shrugged it off. My cell phone says that the node is brodcasting " wx-f9ea4d.
    Cell phone connects with 4 bars saying connected without internet/not secured. Computer running windows 11 pro will not see it or connect after the first two attempts. I never to to msn.com for any reason and my browser history is always cleared on closing.
    Cnn I could see, Parallax.com I could see but not msn.com.
    Option 1:
    sel to 3.3 connection
    module wx green light on assoc blinking vin green

    Option 2:
    sel to pin 7 to 10 to ground in and quickly out as above paragraph.
    ony assoc blinking , wx is out.
    Cell phone saw it for lexx than a minute.
    Computer connects then the module drops out.
    No redirect to msn.com
    As with above push reset x 4 in < 2 sec no changes.
    change sel to 3.3 wx on, assoc blinks cellphone sees the module for

    Option 3:
    do to 9, di to 8 sel to gnd.
    Assoc light blinks, others dark, reset button cycled x 5 no changes.

    change sel to 3.3, do and sel no change:

    wx is green assoc blinks cell phone sees wx-f9ea4d,
    atttempt to connect computer:
    Connects drops out < 1 min.
    recycle reset wx green assoc blinks occaisional di red blink.
    seen by cellphone and connects.

    Computor connects x 1 for < 1 min, disconnects Cellphone stays connected computer now says unable to connect.
    Tried 3 times,

    AND GAVE UP. I NEED WHAT EVER HAIR I HAVE LEFT OVER AT 68.

    These are the instructions from the tutorial.
    Now I am confused. I have tried to get the module to work. Sometimes and I mean sometimes it will conntect. I can get the browser to open the web page the the module drops out and my computer connects back to my wifi connection.
    I do not understand why.
    Thanks in advance.
    Martin



  • I think the surprise loading of MSN.com is a built-in behavior of the Edge (and IE?) browser if the Internet connection resets (Wi-Fi Module drops out and your computer automatically re-associates to your other known access point) and perhaps only if the IP address-based site it was trying to reach is no longer reachable.

    Now I understand what you were talking about with the 10K resistor... I'm not familiar with those tutorials. All the options except what you label as Option 1, which corresponds to "All Communication Through WX Wi-Fi Module" are things I wouldn't recommend trying unless you can first successfully maintain a connection through Option 1 (SEL wired to 3.3v). Those other options are more advanced uses, and one of them is actively affected by the P7 pin if the P1 chip is running code that adjusts it.

    The module dropping out is odd. Do you notice LED changes when that happens? Assuming you have the passphrase for your trusty Internet-connected access point, you might be best off by telling your computer (and/or phone) to "forget" your Internet-connected access point so that it doesn't automatically switch away from with Wi-Fi Module's AP the moment it drops... but rather your computer/phone will try to re-connect when the Wi-Fi Module's AP reappears.

    I'm wondering if there is something wrong with your Wi-Fi Module or it's power connections. If you have an oscilloscope, it'd be good to probe around a bit (on power and also /PGM pins, for example) when the module starts up and ends up dropping out again.

  • @"Jeff Martin"
    @iseries

    I am using Waterfox/Firefox. I understand the Edge/I.E issues. Not sure where MSN.com comes from.
    Will use the Oscilloscope and probe. Should be getting new boards and modules today. Will do a slow analysis and compare the new to the
    old and see what I get. I am not going to try to link to the main wifi until I am sure what is going on.
    Thanks to both of you for your help. Wonderful learning process.
    Martin

  • pilot0315pilot0315 Posts: 858
    edited 2024-06-22 08:56

    @"Jeff Martin"
    @iseries
    @VonSzarvas

    Thank you guys.

    Attempted with new WX board and WIFI module.
    Still getting drop outs.
    Tried the sel to 3.3 to power it.
    When it does come on My computer is intermittant when seeing it.
    My cell phone sees it and can connect. Every thing is set for unmetered.
    Interesting, as I was throwing the kitchen sink to this problem I found that
    this:

    The wx board shows up on the bluetooth list.
    ???Why here I do not know. ????

    The only option under bluetooth is to remove the item.

    Went through anything I can find. Added the network name to the list in windows 11 and still cannot
    connect even if the device is not broadcasting.
    When broadcasting still cannot connect.
    Also when rebooting the computer same issue. Reboot wifi device sees the module, attempts to connect, new
    browser window appears then the module drops out and it goes back to my internet wifi.
    This happens within seconds.
    Wow this is a real pain.
    Thanks in advance to anyone who can help.
    Martin
    Also thanks to those who are already helping.

  • RsadeikaRsadeika Posts: 3,837

    "Attempted with new WX board and WIFI module.
    Still getting drop outs."
    Could you explain more about "drop outs".
    I have been using a WX board and WX WiFi for a while now, and the the problem that I have is with my router WiFi. I am still trying to zoom in on the problem.

    Ray

  • pilot0315pilot0315 Posts: 858
    edited 2024-06-23 07:08

    @Rsadeika

    Dropouts:

    The module, I have four and trying with three and swapping wx boards. Two new wx boards.
    The module will occasionally continue to broadcast and I can connect via cellphone and PC.
    After about 15 sec the module goes off line. Attempts to reconnect are to no avail.
    Settings for the module are "sel to 3.3v".
    Rarely will any of the modules restart and broadcast.
    Any ideas will be greatly appreciated.
    Scanning the internet looking for a remidy of the issue.

    Tried all of @"Jeff Martin" 's suggestions no joy on the target.

    Still tried it again. Old module labeled #1 blue light assoc blinks, wx led on. Broadcasted wifi, connect with pc, begins then the signal is lost and pc reverts back to my secured network, then the window that was opened by the wifi module now gets redirected to msn.com:

    I am running waterfox:

    Wow this is really interesting.

    Martin

  • iseriesiseries Posts: 1,475

    Here is my setup for testing. I left the SEL pin unconnected, but you can also ground it to set it to USB mode.
    Activity
    You don't need to have it set to WiFi to use it as a wifi module. The select pin just sets it up so you can program it from SimpleIDE.

    I have DO (blue wire) connected to pin 0 and DI (white wire) connected to pin 1.

    Test program:

    /**
     * @brief Description of Project Here
     * @author 
     * @date Month Day, Year
     * @version 1.0
     * 
    */
    
    #include "simpletools.h"
    #include "fdserial.h"
    
    void doit(char *);
    
    
    #define PIN1 26
    #define PIN2 27
    #define DO 0
    #define DI 1
    
    fdserial *fd;
    char Buffer[1024];
    int i;
    
    
    int main()
    {
      print("Starting...\n");
    
      fd =  fdserial_open(DO,DI,FDSERIAL_MODE_NONE, 115200);
    
      doit("module-name");
    
      doit("wifi-mode");
    
      doit("wifi-ssid");
    
      while(1)
      {
        high(PIN1);
        low(PIN2);
        pause(1000);
        low(PIN1);
        high(PIN2);
        pause(1000);    
      }  
    }
    
    void doit(char *data)
    {
      int i;
    
      dprint(fd, "%cCHECK:%s\r", 0xfe, data);
      pause(1000);
      i = fdserial_rxCount(fd);
      print("Count: %d\n", i);
      readStr(fd, Buffer, 256);
      print(Buffer);
      print("\n");
    }
    

    Output from test program:
    TestWX

    Mike

  • RsadeikaRsadeika Posts: 3,837

    In my particular case, when I have a "drop-out", I have to ping the WX WiFi to bring it back to life. Still have not found a solution for this ailment.

    Ray

  • iseriesiseries Posts: 1,475

    @Rsadeika ,

    A dropout accurses when the WiFi Router loses connection with the WiFi module. In this case a ping should not work but return timed out.

    I had an application that used a display module that generated a lot of RF interference and would cause the WiFi module to disconnect from the network.

    To test this, I used a continues ping command and brought the WiFi module closer to the display until it slowly stopped responding. I have since used a newer version of that display and the manufacturer has fixed that issue.

    C:\>ping 101.1.1.12
    
    Pinging 101.1.1.12 with 32 bytes of data:
    Reply from 101.1.1.12: bytes=32 time=1324ms TTL=255
    Reply from 101.1.1.12: bytes=32 time=2ms TTL=255
    Reply from 101.1.1.12: bytes=32 time=220ms TTL=255
    Reply from 101.1.1.12: bytes=32 time=116ms TTL=255
    
    Ping statistics for 101.1.1.12:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 2ms, Maximum = 1324ms, Average = 415ms
    

    The ESP8266 as designed to reconnect to the network in case of a disconnect. Actually, under the covers it only sends a packet once in a while to see if it's still there. It's not a continues radio connection as one might think.

    If the unit shuts down after a while it would be caused by the module being put into sleep mode or have a sleep timer programmed in.

    I have units connected to my network 365 days a year and they send out a packed of data every minute. They run for months at a time only to be disconnected because of a power outage.

    Mike

  • RsadeikaRsadeika Posts: 3,837

    Not sure if this will be helping pilot0315. My setup is a router and maybe 20 feet from the router I have a range extender for the router. In fact I have two range extenders at opposite sides. So maybe my drop-outs are caused by the range extender connection. But I have other WiFi devices that are connected to the extenders and they do not seem to be experiencing a drop-out, at least I have not encountered one just yet.

    Ray

  • pilot0315pilot0315 Posts: 858
    edited 2024-06-25 05:50

    @"Jeff Martin"
    @Rsadeika
    @iseries

    Question of the day.

    If one is looking at the tutorial:
    "Connect WX Wi-Fi Module to your propeller"

    https://learn.parallax.com/tutorials/language/propeller-c/parallax-wx-wi-fi-module-prop-c/connect-wx-wi-fi-module-your

    "Join the Module's Wi=Fi"

    https://learn.parallax.com/tutorials/language/propeller-c/parallax-wx-wi-fi-module-prop-c/join-module’s-wi-fi

    and then:

    "Update the module Firmware"

    https://learn.parallax.com/tutorials/language/propeller-c/parallax-wx-wi-fi-module-prop-c/update-module-firmware

    and finally:

    The module datasheet: (at Mouser)

    https://www.digikey.com/htmldatasheets/production/2066534/0/0/1/wx-esp8266-wi-fi-module-product-guide.html

    Nothing tells me anything about what the lights are really telling me. I get WX green sometimes blue lights some red lights.
    Rapid blue followed by slow blue so I am confused. My oscilloscope from what I can see does not tell me anything useful.
    I do not have equipment to "listen" to the module. I get periodic and I mean periodic notices from my network and internet wi-fi, on windows 11 pro
    on an intel (R) wi-fi 6e ax211 160 Mhz drivers (current) 22.250.0.4 that the module is broadcasting but I cannot get the connection to work.
    System tells me that it cannot connect to this unit.

    I am lost.

    I have tried 3 modules on 5 different WX boards one of which was delivered last Friday with two new modules. Have tried one of the modules on all boards. Tried the other two on all boards. Getting different led blinks and some not blinking even though WX green is on.
    Using SEL to 3.3. The other settings are blank.

    Thanks ahead of time for your time and expertise.
    Martin

    P.S. I am not a radio guy so I am basically clueless. I understand how radio works but this is above my pay grade for now.

  • iseriesiseries Posts: 1,475

    The product guide you referenced above tells you exactly what each of the LEDs is for. I reference item 6 above as well.

    The fact you are seeing blinking blue LED is a sign that the board is working as designed.

    Mike

  • pilot0315pilot0315 Posts: 858
    edited 2024-06-25 05:57

    @"Jeff Martin"
    @Rsadeika
    @iseries

    Thank you all for the help.
    I went through every thing systematically on a checklist. All the way to checking on the router and seeing how it was
    behaving.
    All good.
    Went all the way to the power supply. One never knows. Well the power supply metered out on my Simpson and my digital machines and appeared to be outputting only around 6 volts. Rummaged around and found my box of extra wall worts and swapped it out after comparing voltages. Well 12 volts was not 12 volts. Swapped in a different unit. Well lookie there that was the culprit. After an hour of testing three modules all is better. I also was able to isolate the module where I made it "join another network" That I am having problems with but, since, the module is working and none of the modules are now dropping out, I will save that for later. Thank you @"Jeff Martin" for the suggerstion to stay away from that stuff until all is good on the western and eastern fronts. Cannot fight a bicoastal war so to speak.
    Again thanks to all for the help and your patience.
    As I am embarassed to say I should have seen this.
    Martin

  • I'm so glad you found the culprit! Pesky power supply issue. Yes, that will do it; makes sense.

    When the module goes to transmit, it pulls more current from the supply than it does at any other time, and at that moment the weak supply was probably unable to fully deliver, and dropped it's voltage output to the point it finally dipped below the practical operating limit of the PAB WX and/or the WiFi Module itself. Note also that it could have been bordering on a brownout voltage level and didn't fully shut the module down, but left it in a strange state where it wasn't able to properly function thereafter until reset.

    Mystery solved.

  • @"Jeff Martin"

    A learning experience. Quite an experience.
    While I was going through this I noticed something and I have a suggestion for the next rev of the WX board:

    When your folks designed the WX boards and the like, the female power connection is really close to a board mounting hole.
    I do not think anyone expected to go to a second story with the frames you have. As you can see that a stand off requires one to bend
    the male cable out of the way. I ordered 90 degree male connections and am going to use this type as am going to use a second story and need
    the room for my project.
    Suggestion is that on the next revision maybe move the female connector to accomodate the straight cable or maybe even change or give the option
    for 90 degree male ends. That leaves quite a lot of room as you will see in the photos.
    Male ends are 1 inch long, 90 degree protrude out slightly less than 1/2 inch.
    I figured this out as I am not only adding a nother level but will have a second female terminal with a single throw double pole switch so as to swap between
    internal power and external power for programming and other tasks.
    Thanks as always for your help.

    Martin

  • Very good point, Martin. Thank you. I'll be sure to remind us for that and future board designs as well.

Sign In or Register to comment.