Shop OBEX P1 Docs P2 Docs Learn Events
No Propeller found on com3... — Parallax Forums

No Propeller found on com3...

Hi guys, I know this is a noob question. I found a Propeller proto board.
Downloaded Spin 2.9.3. Installed in on Win10-11x ? something (never sure about the billyware versioning).
Tried a bunch of voltage settings. Always can see the red-green flash on the board when trying to id the Propellor (F7). Using a new USB cable, slowed the device driver baud rate to 19200 and set the latency timer from 16 to 8 then to 1. Using FTDI 2.12.36.4 (7/5/2021).
Also see in the windows event log for the driver load (when board is connected to USB)...
Driver Management has concluded the process to add Service Serenum for Device Instance ID FTDIBUS\VID_0403+PID_6001+A8007DUHA\0000 with the following status: 0.

Looks like everthing is working, not sure what Propeller chip is on the proto board. (seems like a 1).

Any ideas?

Comments

  • RaymanRayman Posts: 14,156

    Is it this one?
    https://www.parallax.com/product/propeller-project-board-usb/

    The flashing LEDs is a good sign that it's working a little bit...

  • RaymanRayman Posts: 14,156

    Somebody once gave this advice:
    From the Propeller Tool:

    Try:

    • preferences

    • edit ports

    • restore defaults

  • Hi Rayman,
    Thanks for taking a pass over this.
    First answer, no, Proto board is close, close by a different rev.
    Second, ya, looked at (what I think is) all the easy stuff.

    Some new info though, I shot a couple of messages off to support on Friday but on my own, got the below...

    I think there's some in-between issue with the IDE software (Propeller and simpleIDE) with their respective compilers and the board version. I cant find where propeller 2.9.2 is getting its gcc. no idea what template files 1&2 are.
    I also found a basic stamp (see pic). hardware does not ID on either IDE. "Clearly marked as basic stamp homework board"

    From propeller tool 2.93 the board recognizes as Propeller 1 Rev A on com3.
    Even if I edit ports (both 3 and 4 show up) and the editor can move their search order, the IDE only finds a device on 3, reports the same.

    Using simpleIDE v 1.1.2
    Opens search for ports, welcome shows, reports both com3 and 4, but defaults to 4.

    F8 does its think, console appears, no data. on com4 (see debug below)

    On com3, it works.

    ===== Debug ====
    Project Directory: D:/_downloads/spin/simpleIDE/workspace/SimpleIDE/My Projects/

    SimpleIDE Version 1.1.2
    D:/_downloads/spin/simpleIDE/workspace/SimpleIDE/Learn/Simple Libraries/
    D:/_downloads/spin/simpleIDE/workspace/SimpleIDE/ Updated on: 2024-07-12

    propeller-elf-gcc.exe -v GCC 4.6.1 (propellergcc_v1_0_0_2408)
    propeller-elf-gcc.exe -I . -L . -I D:/_downloads/spin/simpleIDE/workspace/SimpleIDE/Learn/Simple Libraries/Utility/libsimpletools -L D:/_downloads/spin/simpleIDE/workspace/SimpleIDE/Learn/Simple Libraries/Utility/libsimpletools/cmm/ -I D:/_downloads/spin/simpleIDE/workspace/SimpleIDE/Learn/Simple Libraries/TextDevices/libsimpletext -L D:/_downloads/spin/simpleIDE/workspace/SimpleIDE/Learn/Simple Libraries/TextDevices/libsimpletext/cmm/ -I D:/_downloads/spin/simpleIDE/workspace/SimpleIDE/Learn/Simple Libraries/Protocol/libsimplei2c -L D:/_downloads/spin/simpleIDE/workspace/SimpleIDE/Learn/Simple Libraries/Protocol/libsimplei2c/cmm/ -o Welcome.elf -Os -mcmm -m32bit-doubles -fno-exceptions -std=c99 Welcome.c -lm -lsimpletools -lsimpletext -lsimplei2c -lm -lsimpletools -lsimpletext -lm -lsimpletools -lm
    propeller-load -s Welcome.elf
    propeller-elf-objdump -h Welcome.elf
    Done. Build Succeeded!

    proploader.exe -r -I C:/Program Files (x86)/SimpleIDE/bin/../propeller-gcc/propeller-load/ -b activityboard -p COM4 Welcome.elf
    Opening file 'Welcome.elf'
    ERROR: Propeller not found on COM4
    ERROR: Download failed: -1

    Opening file 'Welcome.elf'
    ERROR: Propeller not found on COM4
    ERROR: Download failed: -1

    ==== END Debug

    Not sure what to do from here. LIke the IDE's, but not if they cant figure out the target hardware.

    Thanks again for looking. Hope the weekend is good for you. I

    Mark

    1440 x 1920 - 962K
    763 x 421 - 30K
  • Rayman, I just noticed something else...
    Running just simpleIDE on com3 only works s3 times, (f8).
    After that, resetting the port, clearing the com window, running again,
    download looks like everything is working, but the download fails persistently after that.
    Tried using the FTDI driver utils to reset the port. No Joy.

    (64b win11 laptop). FYI.
    Mark

Sign In or Register to comment.