Shop OBEX P1 Docs P2 Docs Learn Events
Trouble with XOJO baud rate — Parallax Forums

Trouble with XOJO baud rate

I often use code written in XOJO to get and display telemetry on a Laptop from my Propeller projects.
This has been occurring at 115200 baud using FullDuplexSerial. No problems.

But today I tried to get XOJO and the Propeller to use 57600. Nothing but errors from XOJO. Seem to be frame errors, but hard to tell. So I tried all the other standard bauds. Nothing. It only works at 115200.

This seems weird. I've check all the settings I can think of for both XOJO and the Propeller.

Can someone think of a reason this might happen?


  • I've only worked with Xojo a bit, but it was at 57600 for coms with an XBee radio. Can you try a generic terminal (even PST) to verify that the Propeller is communicating at 57600?

  • Thanks for the hint. Yes, I did try it with PST at all bauds. Only 115200 work. I've got something crossed up somewhere, but it is not on XOJO's side.


  • Solved.

    I had a watchdog that was rebooting the propeller, but since I was not loading the EEPROM every time, my changes were not registering once the ram was wiped out by the reboot.

    All sorted out.


Sign In or Register to comment.