Shop OBEX P1 Docs P2 Docs Learn Events
SOLVED: My odd connectivity problem... — Parallax Forums

SOLVED: My odd connectivity problem...

TommieBoyTommieBoy Posts: 26
edited 2023-04-24 22:06 in Propeller 1

I've been using an Activity Board WX with a wifi module for a couple of months now, and I love it.
One of my favorite things is that I can program the WX without physically connecting to my PC. I can leave the WX in the kitchen, testing away, while I access it from the 'lab' for the occasional adjustment.

Today, I am faced with a new issue and it has me scratching my head.

I wanted to tweak my program on the WX. When I went to upload it, SimpleIDE couldn't find the address to upload to. Odd. That's never been an issue.

  • I reset the port in SimpleIDE. No change.
  • On spec, I reset my modem and my wifi router. No change.
  • I can access the page from my iPhone and the page is updating normally.
  • My wifi router sees both my PC and the WX.
  • My PC has full internet access via wifi and a speed test shows I have a fast connection.
    - I tried to ping the address from my PC. No joy, yet I can ping from my iPhone.

Any help on what to investigate would be appreciated.



  • I'm not a networking guy, so this may cause some laughs, but did your router assign a new IP to the WX that may not be known to Propeller Tool?

  • No, I checked that too. Both the phone and the PC have 'remembered' the same IP address. Both devices have historically connected without issue.

    I have a mesh system with two nodes, and previously, while troubleshooting through the mesh app, I had restarted the network. The result was 2 more devices became 'visible' on the network but none that were of interest to my problem. (A wifi speaker and a printer.) My WX connectivity problem persisted.

    Later I wanted to watch some TV. (Go Oilers!) The TV is hardwired to one of the mesh nodes, and I couldn't boot the TV's app that I wanted to use. The mesh app said the node was working but I did a hard reset of the node and bingo! I watched the Oilers win a squeaker, and I was able to upload my tweaks.

    I guess the moral of the story is, don't rely on a soft reset to solve every network problem. Sometimes you still need to pull the plug!

  • Good news. You may want to add "[SOLVED]" to the thread title -- you can do that by editing the first post.

Sign In or Register to comment.