Shop OBEX P1 Docs P2 Docs Learn Events
PropScope — Parallax Forums

PropScope

Prop scope requires Microstoft.net framework v2.0
I am now running windows 11 pro.
I cannot find it for win11
Is there a work around.
Thanks in advance.
Martin

Comments

  • You should be able to download 2.0 framework as installer, else install Visual Studio Community Edition, it is free. 2019 from it you can install all frameworks and 2. is still supported.

    Mike

  • @msrobots

    Sorry did not see your post until now. Thanks I will look into it. Does it work with windows 11 pro???

  • @msrobots
    I looked up the rfc 2119 kool stuff. Reminded me of the time when I programmed on the IBM 1130 and 360 systems back in the Jurassic era.

  • @pilot0315 were you able to get the PropScope running on Win 11? I found and installed .Net2.0 for 10 without any issues, but the v207 software does not "see" the scope. I suspect it has to do with 64 vs 32 bitness, but I was not able to get it working in a 32bit XP virtual machine either.

  • pilot0315pilot0315 Posts: 864
    edited 2023-06-02 00:16

    I was unable to get it to work. The unfortunate part is that the person who wrote the code,
    1. Is hard to get a hold of as he is off shore.
    2. He has not supported the product for several years.
    3. And of course he needs to be paid to update.

    I wonder if we could shmooze someone in the forums to do an update. The firmware is out of my expertise. I would like to see the code. Do you know how to download the actual code?
    Maybe we could ask some questions in the forums about modifications.
    Thanks.
    Martin.
    @msrobots
    Sorry to bother you but do you have any ideas on this topic.
    Thanks in advance.
    Martin

  • msrobotsmsrobots Posts: 3,709
    edited 2023-06-02 05:28

    As far as I know Hanno never published the source.

    There is/was a schematic and somewhere in the deeps of this forum was a project of someone writing something for linux, but it never got finished.

    You might try running the software in compability mode in W11, maybe even select Windows7 not W10.

    I solved the problem via BANGOOD and got myself another Scope.

    Mike

  • @msrobots
    @djrosen

    I may have it working under windows 11 I will let you know.
    Martin

  • @pilot0315, I got it working with an old Windows 7 box without the DAC, so I tried the same with my WIndows 10 64bit, and v207 of the software found it immediately. I ran a couple of waveforms from my cheapo waveform generator and all the values match, so the oscilloscope appears to be good to go. The problem was that I wanted a better waveform gen. and that is provided on the DAC. I would very much like to hear if you got them to work together. The Linux version is on GitHub: https://github.com/rbehm-ibb/PropScope, but only uses a single cog and has not had a commit in years.

  • rbehmrbehm Posts: 102
    edited 2023-06-07 05:19

    @djrosen said:
    The Linux version is on GitHub: https://github.com/rbehm-ibb/PropScope, but only uses a single cog and has not had a commit in years.

    I'm still using it, as it fulfills my needs. I was just too busy to update anything

  • @djrosen
    @rbehm
    @msrobots

    For some reason now W 11 PRo now likes the scope. Tested it this morning
    getting wave forms.
    Checked the forms with my Fluke 3082 and the look the same.
    I do not know what happened but I suspect microft. Did not have to do the compatability
    check.
    We will see.
    Nice chatting with you.
    Martin

Sign In or Register to comment.