Shop Learn P1 Docs P2 Docs Events
propeller tool v2.9.2 error — Parallax Forums

propeller tool v2.9.2 error

@"Ken Gracey"

I am using windows 10 pro.
Every time I try to up grade to the newest version I get an error regarding parallax.ttf font.
It appears that has been an old bug.
https://forums.parallax.com/discussion/173189/parallax-font

Like other posts I searched my computer for this parallax.ttf file and cannot find it.
Forgot how I got around it.
According to the prop tool that I am using it is 2.9.2 is this a _**NEW **_2.9.2/
Y'all got me confused.
Thanks in advance.
Martin

706 x 489 - 25K
543 x 363 - 37K

Comments

  • Jeff MartinJeff Martin Posts: 746
    edited 2023-01-12 21:59

    I've seen this happen on occasion also. I tried to make the installer not bother to replace the file if there were no changes, but it seems to try anyway.

    The problem is caused by a font file removal error in the OS. The file itself, Parallax.ttf, is in the C:\Windows\Fonts\ folder... but that's a "special" folder where font files are placed AND need to be "registered" with the system. In Windows Explorer, both processes (of copying the file and registering it) happen automatically. When a font is being replaced or removed, there are two steps as well, 1) deregistering the original, and 2) deleting the original file (followed by the installation steps for the new file). Sometimes the system successfully does #1 but fails #2... leaving the file "invisible" to Windows explorer and not available to applications; however, if you open a command window and explore the folder, the file still remains.

    If you can not delete the file through the command window, there's a permission problem or the OS has the file held in some open state, and you'll have to reboot the computer and try again through the command window. After that, the Propeller Tool software will install that file correctly.

  • This happened to me earlier. I should have opened Process Explorer to see what had the filehandle open. I may try to reproduce this, as I know it has been a pain for some people. I was able to get past it by ignoring it. The font was all messed up when proptool opened. I ran the installer again, got no error and it looked correctly the 2nd time.

    I will see if I can reproduce it and investigate what process has ahold of it. I bet it is something stupid like the browser.

  • Another option, almost as Jeff explains, for a user with Windows admin permissions and only a font issue...

    1. Open the C:\Windows\Fonts folder.
    2. Delete the Parallax font file if it already exists. (Important! You cannot just copy the new file over the old one, or the de/re-registration mechanism will not be invoked.)
    3. Copy/Paste the Parallax.ttf font file into the Windows font folder.

    After a second the font should be recognised, even by open applications. But if not, just close/re-open Propeller Tool.

    Font file can be downloaded here: https://drive.google.com/drive/folders/1vwd8ofG4TtVfK0RnTHhvSENwN3oXMNVU

    Tip: In the Windows Fonts folder, the Parallax font may be called "Parallax Regular".

  • I have the same errormessage. I looked C:\Windows\Fonts folder, but there is no Parallax.ttf. So the install-tool seems to try to delete a Font that is not there (anymore).

  • After installing the font manualy, I had to select 'skip this file'.

  • @dnalor said:
    I have the same errormessage. I looked C:\Windows\Fonts folder, but there is no Parallax.ttf. So the install-tool seems to try to delete a Font that is not there (anymore).

    If you're looking with Windows Explorer, it treats it in a special way where it's really only showing you the fonts whose file(s) is/are in in the folder AND are currently registered with the OS as a font... if the latter isn't true, then the font appears to be missing from the folder; however, looking at the folder with a command prompt window, you can see that the file is indeed in there.

    What I meant early about Exploring doing special handing is... if you copy the file in there with Windows Explorer, all should be well, but if you copy it in there via a command prompt, only the file itself will be there but the font will not be registered and the OS will not recognize it nor will Windows Explorer show that it exists in the folder.

Sign In or Register to comment.