Shop OBEX P1 Docs P2 Docs Learn Events
Wiznet official driver working (FlexC) (now with W6100 support!) - Page 3 — Parallax Forums

Wiznet official driver working (FlexC) (now with W6100 support!)

13»

Comments

  • RaymanRayman Posts: 14,047

    I see the W6100 C code in the Wiznet github page now:
    https://github.com/Wiznet/io6Library

    Not sure how I missed it before... guess I didn't equate IPV6 with W6100...

    Code structure looks nearly identical to W5XXX code that is working.
    So, I guess I'll take a shot at getting my new Spinner Edge board (Thanks @ke4pjw) working with this.

  • RaymanRayman Posts: 14,047

    Just got the W6100 driver from Wiznet working.
    Fortunately, the code is similar enough to the W5XXX code that it only took a couple of hours to get it going.

    This demos an http server in SPI mode with Spinnernet Edge on basepin 8 (obviously need to change basepin to multiple of 16 to use with P2 edge).
    The http server code files are identical to the W5XXX (a relief!).
    Hoping this means that all the other IPV4 files will work as well...

    Executable filesize is huge, but that's mostly because have a large image embedded in it.
    Have to implement serving from uSD in the future...

  • RaymanRayman Posts: 14,047
    edited 2023-04-05 17:07

    Haven't implemented "bus" mode, just SPI, but should be easy to adapt from @ke4pjw code.

    The loopback test compiles and may be working, but I don't know enough about what it is supposed to do to say.
    Strange that the IPV6 code only comes with loopback test.
    Was pleasantly surprised the IPV4 HTTP server code worked as is.
    Maybe they didn't include it because there is no IPV6 HTTP server code?
    not sure...

Sign In or Register to comment.