Shop Learn P1 Docs P2 Docs Events
PropStick USB (#32210) no propeller found on any serial port — Parallax Forums

PropStick USB (#32210) no propeller found on any serial port

I have tried multiple PCs. I have tried different USB cables. I have tried different PropSticks (I have 5-6). I have tried the Propeller Tool and SimpleIDE at work with multiple different PropSticks. These PropSticks have been known good in the past.

I work in a place where USB devices can be restricted, so I took one of the PropSticks home and tried it there with the same results.

I still need to try SimpleIDE and multiple other PropSticks on my home PC just to verify all of them have the same result.

The PropPlug does work when plugged in and used to program a different board with a propeller chip.

Maybe I have all bad PropSticks? Has anything changed with the IDEs that could make this happen (current version 2.5.3). The PropStick hasn't been phased out, right?

Comments

  • @travelerdawg said:

    The PropStick hasn't been phased out, right?

    Hi @travelerdawg

    The PropStick USB (32210) has been discontinued; the updated replacement is the Propeller FLIP Microcontroller Module (32123).

    Link to the old Parallax website, with information pertainning to the PropStick USB:

    https://www1.parallax.com/product/32210

    Hope it helps...

    Henrique

  • Unplug the propstick from your PC.

    Obtain and manually install the drivers for the FTDI FT232RG chip from FTDI.

    Despite the manual or any other claims for Windows Update to find serial adapter drivers, this is not the case today in 2022. Anyone that tells you it'll find the driver automatically is working on decades old bad info.

    Because this design predates all the recent chips like the ESP32 and feather and pi pico and others, it is not self powered from USB.

    Connect +5 volts DC to pin 12 (VIN). Use one of the VSS pins 9 or 10 for the - of that supply voltage. Verify connections with diagram in the manual before turning power on.

    Plug in USB after FTDI driver has been successfully installed. This would involve a mandatory PC reboot if asked.

  • Why is FTDI seemingly the only company that still has this problem with their Windows drivers? And it's not a hardware problem - FTDI chips just work on Linux without having to install anything.

  • The customer isn't using Linux.

    So Microsoft should knowingly distribute official manufacturer's driver updates that intentionally disable currently functioning hardware the manufacturer considers "counterfeit"? Who gets the blame?

  • My first thought was about VIN too. The propstick is not powered by USB, so needs the VIN connection too. That's a common gotcha.

  • ElectrodudeElectrodude Posts: 1,549
    edited 2022-10-19 19:53

    @whicker said:
    So Microsoft should knowingly distribute official manufacturer's driver updates that intentionally disable currently functioning hardware the manufacturer considers "counterfeit"? Who gets the blame?

    Oh, right. Forgot about that. FTDI deserves it, then.

  • Oh wow, yup, thanks for the update folks! @whicker ya got me, it has been quite a while since I used the PropStick and I totally forgot about this! @VonSzarvas it totally did. I will get an external power supply and let y'all know when it works.

  • Well, still not happening for me. At this point, I can't think of anything else other than having all bad PropSticks. This IMHO, is the least likely scenario but it is the only conclusion I can come to. FYI, I have a P2 Eval board that works.

    Note: When following manual, there is a step to plug in the USB before external power is applied. During this step it is suggested to view the LED where a faint glow should be seen. I do not see a faint glow.

    Power cycled PC after installing drivers or reinstalling IDE software
    Attempted multiple PropSticks on multiple PCs
    Attempted with at least two different USB cables
    Windows 10 version 21H2 and 21H1
    USB drivers installed v2.12.16r2
    SimpleIDE 1.1.2
    PropTool 2.7.0 (Beta) I have also tried on previous non-beta version
    5V power supplied to VIN and GND supplied to VSS
    powered with 5V <700ma power supply module powered with a 5V 2.5A wall wart
    verified 3.3v on the VDD with external LED and 100Ω resistor

  • Solution: Connect all VSS to GND. Don't assume everything labeled with the same name are interconnected, like they should be, and like they are in every other schematic I've ever read.

    VSS on pin 29 needs to be connected to GND along with PIN9 or PIN10. In my previous post, I somehow connected the LED to VSS PIN29 instead of VDD PIN32 and still managed to turn the LED on. That didn't hurt anything but it didn't help with troubleshooting.

    The following is a screen shot from the manual. It shows VSS PIN9 and VSS PIN29 connected to GND along with VIN PIN12 provided with 5v. Hopefully no one else will run into this problem in the future, if they do, I hope this post provides the answer they seek. I actually do have one bad PropStick but I knew all the PropSticks couldn't be bad.

Sign In or Register to comment.