Shop Learn P1 Docs P2 Docs
MCP3426 Solved the problem — Parallax Forums

MCP3426 Solved the problem

DigitalBobDigitalBob Posts: 1,301
edited 2022-09-17 01:13 in General Discussion

I’ve used this adc several times without any major problems. Now I soldered the MCP3426 to my board and nothing doesn’t read. Checked it my scope and just a steady pulse train no one shot byte. Tried different pull-ups, no cigar. Scraped about four of these thinking they are bad.
So tried it on the ardriuno still a dud. Then I tried soldering a long lead 0.1 cap directly to the pins, nothing still dead. While running the I2C scanner I touched the cap. leads and Bada Bing , I2C found at 0x69,. But still Intermittent , So I cut the long leads on the cap. to about 1/4” and now it runs like champ. Now I can’t get it to glitch. Runs smooth as silk.
But doesn't work on the Prop1 with my Object, The jm_I2C device see's it but not my MCP3426 demo, I have a MCP3428 and that works, wondering if there is a device ID change on the MCP3426.

In the jm_mcp342x object I had to change the address line in the startx to, addr :=%1000 and that fixed it.
I don't need the A0 and A1 for the mcp34236

Sign In or Register to comment.