Shop Learn P1 Docs P2 Docs
Having Issues with breadboard p1 setup. — Parallax Forums

Having Issues with breadboard p1 setup.

Hello,

I've recently bought the p8x32a-d40 and wired it up as per the typical connections diagram in the datasheet without the optional EEPROM and with/without an 5mhz crystal. Also have 2 0.1uF ceramic capacitors between the VDD and VSS.

When I try it identify the chip it succeeds once, after that it wont find it until the USB is unplugged from the prop plug or I disable/restart the COM port in device manager. I've tried 2 different prop plugs, several usb cables/ports, different pcs but the result is always the same a above.

Before biting the bullet and buying another chip since its the last thing to replace I thought id ask here if anyone has seen this behaviour before and there is something else causing this?

Comments

  • Check your connections on the breadboard, do you have the correct power, 3.3v regulator etc.

  • Thanks for the reply

    Yes I've checked all the connections and redone them just in case, 3.3v regulator (800ma, also tried one of those breadboard psu set to 3.3v).
    I'll replace the p8x32a with a new regulator this weekend to see if that does the trick.

  • evanhevanh Posts: 13,424
    edited 2022-07-07 12:43

    It does sound like there is a power problem. USB bus supply is quite susceptible to protective shutdowns on bad power conditions - Requiring a re-socketing to recover. Where is the 3.3 V regulator getting its power from?

Sign In or Register to comment.