Shop Learn
P1 connection to ESP32 — Parallax Forums

P1 connection to ESP32

I hope this is the correct catagory for this question.

I'm trying to get a P1 Flip talking to an ESP32.

Can I directly connect a set of RX TX pins on the P1 to a set of TX RX on the ESP32?

If not what do I need?.

I would like , at least to start, by using the main connection(USB, on both systems for programming and debuging then setting up a second port on both systems to talk to each other.

I have seen posts on the parallax WX esp board but I already have more than a few P1s and ESP32s on my bench.

Thanks in advance for the help.

Don

Comments

  • They're both 3.3V, so it should work fine as long as you have a common ground.

  • Maybe fit some series resistors high enough in value to prevent chip damage should both ports be accidently outputs, but low enough in value not to affect your signalling edges too much.

  • iseriesiseries Posts: 1,268

    I have hooked up several ESP32 modules to the P1. It works just fine.

    It sounds like you have the models that have a USB interface on them. I have not tried to use one of those to do serial between them but it should work fine.

    I have the models that have no USB interface on them and I use a Prop Plug to program them and connect the serial to the P1.

    Mike

  • Thanks for your help so far.

    I started on the esp32 side. I set up two esp32's cross connecting the RX/TX between the second port on both of them and was able to get them talking in both directions with little trouble.

    I was able to do this by running two instances of the Arduino IDE on my windows PC along with two debug windows open.

    I can't seem to start two instances of the propeller Tool on my PC. Is this by design? Am I missing something? Is there a new program?

    Your thoughts please.

    Don

  • @DonRacz said:
    I can't seem to start two instances of the propeller Tool on my PC.

    There's an option to allow multiple instances in the preferences (F5). In my experience, the Propeller Tool is more likely to misbehave when using more than one instance.

  • I don't see it. What version are you running?

  • Found it!

    Thanks Duane

Sign In or Register to comment.