Shop Learn
TAQOZ Reloaded - invalid partition — Parallax Forums

TAQOZ Reloaded - invalid partition

Hello,

I am using a P2 Eval Board - Revision C with an 4 GB SD Card and
TAQOZ Reloaded 2.8. If I start a picocom terminal session I get
the following output:

picocom v3.1

port is : /dev/ttyUSB0
flowcontrol : none
baudrate is : 921600
parity is : none
databits are : 8
stopbits are : 1
escape is : C-a
local echo is : no
noinit is : no
noreset is : no
hangup is : no
nolock is : no
send_cmd is : sz -vv
receive_cmd is : rz -vv -E
imap is :
omap is :
emap is : crcrlf,delbs,
logfile is : none
initstring : none
exit_after is : not set
exit is : no

Type [C-a] [C-h] to see available commands
Terminal ready
�BOOTING.... ERROR - INVALID PARTITION


TAQOZ#

What is that message about an invalid partion about?
The SD card has one Win 95 FAT32 partition and it is
fomatted with the Windows 10 tool. What do I need to
do to get rid of that message.

Kind regards,
Fabian

Comments

  • bob_g4bbybob_g4bby Posts: 311
    edited 2022-03-03 06:25

    Hi @fbou Fabian,
    My glossary has a section at the back called 'System Installation and Booting Up' which worked for me and my P2-EVAL. Your problem is probably due to either of two things:-
    1. An obsolete SD card that is not fully SDHC compatible. Modern Sandisk cards are known to work
    2. Taqoz may not support your chosen SD card format - using the SD association formatter would probably fix that
    Cheers, Bob

  • Thanks Super-Bob, I will try that later.

  • Hi @bob_g4bby Super-Bob,

    switching to a spare Sandisk SD card worked for me.
    Thanks a lot.

    Cheers,
    Fabian

  • Good to hear you're up and running Fabian, hope you have some fun with Taqoz. I'm currently learning about serial input and decoding FMEA sentences from a gps module. Cheers, Bob

  • I remember Peter mentioned some issues with the SD vias (inductive capacitance?) of the P2-EVAL. I had SD issues with the KISS board, too, where using different clock speeds sometimes lead to problems. I have no skill or instruments to dig the source of such problems, at least until the SD is working with specific configs.

Sign In or Register to comment.