Shop Learn
Perplexing Prop Plug Problem - Solved — Parallax Forums

Perplexing Prop Plug Problem - Solved

blittled2blittled2 Posts: 25
edited 2022-02-17 02:15 in Propeller 1

After a long sabbatical from the Propeller 1 I decided to wire up a Prop with a 6.25MHz crystal on a bread board to try Ray's new 40 character VGA text driver. I got the Propeller not found with the most recent Propeller tool. I double checked the wiring and have 0.01uf decoupling caps on both power pins. I then decided to try some of my other Propeller boards to see if it finds the Propeller on them and got hit or miss results. Using the same cable and Propeller plug (bought somewhere around 2010) here are the results:
Windows 11 Build 22543.1000
Breadboard - Plug - not found
Spin Studio - Plug - not found
Micromite Companion - Plug - found
Hydra - Plug - not found
Hydra - USB - found
Demo Board - USB - found
Prop Prof Dev Board - USB - found

I was beginning to think the Prop plug was faulty but it does work on OBC's Micromite Companion. I know it also should work with the Hydra and Spin Studio since it has worked on them before but doesn't now. This one leave me scratching my head. Any ideas what may be causing this?

Edit:
Just looked at the Hydra specs and you cannot use the Propplug on it since it is wired differently using the USBSer plug instead.

Comments

  • Jumped the gun on this issue. I just tried my other Spin Studio board and it worked. Looks like the first Spin Studio board has something wrong with the power input since the power LED only goes on when the prop plug is plugged in when it should be on when power is applied. The bread board probably also has an error so I may rewire it.

Sign In or Register to comment.