Shop Learn
Simple tools problem. — Parallax Forums

Simple tools problem.

I have been using simple ide on an older mac. I have a fairly new Macbook Pro that I installed simple Ide on today. The software runs at first like it should opening with “welcome.side” .This program compiles just fine. Any other code that will compile on my older computer won’t compile on the newer one. There is a list of errors basically saying it can’t find simple tools. Any ideas?
My MacBook is running the latest operating system. My older computer is an operating system back. It seems like I have had this problem before on my older computer and it took an Apple update before it would work.
Thanks Eric

Comments

  • When a compile fails, SimpleIDE will give you lots of details about why it has failed. If you go to the Help menu, there is an option "Build Error Rescue" that will allow copying the error details. You can paste that into this thread and maybe, you'll get some help!

    Some questions that may also help:

    1. What version of SImpleIDE are you running
    2. How did you install SimpleIDE (from Parallax website or copied from your older system)?
    3. Did you follow these instructions: https://parallax.com/package/simpleide-software-for-mac-propeller-c/
    4. What version of macOS are you running?

    Also, You may need to run the "Update Workspace" option inside the Tools menu.

    dgately

  • Beavis3215Beavis3215 Posts: 229
    edited 2021-12-24 00:04

    It turns out that I downloaded the incorrect file. This is what happened when I downloaded the correct one.

    Simple-IDE 1-0-2-RC2 MacOS.pkg can’t be opened because Apple cannot check it for malicious software.

    This software needs to be updated. Contact the developer for more information.

  • dgatelydgately Posts: 1,494
    edited 2021-12-24 02:24

    @Beavis3215 said:
    It turns out that I downloaded the incorrect file. This is what happened when I downloaded the correct one.

    Simple-IDE 1-0-2-RC2 MacOS.pkg can’t be opened because Apple cannot check it for malicious software.

    This software needs to be updated. Contact the developer for more information.

    You can open the package file by holding down the Control key when you click on its icon. The Open option shown will allow you to open the package and export its content. Apple has made it more difficult to open/run packages and apps in newer versions of the OS. The 1-0-2-RC2 package was definitely created with the correct signage & certificate when it was built, so I'm not sure why the warning.

    You may see this dialog. Choose "Open"...

  • With your help I got past the warning and got the proper version of simple ide installed. Thank you. It did not solve my original problem where the compiler cant find simpletools and its components. Simple ide also freezes so that most of the time I can’t read the error list.

  • dgatelydgately Posts: 1,494
    edited 2021-12-24 23:27

    Well, if the IDE does not freeze during any one compile (your stated 'most of the time'), can you get the data as requested in post #2? You just need one time that it completes the compile with the failure data. Your'e trying to understand where SimpleIDE 'thinks' the simpletools library is located... On a Mac, it should be located at /Users/your_user_name/Documents/SimpleIDE/Learn/Simple Libraries/Utility/libsimpletools. If its not there, your installation may be broken.

    Do note, there is an option "Update Workspace" within the Tools menu that you can attempt to run. It may help rebuild your library directory. You can also update to the latest 'learn' directory by following the instructions and downloading from this site: https://learn.parallax.com/tutorials/language/propeller-c/propeller-c-set-simpleide/update-your-learn-folder

    Also, if SimpleIDE is 'freezing', you may have other problems. The Console application in your Mac's /Applications/Utilities directory can show you any recent 'hung' apps (as "Spin Reports") and provides debug information about the app freeze.

Sign In or Register to comment.