Shop Learn
Propeller chip lost error — Parallax Forums

Propeller chip lost error

DiverBobDiverBob Posts: 945
edited 2021-10-23 21:48 in Propeller 1

I've been successfully loading programs onto a P1 board (RoboPi) for a couple of hours when I suddenly got a Communication Error message stating 'Propeller chip lost on COM3 during an upload to RAM (F10). A Check for Hardware (F7) finds the propeller with no problem. I have PST running on COM3 also but closing PST doesn't fix the problem. I am running version 2.5.3 of the Prop Tool. I hooked up to a different propeller board and got the same error message. I rebooted my Dell Win 10 computer and got the same message. I also tried upload to EEPROM (F11) and got the same error message. The Prop Tool says the compile was successful but download failed at the bottom of the Prop Tool screen.
Not sure what changed as it was working great all afternoon and just suddenly stopped uploading the compiled program.
Any ideas for a fix?

Comments

  • Cluso99Cluso99 Posts: 18,013

    I seem to recall an old ProTool problem where downloading a certain size would cause problems. Just to make sure, add a dat section with
    dummy long 0[256]
    and try this.

  • Run loading a simple demo spin program, like a one or two liner

  • evanhevanh Posts: 12,021

    Oh, that's two Bobs! Lol, Had me puzzled for a moment trying work out what Bob was saying.

  • After leaving the W10 computer off overnight, this morning everything has been working correctly. Apparently just doing restart wasn’t enough! I’ve already gotten in several hours of coding and fixing stuff in!

  • PublisonPublison Posts: 12,200

    Good news Bob.

  • evanhevanh Posts: 12,021
    edited 2021-10-24 21:39

    Sounds familiar. It'll be USB hardware glitches not able to reset fully after a power spike.

    Now I think about it, I haven't had one of those hiccups since I got a fancy four-port mains-powered USB hub for my Propeller work. It won't operate without its power pack. Relatively expensive but clearly much better quality. The previous seven-port hub up and died after only a few months of use, probably through those incidences.

Sign In or Register to comment.