Shop Learn
Problem with Prop Tool — Parallax Forums

Problem with Prop Tool

I want to run a demo for students, but when I try to load RAM, the message in the attached image appears. The "Coin Changer" file was from an old project and that file does not exist. I suppose there's some pointer or cache that I need to clear or reset. But this problem baffles me. Help greatly appreciated. Thanks. --Jon

Comments

  • This message pops up whenever I try to load any program into RAM. It's not just the program shown above.

  • I removed the old Propeller Tool and replaced it with Propeller Tool 2.5.3. I still get the same error message.

  • Phil Pilgrim (PhiPi)Phil Pilgrim (PhiPi) Posts: 23,050
    edited 2021-09-08 17:23

    I'm sure you know this, but in case you've forgotten: all objects referenced by a Spin program have to exist either in that program's own directory or in PropTool's library directory.

    -Phil

  • JonTitusJonTitus Posts: 182
    edited 2021-09-08 18:01

    I don't understand why the Propeller tool looks for the Coin Changer file. The I2C Demo I want to run does not use this file and shouldn't even "know" it existed. The Coin Changer file was in a different folder and there's no "connection" between that directory and the I2C files. All of the I2C...spin2 files are in the Library folder: Documents/Propeller Tool/Library. That's where all my SPIN2 files are.

    I just tried a SPIN2 demo from Parallax and I still get the same message!!! Aaaargh!

    I've been trying to get I2C to work for two days. I'm tired of the process that yields no results and appreciate your help. Phil. --Jon

  • It's probably still set as your top object and you're trying to build that. Either set the correct top object or use the option that builds the current object.

  • RaymanRayman Posts: 12,185

    Wonder if it has to do with MRU files in the registry...

  • RaymanRayman Posts: 12,185
    edited 2021-09-08 20:02

    There was some registry weirdness discussed here: https://forums.parallax.com/discussion/comment/1526755#Comment_1526755

    Maybe I'd delete the lists of files there...

    Use regedit and look here: Computer\HKEY_CURRENT_USER\SOFTWARE\ParallaxInc\Propeller\2.4.0

  • Thanks, Wuerfel. How to I "unset" this project as the "top project"? It no longer exists. Cheers. --Jon

  • As a crude work around, try creating a dummy spin file with that same name in the directory where it thinks it should be.

  • @JonTitus said:
    Thanks, Wuerfel. How to I "unset" this project as the "top project"? It no longer exists. Cheers. --Jon

    Just set a different one.

Sign In or Register to comment.