Shop Learn
TAQOZ and Chromebook — Parallax Forums

TAQOZ and Chromebook

WhitWhit Posts: 4,181

Is anyone running a terminal on a Chromebook to program in TAQOZ or Fourth? I honestly don't know enough to know if this is dumb question.

It looks like I can enable Linux this way on a Chromebook...

Set up Linux on your Chromebook
Linux is a feature that lets you develop software using your Chromebook. You can install Linux command line tools, code editors, and IDEs (integrated development environments) on your Chromebook. These can be used to write code, create apps, and more. Check which devices have Linux.

Turn on Linux
Linux is off by default. You can turn it on any time from Settings.

On your Chromebook, at the bottom right, select the time.
Select Settings and then Advanced and then Developers.
Next to "Linux development environment," select Turn On.
Follow the on-screen instructions. Setup can take 10 minutes or more.
A terminal window opens. You have a Debian 10 (Buster) environment. You can run Linux commands, install more tools using the APT package manager, and customize your shell.

Thoughts, warnings, encouragement? I also want to play with the Tachyon Robot Control Language (TRCL) using Chromebook too.

Comments

  • MaciekMaciek Posts: 466
    edited 2021-08-07 08:17

    All you need to talk to a P2 board running TAQOZ is an ANSI terminal program on your Chromebook.
    The TAQOZ resides on the P2 and you are actually developing interactively on the P2 itself. Nothing more is needed on the PC side. You can even use your smartphone or a tablet as long as you have some terminal program installed (plenty of options there for any platform).
    The same holds true for the Tachyon. It runs on the P1 (if you have it loaded to the P1 first, of course).

    Things are different with the PC forth but I do not have experience with the PC forth so I will not go into any specific details.

  • WhitWhit Posts: 4,181

    @Maciek, Thanks so much! I've played around some with TAQOZ some on my PC, but I wanted to try it with the Chromebook.

  • @Whit , It's possible I misunderstood your intention then.

    I do not own a Chromebook but I have seen instructions on how to install linux on it, that looked like they might actually work. Haven't tried them so can't be sure.

    If you want to run a FORTH dedicated for the PC then you'll need to either get the right Forth that runs on your operating system and your hardware platform or the vice versa.

    If you'd like to run Tachyon or TAQOZ on your Chromebook then you'd need some kind of P1 or P2 emulator that can handle that job for your Chromebook. I haven seen such an emulator. Maybe it exists but I rather doubt it.

    If you want to run Tachyon or TAQOZ on their respective hardware platforms natively (P1 or P2) then you only need a terminal on your Chromebook to communicate with the P1/P2 boards. Nothing more.

  • WhitWhit Posts: 4,181

    @Maciek - You understood. I am just trying to get a terminal running on my Chromebook. I think the Linux terminal is the way to go. I tried it and it was not communicating properly. More research.

    I am using a P2 (and maybe a P1) to do this. As I said - no issues doing this on my PC. Exactly how the Chromebook does things via the Linux terminal is the mystery...

  • @Whit, ok then - let's try to debug your problem.

    What I would suggest is to first check if your terminal program is working at all. If it does then maybe your linux distribution on the Chromebook lacks a driver for your usb>serial cable/dongle/whatever or the driver is misbehaving for some reason. If also the driver for your usb>serial hardware on your Chromebook is correct and functioning properly then maybe you need to set the correct privileges for it it use the serial port ? These are generic steps but maybe they can help you.

  • rosco_pcrosco_pc Posts: 419
    edited 2021-08-08 07:49

    Just installing the linux terminal will not give you serial access directly. You'll need to use a serial terminal program, like screen or need to install minicom/... (see Connecting To The Serial Console for some alternative ways)
    And to use either serial terminal program under linux you need to find out where your usb-serial adapter is connected (see further below for a detailed description)

    Alternatively you can try to install a serial terminal, like this:
    diginow
    or
    beagleterm
    list supported devices

    This last might be easiest, but I have no chromebook and no experience with these extensions.

    Connect usb-serial adapter under Linux

    (hoping I did not forget anything):
    1. open linux terminal
    2. plugin serial adapter
    3. issue the following command in the terminal

    $ dmesg
    

    at the end you should see some lines like this (depending on the serial adapter you use)

    [5838315.183573] usb 1-9: Product: CP2102 USB to UART Bridge Controller
    [5838315.183575] usb 1-9: Manufacturer: Silicon Labs
    [5838315.183577] usb 1-9: SerialNumber: 0001
    [5838315.228024] usbcore: registered new interface driver usbserial_generic
    [5838315.228037] usbserial: USB Serial support registered for generic
    [5838315.231173] usbcore: registered new interface driver cp210x
    [5838315.231189] usbserial: USB Serial support registered for cp210x
    [5838315.231231] cp210x 1-9:1.0: cp210x converter detected
    [5838315.243613] usb 1-9: cp210x converter now attached to ttyUSB0
    

    [edit to add eval board dmesg]

    [5841002.405719] usb 1-8: new full-speed USB device number 86 using xhci_hcd
    [5841002.765285] usb 1-8: New USB device found, idVendor=0403, idProduct=6015, bcdDevice=10.00
    [5841002.765289] usb 1-8: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [5841002.765291] usb 1-8: Product: Propeller P2-EVAL-ES
    [5841002.765293] usb 1-8: Manufacturer: Parallax Inc.
    [5841002.765295] usb 1-8: SerialNumber: P2EEL5K
    [5841002.814469] usbcore: registered new interface driver ftdi_sio
    [5841002.814480] usbserial: USB Serial support registered for FTDI USB Serial Device
    [5841002.814557] ftdi_sio 1-8:1.0: FTDI USB Serial Device converter detected
    [5841002.814586] usb 1-8: Detected FT-X
    [5841002.824424] usb 1-8: FTDI USB Serial Device converter now attached to ttyUSB0
    

    this means the usb-serial adapter is attached to /dev/ttyUSB0 and you should use that as your serial device

    $ ls -l /dev/ttyUSB0
    crw-rw---- 1 root dialout 188, 0 Aug  8 07:29 /dev/ttyUSB0
    

    [edit to add] Note that Linux is much more 'consistent' than windows and if you have only 1 usb-serial adapter connected it is always attached as ttyUSB0 (even after repeated plug/un-plug cycles)

    1. In order to use the usb-serial adapter your user needs to be part of the dialout group, which allows access to serial devices
    2. issue this to check
    $ groups
    <user> adm dialout cdrom sudo dip plugdev lpadmin sambashare
    
    1. and this to add the user
    $ sudo usermod -a -G dialout <user>
    
    1. You need to restart linux terminal (or your complete chromebook) in order to make the changes work.

    [editied to add]: the steps 3-8 only need to be performed 1 time :)

    1. you can now check if screen is working (it is normally installed by default):
    $ screen /dev/ttyUSB0 230400
    
    1. connect the P2 board and perform the normal magic key incantation to get it to start TAQOZ.

    you can leave the screen window and come back at any time it will be left in the same state (providing that the connection remains)
    you can close screen by issuing the following command sequence: ctrl-A k

  • WhitWhit Posts: 4,181

    @rosco_pc, Thanks for this info. I'll play with this when I get a chance. I appreciate all the info.

Sign In or Register to comment.