Shop Learn
Problem with flip — Parallax Forums

Problem with flip

I just got a propeller flip and it doesn't seem to be working. My computer doesn't recognize it at all. when I try the identify hardware it shows up fine but trying a simple program it complains that it can't communicate with the cpu. My computer won't allow me to copy and paste the messages which is why I'm not posting it.

I usually use linux and can't do it on windows.

Comments

  • I think the propeller tool supports only windows. Try propeller IDE for linux

  • 4x5n4x5n Posts: 726

    I'm using linux and got the propeller tool up and running.

  • 4x5n4x5n Posts: 726

    For what it's worth I have a p2 edge and it works fine!!!

  • Some linux os's require a change to permission to give user programs to access to serial ports and USB port.
    One thing to try is run software in root access. If it works, its permission issue. Otherwise something else is wrong.

  • VonSzarvasVonSzarvas Posts: 2,393
    edited 2021-06-11 12:02

    For sanity control, can (or have) you tried programming the FLiP module with a *.spin file, from PropellerTool running on Windows ?

    Another think you could try is https://solo.parallax.com
    That would be another way to program the FLiP module, from a Chrome browser.

    Or one of the ersmith Flex gui's? As I understand, they run natively on linux and allow both P1 and P2 programming.

  • 4x5n4x5n Posts: 726

    I'm using windows 10 for the prop. There is no linux installed on that machine. I normally use linux and the copy and paste from windows doesn't work like linux so I can't paste the messages I get or code. I suppose I can type it in the window.

  • My computer won't allow me to copy and paste the messages which is why I'm not posting it.

    You can always do a screen grab and post the resulting image.

    -Phil

  • msrobotsmsrobots Posts: 3,364

    In Windows you need to mark the text and press ctrl-C to copy and ctrl-v to paste

    Enjoy!

    Mike

  • If this turns out to be a problem with the FLiP and not the PC/tools/port configuration, we're obviously ready to cross-ship 4x5n a replacement FLiP module. This isn't likely the problem due to our tests, but we'll be on standby with this thread.

    Ken Gracey

  • Hi
    I had similar problem a couple of years ago, and could not communicate with the Flip module.
    That turned out to be problem with the USB-cable. I used a cable from a charger to a cheap equipment, but that did not work.
    Changed to another cabel and the problem was solved.
    Have you tried another USB-cable from PC to Flip?

  • 4x5n4x5n Posts: 726

    @LA6WNA said:
    Hi
    I had similar problem a couple of years ago, and could not communicate with the Flip module.
    That turned out to be problem with the USB-cable. I used a cable from a charger to a cheap equipment, but that did not work.
    Changed to another cabel and the problem was solved.
    Have you tried another USB-cable from PC to Flip?

    The cable works fine with the prop2 though.

  • @4x5n, if you're pretty certain it's a defective module, let's cross-ship one to you. Contact me at kgracey@parallax.com and we'll make arrangements.

    Thank you,

    Ken Gracey

Sign In or Register to comment.