Shop Learn
Compile Tachyon-IDE for Windows 10 — Parallax Forums

Compile Tachyon-IDE for Windows 10

I tried to compile and rbehm's IDE for Peter Jakacki's Tachyon FORTH for the Propeller at https://github.com/rbehm-ibb/Tachyon-IDE

The repository contains a number of cpp and h files along with a few others. The only file that compiles is project.h. It creates a project.exe, but the error message is "This app can't run on your PC."

I am using Visual Studio Code 1.56.2 to compile from a local fork for personal use with C/C++ IntelliSense 1.4.0 and C++ IntelliSense 0.2.2 extensions.

I'm sure I selected the wrong file to compile and not compiling with the correct compiler or switches.

Can someone advise how to compile Tachyon-IDE to run on Windows 10?

Comments

  • dbpage:

    Attach find a zip file which contains the program Forfiter.exe, which was designed to simplify forth programming . I have successfully used it with Tachyon. It was first posted on the web in 2010 by Lubos Pekny.

    Nick (nchlor)

  • @dbpage said:
    I tried to compile and rbehm's IDE for Peter Jakacki's Tachyon FORTH for the Propeller at https://github.com/rbehm-ibb/Tachyon-IDE

    The repository contains a number of cpp and h files along with a few others. The only file that compiles is project.h. It creates a project.exe, but the error message is "This app can't run on your PC."

    I am using Visual Studio Code 1.56.2 to compile from a local fork for personal use with C/C++ IntelliSense 1.4.0 and C++ IntelliSense 0.2.2 extensions.

    I'm sure I selected the wrong file to compile and not compiling with the correct compiler or switches.

    Can someone advise how to compile Tachyon-IDE to run on Windows 10?

    It seems to be a QT5 program. You would need Qt-Creator, i think.

  • Downloaded Qt and tried to compile the project. Complains about a missing singleapp.h. Maybe @rbehm could help.

  • dnalor,

    Which Qt Creater did you download?

    Dennis

  • First I installed Qt 5.15.2 MinGW 8.1 32bit, then I tried a new Qt 6.2 with Qt5 compatibility module which gave me even more errors, but also missing singleapp.h which by the way is included in main.cpp. I think this header is missing in the git-repository because it is included with '#include "singleapp.h"' not '#include <singleapp.h>'.

  • I found out that singleapp is not a Qt library. I found something here, but did not manage to include it. The error messages are getting more and more. I never use Qt because it's an inscrutable system and that's why the journey ends here for me, sorry.

  • dnalor, I agree with your suggestion that maybe @rbehm can help

  • @dbpage said:
    dnalor, I agree with your suggestion that maybe @rbehm can help

    I will have a look into this. It is from my own library. I guess I have forgotten to put it into the library.
    As for compiling: I use QtCreator which handles all builds.

Sign In or Register to comment.