Shop OBEX P1 Docs P2 Docs Learn Events
Scribbler S3 - Can not set port COM9's options - DTR: false - Page 2 — Parallax Forums

Scribbler S3 - Can not set port COM9's options - DTR: false



  • I lucked out, just downloading the latest driver cured the problem. All is happy now.

  • banjobanjo Posts: 443
    edited 2022-10-02 06:53

    @"Carol Hazlett", great! Was just now going to reply that things started to work without me knowing why.

  • I am having the exact same issue right now. First download works and then we get the dtr false message. Switched computers and got the same thing so the problem seems to be in the robot. Haven't tried switching robots yet. I will go look for new drivers for the ActivityBot.

  • Anyone come up with a fix? I am also haveing the same issue with Activity Boards? After the first download I ger the DTR false message.

  • This is an elusive problem we've been chasing for a while. Unfortunately, nothing we have tried in the software it actually detects the pending problem nor recovers from it gracefully as we would like to have happen.

    The problem tends to happen in bursts, then not again, which makes me think it's related to the code that was successfully downloaded prior to the problem; namely, if that code serially communicates back to the computer in a certain way (perhaps without delay at the start of the code); however, we've never been able to prove since, after a driver update, computer reboot, or simply after closing/reopening the Blockly Prop Launcher application a few times when it happens, the problem mysteriously disappears. Please try closing/reopening the Blockly Prop Launcher after this error occurs and hopefully it will resolve itself as it has when we've diagnosed it.

    For the future, we are working on an update to the Solo + Blockly Prop Launcher system that will likely prevent the problem by using a different communication library. I don't have a projected date of release yet.

Sign In or Register to comment.