Shop Learn P1 Docs P2 Docs Events
Error installing SimpleIDE on Ubuntu 20.04 Desktop — Parallax Forums

Error installing SimpleIDE on Ubuntu 20.04 Desktop

I’m installing SimpleIDE for Parallax Propeller development on Ubuntu 20.04. The git repository is: .

I had a problem initially with qmake. The install script was not detecting qmake / Qt5 properly, but I got past that by installing the latest Qt5 and modding the SimpleIDE Linux installer script slightly.

The install script runs for a long time compiling and linking.

Eventually it bails with the following error message:
g++ -Wl,-O1 -o SimpleIDE mainspin.o PortConnectionMonitor.o PropellerID.o editor.o ctags.o mainspinwindow.o cbuildtree.o treemodel.o treeitem.o projecttree.o terminal.o termprefs.o properties.o newproject.o PortListener.o highlighter.o hardware.o help.o console.o asideconfig.o asideboard.o projectoptions.o replacedialog.o aboutdialog.o loader.o qextserialport.o qextserialenumerator.o buildc.o buildspin.o build.o spinhighlighter.o spinparser.o gdb.o highlightc.o hintdialog.o blinker.o buildstatus.o highlightbuild.o directory.o zip.o zipper.o StatusDialog.o workspacedialog.o rescuedialog.o xesp8266port.o qextserialport_unix.o qextserialenumerator_unix.o qrc_resources.o moc_mainspinwindow.o moc_PortConnectionMonitor.o moc_PropellerID.o moc_editor.o moc_ctags.o moc_highlighter.o moc_treemodel.o moc_PortListener.o moc_terminal.o moc_termprefs.o moc_properties.o moc_newproject.o moc_console.o moc_hardware.o moc_help.o moc_projectoptions.o moc_replacedialog.o moc_aboutdialog.o moc_loader.o moc_projecttree.o moc_qextserialenumerator.o moc_buildc.o moc_buildspin.o moc_build.o moc_spinhighlighter.o moc_gdb.o moc_qportcombobox.o moc_hintdialog.o moc_blinker.o moc_zipper.o moc_StatusDialog.o moc_workspacedialog.o moc_rescuedialog.o moc_xesp8266port.o -lz /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/ -lpthread

usr/bin/ld: cannot find -lz
collect2: error: ld returned 1 exit status
make: *** [Makefile:400: SimpleIDE] Error 1


  • That z means, if I'm not wrong, you need to install zlib1g-dev:
    sudo apt install zlib1g-dev
  • Thanks, Macca

    I checked for zlib install and I did have a few, but clearly not all. I ran your command line and it installed the missing ones.

    The insatll script got much further, but failed again.

    Now it’s looking for proploader and openspin.

    It bailed out here:
    Creating Version SimpleIDE-1-1-2
    bin INSTALL.txt license
    proploader not found. Adding:
    Cloning into '../proploader'...
    remote: Enumerating objects: 1176, done.
    remote: Total 1176 (delta 0), reused 0 (delta 0), pack-reused 1176
    Receiving objects: 100% (1176/1176), 344.62 KiB | 4.85 MiB/s, done.
    Resolving deltas: 100% (885/885), done.
    ./ 224: pushd: not found
    VERSION v1.0-46 (2020-06-30 12:07:49 gd647776)
    gcc -Wall -DVERSION=\""v1.0-46 (2020-06-30 12:07:49 gd647776)"\" -DLINUX -I/home/billmack/Downloads/simpleide/proploader-linux-build/obj tools/split.c -o /home/billmack/Downloads/simpleide/proploader-linux-build/bin/split
    cd spin/; openspin -o /home/billmack/Downloads/simpleide/proploader-linux-build/obj/IP_Loader.binary IP_Loader.spin
    /bin/sh: 1: openspin: not found
    make: *** [Makefile:154: /home/billmack/Downloads/simpleide/proploader-linux-build/obj/IP_Loader.h] Error 127
    ./ 228: popd: not found
    cp: cannot stat '../proploader-linux-build/bin/proploader': No such file or directory
    ../proploader-linux-build/bin/proploader is missing. Build it?

    I’m not sure about openspin, but I think I see proploader folders and can install that.

    Why is Parallax’s Linux relase so messy? Is it abandoned?

  • I’m not sure about openspin, but I think I see proploader folders and can install that.

    Why is Parallax’s Linux relase so messy? Is it abandoned?

    In the GitHub notes:
    Items required but not included here:
    propeller-gcc compiler source
    Open Spin compiler source
    proploader source
    Learn workspace
    Qt5.4 libraries
    QtCreator community edition
    OpenGL xorg-x11-server-devel



    I got openspin downloaded. It’s already compiled, just dropped it in /usr/bin.

    Then I ran make on the proploader Makefile. It wasn’t detecting the OS.
    Maybe I’m in over my head, but it seems like make or the Makefile should detect the OS and set the environment var OS.
    I edited Makefile and set OS=linux.
    Ran make on Makefile and it successfuly spit out proploader.

    Next, went back to SimpleIDE install script and ran it...again.
    Completed without errors.

    SimpleIDE works on Ubuntu 20.04.
Sign In or Register to comment.