Shop Learn
PropellerIDE and Raspberry Pi Stretch — Parallax Forums

PropellerIDE and Raspberry Pi Stretch

I am using the Raspberry Pi 3 running Raspbian version Stretch. I have installed PropellerIDE 38.5 on it.

When I build the program I want to load to the propeller I get the following error in a "Build Manager" dialog window:

"/usr/bin/bstc: 1: /usr/bin/bstc: Syntax error: "(" unexpected"

The following is the program I am trying to load to the propeller:

PUB Blink

dira[6] := 1
outa[6] := 1
waitcnt(clkfreq + cnt)
outa[6] := 0
waitcnt(clkfreq +cnt)

I have absolutely no experience with Debian/Linux/any flavor of UNIX.
Everything worked fine with Raspbian version Jessie...contemplating loading version Jessie.

Thank you for any assistance,


  • Heater.Heater. Posts: 21,233
    Your Simple IDE is using BSTC to compile Spin code. BSTC is an Intel x86 executable. It will not run on the ARM processor of the Raspberry Pi.

    I'm a bit out of touch with SimpleIDE now a days. I thought Spin support was be dropped from it. Presumably you were using OpenSpin before.
  • Heater,

    Just to clarify, I'm using PropellerIDE 38.5, not SimpleIDE. I remembered that I was able to get PropellerIDE 36.5 to work on Jessie. I downloaded and installed it. I got a build error of "Could not start "." Check Preferences". All I did was confirm the path of the compiler and now the program successfully builds. Later I will upgrade to PropellerIDE 38.5 and see if I can get that to work the same way.
  • Heater.Heater. Posts: 21,233
    Oops, sorry.

    Either way BSTC ain't going to work.
  • yetiyeti Posts: 776
    edited 2017-09-08 19:30
    The last time I tried PropellerIDE, it refused to run. I don't remember exactly what failed, but it was something with the IDE istself that turned it useless for me.

    I didn't retry since then because I prefer a shell, "normal" editors, makefiles and such stoneage hammer and chisel stuff and looking at PropellerIDE just was meant for satisfying my curiousity.

    If you get PropellerIDE that far that it tries to run BSTC, you can look at this hack to let i386ish BSTC run on your ARMish system or install PI-native OpenSpin or FastSpin instead. ;-)
    Or even better: All of them... \o/
  • Yeah, I see the same thing with version 0.38.5. To eliminate this, go to Edit->Preferences and change the Spin Compiler to 'openspin'.

    However, for me the loading of the file to the board failed since the loader is looking for a ".binary.binary" file rather than a ".binary". I'm not sure how to fix this outside of running the install manually.

    1. Identify the tty port the Propeller device is connected to:
    propman -i
          ttyUSB0:  Propeller P8X32A

    2. Run propman to load the binary from the IDE to the board attached to the tty port listed previously.
    propman -d ttyUSB0 BlinkTest.binary

    This seemed to work for me running Stretch on a RasPi.

    I suppose a note should be sent to the individual supporting this (if anyone) or on the GitHub page.
  • Regarding not being able to load to the board:
    I attached a patch awhile ago to that issue reported on the PropellerIDE issue tracker at github (see
    I haven't heard from anyone as to whether it's the best way to fix it, but it worked for me, and it's not a particularly invasive change.

  • TheTech69TheTech69 Posts: 51
    edited 2017-09-09 13:44
    Thank you all for the responses. The fix that made it work was go to Edit-Preferences(F5). Click on "Browse". I noticed that the dialog window that opened went to my Home directory instead of the directory that contained the compiler. I browsed to the directory that was already being displayed when I first opened Preferences. I clicked on that same compiler and clicked OK. All I had to do was re-map to the directory that was displayed when I first opened Preferences. Everything works fine now.

    The PropellerIDE version I used was 36.5 and NOT 38.5. I'm still going to try that version later.

    Thank You
Sign In or Register to comment.