WiFi module 32420 setup question

Hello, I have a few setup questions with these 32420s wifi modules.

I have two laptops running. One is logged onto the wifi board per tutorial.
The other is usb connected to a board of education usb model.

I downloaded the most recent firmware "parallax-esp-2016-11-02-1804-e"
but the only OTA file is parallax-ESP.ota.
Not the "32420-Parallax-ESP-vnnn.ota" mentioned in the tutorial.
It updated ok but it shows to be version 1.0(2016-11-02 18:04:30)

I continued with the tutorial and setup the baud rate and stop bits.
I then opened the val-from-micro.html web page and ran the val from micro host.bs2 program.
It uploaded fine and when i click update on the web page it pulls up a number sent from the BS2
but it only updates once. When i repress the update button the number never changes.
The debug screen shows the BS2 sent value correctly.

Why does the value not change when i repress the update button on the web page ?
Do I need a newer firmware ?

C. Jennings


  • 12 Comments sorted by Date Added Votes
  • One odd thing I noticed is the pin headers don't appear to be soldered onto the board.
    I haven't tried to pull on the pin headers but under a magnifying glass i see no solder.
    Am I missing something ?

  • edited February 2017 Vote Up0Vote Down
    Hello C. Jennings,

    The pin headers are manufactured with solder that is pre-deposited in the header, and it reflows into the plated holes as it passes through our oven. It deposits just enough solder to make a good intermetalic bond, but not much more. So the fillet on the top side is often not visible. I have handled a number of them, "carelessly" with no damage. They're petty sturdy.

    This is interesting, we were just discussing the one-shot behavior of the webpage in another thread with the Propeller. I have not been able to duplicate the symptoms here. I have been using Chrome and Safari in OSX Yosemite and Chrome in Windows 10. Are you using a different browser, and if so, does it start working if you switch to Chrome? Any additional info you can provide about your OS, browser, setup, security settings and security software would be helpful.

    Thanks, Andy
  • E_TexasTeslaE_TexasTesla Posts: 13
    edited February 2017 Vote Up0Vote Down
    I'm running Windows 7 professional with IE 11.0.9600.18537
    Java 8 update 77
    on a Panasonic CF-52

    I will try it with Chrome this afternoon.

    Thanks for the fast reply.
  • Ok ran the wifi tutorial on a different pc.

    Windows Vista Home premium SP2
    Chrome browser v 49.0.2623.112m

    I can log on to the wifi board ok. wx-db9b37
    When i attempt to update firmware is shows updating... them updating done rebooting..
    but it never completes reboot. Chrome times out and says web page unresponsive.
    My settings match the tutorial. And have been saved and saved to flash.

    Thanks for any advise.

  • edited February 2017 Vote Up0Vote Down
    Don't worry about updating the firmware for now. We haven't released any updates compared to what was originally loaded during manufacturing.

    If you just want to be sure it can do it, check the Mode dropdown on the Network page. It seems most likely to exhibit the symptoms you describe in STA+AP mode. If you have not already connected it to another Wi-Fi network, then put it in AP mode. If that still doesn't work, wait until after you have completed the Join Another Network instructions, then retry. I almost never see that behavior when the Wi-Fi module is on another network.

    Another thing to try would be re-loading an empty program into the BS2 so that it is not asking the Wi-Fi module to do anything else during the update.
  • E_TexasTeslaE_TexasTesla Posts: 13
    edited February 2017 Vote Up0Vote Down
    Problem solved.
    I started with a fresh install of Chrome on my windows 10 laptop.

    Val-from-micro.html updates values like it should.


  • Great! Thanks for the update Tom.
  • E_TexasTeslaE_TexasTesla Posts: 13
    edited February 2017 Vote Up0Vote Down
    New problem.
    I was running the "page-controls-lights" web page and everything was working great.
    But after a few minutes the wifi board stopped responding.
    No flashing red or blue leds
    Just green Vin. (New 9v battery.)
    I turned the BOE off then back on but only green Vin led comes on.
    I switched to another BOE and still nothing.
    I put a second wifi module in both boards and it works properly.
    I then removed the BS2 chips just to make sure no IO pin problems.
    Same results.

    Has this chip Bricked somehow ?
    Is it possible to reset ?

    I run a BSA robotics Merit Badge course and would love to demonstrate these to the scouts.

    I wired the wifi up on a BOE breadboard but it was still inop.
    I moved it back to the App Mod header x1 and it sprang to life.
    I then moved it back to the breadboard and no go.
    I tested terminal tension/ Checked for good ground and 5v supply. Another new battery.
    Added .1 mf cap across Vss and Vdd. Still doesn't work on breadboard.

    I think this circuit is extremely sensitive to interference / noise on startup.
    It's working at the moment but sporadic.

    I have four Boe Bots and two sumo bots.
    If you have any advise i would appreciate it.

  • Voltage Regulators on sumobots might not be able to keep up with the wifi modules current demand. Regulator on the board of education vdd Supply should be able to keep up with it though, regardless of whether it is in the breadboard or the X1 header. Make sure to use alkaline batteries, because rechargeable batteries could end up keeping the bs2 in a brownout situation because they are only 1.2 volts per cell instead of 1.5 volts.

    That's all I can think of for now, I might post back later with some more suggestions. Keep us posted.
  • Some more ideas.

    Make sure you've got DI to P2, and DO to P4 on the breadboard

    Run the END program before connecting the Wi-Fi module so that a previous program cannot put it in an indeterminate mode.

    Add a pause(2000) at the beginning of the program to make sure the Wi-Fi module has fully woken up before communicating with it.

    Stick with the 6 V (4 cell) or 7.5 V (5 cell) battery pack. You can use rechargeable batteries in a 5-cell pack, but stick with alkaline in a 4-cell pack.

    Set the servo power to VIN.

    We are also testing to find out if a certain I/O sequence can put the module into some kind of lower level access mode. All the more reason to either have an empty program, or one that is a known-working application running in the BS2 before connecting and putting power on the Wi-Fi module. Someone from Parallax will follow-up on that here after we've done some testing. Sorry for the delay.
  • Ok I added a two second pause before END to the RunFirst.bs2 program.
    Uploaded to BS2 and set servo jumper to Vin.
    Still locked up. No wifi activity but Do and Di leds flash once each on power up.
    I also noticed a 3.2mv 450khz signal at the ground pin of the wifi board.
    The board is active just not communicating.
    I had my DSO connected between the BOE Battery ground clip and ground pin at wifi board.

    I have a second wifi board that works great in all three BOE boards.

    Don't worry about a delay, I'm in no hurry.

  • edited February 2017 Vote Up0Vote Down
    @ E_TexasTesla, please check your forum inbox. I sent you a message with a contact info for one of our Technical Support folks that I discussed this with. In many cases, a telephone session will get us to the end of trouble-shooting in a fraction of the time. Thanks for your patience.

Sign In or Register to comment.