Issues with 2 new Propeller 1-2-3 A9 Boards

Hi All,

I recently purchased 2 of the Propeller 1-2-3 A9 boards. I seem to be having some issues with both of them. I’m using the 12volt 5A power supplies from amazon that were linked in the Prop 2 thread.(TNTE 12 Volt Power Supply - 5 Amp Standard (12V 5A DC) Adapter)

Board 1 issues:
Red LED’s 0 - 7 are dimly lit when powered up. (Is this normal?)

Configuration LED not on.

Occasionally the RGB-3 turns on bright green.

Cannot connect to Propeller 2 with PNut or PX.exe

Cannot connect to Propeller 1 with Propeller Tool. It seems like the Propeller 1 or the FPGA is sending data through the USB port but it is not the correct response for the Propeller tool causing it to hang. The Propeller tool trys to connect for about 1 minute while the USB TX light flashes. It’s possible the Prop is not resetting for some reason.

Board 2 issues:
Red LED’s 0 - 7 are dimly lit when powered up.

Configuration LED turns on about 1 second after power on and turns off after about 20 seconds. (Is this normal?)

Cannot connect to Propeller 2 with PNut.

I am able to download to the Propeller 1 and run PX.exe on board 2. Can someone point me to the latest Prop 1 program that works with the latest PX.exe? I could only find the PX.spin version 1 that is in the A7 folder.

Thanks in advance,


  • 39 Comments sorted by Date Added Votes
  • I think you may have the same power supply issue that I had:
    Power supply only works when warm.

    If you either wait 5 minutes or get the power supply section (where all the silver caps are) warm with your hands, maybe it will work...
    Prop Info and Apps:
  • Chuck,
    Your board#2 sounds like it's normal. Just remember to flip the PGM/RUN switch to RUN when using PNut. Use Ctrl-G in PNut to check the Prop2 is active in the FPGA. You should get popup saying:
    Hardware found on COM1.

    Propeller 2
    16 Cogs, 1024KB Hub, Smart pins 63..58/35..32/7..0, 80 MHz

    “What car did you learn to drive stick shift on?” == “What was the make and model of your first car?” -> Password reset! --
  • Red Leds 0-7 dimly lit on boot up is normal.
    It looks like board 2 might be Ok.
    What comm port does the A9 board show up as?
    Px and Pnut only support com1 to com9

    Melbourne, Australia
  • “What car did you learn to drive stick shift on?” == “What was the make and model of your first car?” -> Password reset! --
  • evanh and ozpropdev are right, board #2 sounds like it's normal.

    But maybe board #1 needs to warm up....
    Prop Info and Apps:
  • The latest A9 version is 14a which can be found here

    and here's a test for the P1 on the A9 board.
    'P123-A7/A9 Propeller 1 Test
    'Switch to PGM from RUN
    'Jumper to P8X32A PGM (Right side)
    ' F10 from Propeller Tool
    'Conf. status led should blink 
      _clkmode = xtal1 + pll16x
      _xinfreq = 5_000_000
      led = 27
    pub main
      dira[led] := 1
        waitcnt(cnt+clkfreq >> 3)
    Melbourne, Australia
  • To program A9 board with FPFA image

    Set P8x32A jumper to left side (not PGM)
    Switch PGM/RUN switch to PGM and from command line type the following (i.e for COM6)
    px Prop123_A9_Prop2_v14a.rbf /p /6 
    When PX finishes wait for FPGA to boot (~20 secs) and Cog0 red led should light.
    Switch PGM/RUN back to RUN
    Start Pnut.exe
    Ctrl-G from Pnut should identify Propeller 2...
    Melbourne, Australia
  • You can also verify Prop2 has loaded ok using a serial terminal from 1200 to 2M baud.
    > Prop_Chk 0 0 0 0
    should return
    Prop_Ver Au
    Melbourne, Australia
  • Thanks for helping ChuckG out, Guys. I've been meaning to check what kind of power supply I'm using. I'll probably get out to the shop a little later.
  • BTW I can run my A9 board from the power supply from my DE2-115 board.
    it's a 12V 2A supply and running "spinning fozzie demo" with 16 cogs works fine.
    Here's the DE2-115 supply (left) and the 12V 5A supply I also use for the A9 board.

    719 x 929 - 273K
    Melbourne, Australia
  • ozpropdev wrote: »
    BTW I can run my A9 board from the power supply from my DE2-115 board.
    it's a 12V 2A supply and running "spinning fozzie demo" with 16 cogs works fine.
    Here's the DE2-115 supply (left) and the 12V 5A supply I also use for the A9 board.

    Hey! I'm using my DE2-115 power supply, too. That's what I was going to check tonight.
  • Same
    Do not taunt Happy Fun Ball! @opengeekorg ---> Be Excellent To One Another SKYPE = acuity_doug
    Parallax colors simplified:<br>
  • Okay thanks for the suggestions.

    I tried 3 different power supplies on board 2 including the one for the DE2-115. I don't think that is the problem.

    Can someone verify or point me to the latest Propeller 1 program used to run with PX.exe.

    I tried the new "Prop123_A9_Prop2_v14a.rbf" file on board2. I get the small dialog box with the progress bar. The box disappears when the download is finished. Is there supposed to be a message indicating the download completed successfully? It seems like the .rbf file is downloading but i don't get any cog 0 led turn on and PNut v13 cannot connect and get hardware version.

    My boards are using Com1 and Com4.

    Rayman, Did you order one of those new boards that Chip recently found? If so, any issues?

  • Just confirming board versions.
    #66054 is a A7 board (has 48 pin expansion header above RGB led's)
    #60065 is a A9 board (no 48 pin expansion header)
    Melbourne, Australia
  • @ChuckG
    I'm pretty sure that Px.spin version 1 is used in both A7 & A9 boards.
    Melbourne, Australia
  • ozpropdev, the boards are both #60065 (A9).
  • I just reloaded the v13 rbf to see what happens.
    There is no completed message, window just disappears.
    Then, the red LED by the beanie hat comes on 20 seconds and then "red0" led comes on for a while and then turns off.

    The "Get Hardware Version" function in PNUT doesn't work until you move the jumper from "PGM" to "RUN".

    BTW: I do have 2 new P123s but haven't tried them yet...
    Prop Info and Apps:
  • RaymanRayman Posts: 8,460
    edited January 2017 Vote Up0Vote Down
    Here are the P1V files for P123, think gotten from ozpropdev:

    If I remember right, the top.rbf is the one you want.
    The other thing is the source files that made it...

    BTW: Don't forget to include the "/p" option with px or it won't work right...
    Prop Info and Apps:
  • ChuckG, are you still having trouble? We'll swap out a board if it's bad. I tested all those, myself, but some problem could have developed.
  • Chip,

    Yes, I can't do anything with board 1 and I can't connect to PNut with board 2.
  • RaymanRayman Posts: 8,460
    edited January 2017 Vote Up0Vote Down
    One other thing is that you have to use the V13 PNut with the V13 rbf image.
    Maybe you only have the one though...

    Anyway, somewhere around V11 the serial interface mechanism changed.
    It used to identify in Prop Tool also, but doesn't anymore.

    If you flash the top.rbf image, you should be able to identify with the Prop Tool... (but not PNut)
    Prop Info and Apps:
  • So, I just tested one of my new boards...

    First thing I noticed is that it has that cold power supply issue...
    Could tell because the blue power led was dim and flashing at high speed.
    But, holding bottom of board with my hand (where all the metal capacitors are) and breathing on the top fixed it. It's 73 degrees in this room.

    Then, I was able to flash it with rbf file and px just fine.

    But, when I did "get hardware version" it said it couldn't find it!

    When, I then did "Change from port" to the actual port being used, then it worked!

    Very strange. Now, it recognizes it all the time even if I set the port to something else...
    Prop Info and Apps:
  • Second P123 doesn't have the cold power issue.
    Came on perfectly.
    Programmed perfectly.

    But, "Get Hardware Version" failed at first.
    This time, I just kept on trying, without doing "Change from port".
    Failed first 2 attempts and then worked every time after that.

    One thing I did different that with my other boards is that I didn't cycle power after programming with the rbf file. Recent comments in this forum made me think I didn't have to. So, all I did was flip the switch from PGM to RUN.
    Maybe that's why I didn't see this behavior before?
    Prop Info and Apps:
  • rayman, I have tried the "Change from port" to the actual port being used a bunch of times. I also tried to leave it powered up for long periods of time to warm up. I have a heat gun that I could try to warm that part of the board. I'm not sure if my boards have the blue led behavior that you are seeing. I'll check that tonight.
  • RaymanRayman Posts: 8,460
    edited January 2017 Vote Up0Vote Down
    Wouldn't recommend heat gun, just leaving it on for 10 minutes will let it heat itself up...
    Your board#1 sounded like it might have this issue...

    Did you try the top.rbf with board#2 and then try to recognize with Prop Tool?
    Prop Info and Apps:
  • I wonder if you might be having some kind of FTDI driver issue...
    Have you installed Prop Tool and connected with a Prop1 chip before with that computer?
    Prop Info and Apps:
  • I did not try the top.rbf file yet. This is not for prop 2 right?

    I can connect to Prop1 chips in fact, I can connect to the Prop1 chip that is on this board (board#2). PX.exe seems to download to it as well. I just cant connect with PNut. I wonder if it is a FPGA clock issue or a grounding issue. I thought the board had a clock input. Anyone think an external clock would work?

    rayman, are you using a laptop or a desktop?
  • Using with two different desktops.

    Just to be clear, you aren't doing anything with the "P8X32A PGM" jumper are you?
    If you did something with that jumper closed, you may have reprogrammed the P1?
    If that were true though, I don't think PX would work...
    Prop Info and Apps:
  • Anyway, if PX worked, then I guess the P1 is OK.
    I used to know where the P1 code is to reprogram the P1, but I think I've forgotten...

    I guess I'd recommend trying that top.rbf or an earlier version of P2V.
    Here's the V9 version, would be interesting to hear if that works.
    If you're not tired of messing with it anyway...

    Prop Info and Apps:
  • cgraceycgracey Posts: 8,903
    edited January 2017 Vote Up0Vote Down

    In case the PX program got overwritten on the Propeller chip on the Prop123-FPGA boards, here is the source code. You'd move the P8X32A PGM jumper to the right and use F11 in the Propeller Tool to program the EEPROM of the P8X32A. Then, move the jumper back to the left. If nothing is wrong, you should be able to download FPGA images with the PGM/RUN slider switch in the PGM position.

    If you'd like, PM me with your phone number or Skype name and I will give you a call when it's convenient for you. Thanks. -Chip

Sign In or Register to comment.