SimpleIDE on Raspberry Pi

I have a Pimoroni Propeller HAT and a Raspberry Pi 2 with Jessie.

I have both the Propeller IDE and SimpleIDE installed and working. To get a SimpleIDE icon on the desktop I finally down loaded and unzipped a Debian version to get the icon and desktop files.

What I want to do now is add to the board configuration files and have them show up in the list in SimpleIDE. The manual is not helping me. Where does it hide the list of board types?

Thanks

Comments

  • twm47099twm47099 Posts: 810
    edited 2016-02-26 - 18:21:50
    When I installed SimpleIDE on my RPi 2 I had the problem where there were no boards listed in the dropdown menu and no programs would load because of that. The manual mentions (my manual page is 23) that the board types are in a file "boards.txt" in the propeller-gcc\propeller-load\ folder (under the SimpleIDE install folder. On my windows computer that subfolder is the "Program Files\SimpleIDE\" folder.

    When I checked in my RPi install folder I either could not find boards.txt or if it was there it was empty (sorry, it's been a while & I don't recall which).

    Well if it had been a Windows problem, I would have been able to fix it right away. However, I am just starting out with Linux and there was a lot of trial and error (how to create a new file, edit it, and save it where I wanted).

    Eventually, I was able to create the boards,txt file with the proper text in it. Below I've copied the contents of board.txt from one of my windows installs. It's what I also used with the RPi. I think that putting the completed boards.txt into propeller-load and restarting SimpleIDE was all I needed to do.??? (again sorry I don't completely remember.)

    The cfg flies for the boards are also in the propeller-load folder.

    @parallax -- Please check the install files/instruction for SimpleIDE on the RPi and have the correct boards.txt install.

    Hope this helps.
    Tom

    #
    # This is a board selection file.
    # To enable a board, all that's needed is the
    # board cfg filename somewhere in the text here
    # 
    activityboard.cfg      # this is the Propeller Activity board type
    eeprom.cfg             # this is the default 64KB EEPROM board type
    rcfast.cfg             # the generic rcfast clock setting
    rcslow.cfg             # the generic rcslow clock setting
    c3.cfg                 # this is the default C3 type
    c3f.cfg                # this is the C3 type where only flash is used for code
    demoboard.cfg          # demoboard type
    hydra.cfg              # hydra type
    propboe.cfg            # propboe type
    propstick.cfg          # propstick type
    quickstart.cfg         # quickstart type
    spinstamp.cfg          # spinstamp type
    synapse.cfg            # synapse type
    
    
  • Thank you for your help.
    I found out that the .cfg file needs to be in 2 directories.

    /opt/parallax/propeller-load

    and

    /home/pi/SimpleIDE-0-9-45/parallax/propeller-load

    And yes I used the default user as I have several RPis and more micro SD cards.
  • How can I recompile this for ARM7 instead ?

    Trying to get SimpleIDE to run on this:

    nvidia.com/object/jetson-tk1-embedded-dev-kit.html

    Thanks,
    jt


  • jmgjmg Posts: 13,783
    That link mentions
    NVIDIA 4-Plus-1™ Quad-Core ARM® Cortex™-A15 CPU

    vs Raspberry Pi models of
    BCM2837 64bit ARMv8 Cortex A53 Quad Core
    BCM2836 32bit ARMv7 Cortex A7 Quad Core
    BCM2835 32bit ARMv11 Single Core
  • I will give it shot.
  • jtilghmanjtilghman Posts: 66
    edited 2016-04-04 - 16:07:30
    I downloaded the SimpleIDE for RPI and went to install it.

    When I went to run it, got a error message that it didn't like the version of QT I had installed even tho I have QT4 and QT5 installed.

    This is Ubuntu 14.04 I am running on this ARM board, I am not sure what else to do to get SimpleIDE to work.

    I will recompile it if needed, but not sure what dependents are needed.
Sign In or Register to comment.