Solved - Problem using SimpleIDE with RaspberryPI

twm47099twm47099 Posts: 855
edited 2016-01-11 - 03:00:36 in Learn with BlocklyProp
I recently got an RPi 2B and tried to install SimpleIDE on it. Everything went ok until I tried to run the welcome.c program. I got a "Can't Load an Empty Board Type" error.

I switched to Project View and saw that the Board Type drop down was empty. Clicking on the "Reload Board List" icon did nothing.
I checked the propeller-load folder in both the download folder and in the opt folder and they both have the different board types cfg files. However, neither has a boards.txt file that is mentioned in the SimpleIDE manual. I tried to create such a file with "activityboard.cfg" in it. I was able to save it to the propeller-load folder in the install folder, but not the opt folder (don't have permission). I'm a Linux nubie and don't know how to copy folders to a folder, much less a protected one.
I am not even sure if the boards.txt folder is the problem or what should actually be in it.

I would appreciate any help.
Thanks
Tom

Comments

  • Ok, problem solved.
    I had created the boards.txt file, but was unable to save it to the opt folder. So after I stored it in the propeller-load folder that had all the extracted files, I reinstalled SimpleIDE (not sure how that would work in Linux. It worked, the OS asked if I wanted to remove the old install and then after I said Y it reinstalled.

    Then I opened SimpleIDE - the boards dropdown was still empty and clicking on the icon did nothing. I went to properties and the general tab and changed the general link from opt.parallax.propeller-load to just opt.parallax and then back to opt.parallax.propeller-load.

    The the boards list was populated with activity board and quickstart board (which I had put in the boards.txt file), and activityboard-sdxmmc, and generic.
    So it works.

    Tom
Sign In or Register to comment.