Shop Learn
Cyberbot module installation troubles (it does nothing :( ) — Parallax Forums

Cyberbot module installation troubles (it does nothing :( )

Is there any in depth troubleshooting guide for the module? I moved it to Files on the micro:bit and I no longer get the error when I do
from cyberbot import *
But also nothing happens, even does nothing. If I only import microbit, everything works. Import cyberbot as well - nothing works. I tried both the Mu editor and online editor.

The same bot worked fine, including cyberbot library, on a Mac months ago but now I have Windows.

I downloaded the library from I tried the newest and oldest version.

Any help? I'm out of ideas :(


  • Update; I tried copying the contents of cyberbot library to my code file. I noticed there's a while True loop in I don't really understand how that code is meant to work but it seems to get stuck in that loop.

  • Ugh, found the issue. I hadn't used the robot for a while and the batteries had discharged over time where they weren't at full capacity and unable to move these servos at all (I think they need quite high voltage - other devices would still turn on with those batteries but the cyberbot wouldn't until I charged them to maximum)

  • GenetixGenetix Posts: 1,510


    Weak or dead batteries is a common issue with these servo-driven robots.

    Servos need a lot of current especially when starting and people are surprised at how quickly the batteries get drained.

Sign In or Register to comment.