Elev-8 Crashes

Hi everyone!
I have been experiencing a non-consistent problem with my Elev-8. I can often get in some 10-15 minute flights, gaining some altitude and distance. But, occasionally the copter will flip (roll) 180 degrees and head straight (upside) down. This has happened anywhere from 7 to 20 feet in altitude resulting in damage to motor mounts and props.

I really do not know where to start. I have been looking at the sensor data stream, but do not know if it is the flight controller or the transmitter or even the esc. I took screenshots of the sensor data to try to analyze, but really do not know where to start. Sometimes the Yaw Data is off the charts.

I have done the Accel and Gyro calibration many times.

Any advise would be greatly appreciated.

Comments

  • 10 Comments sorted by Date Added Votes
  • Welcome to the forums, your first post..well you have been signed up since 2015 :)

    Which version of the ELEV8 you you have? The controller matters. Version 1 and 2 have the Hoverfly controller, while the Version 3 has the Parallax Flight Controller.
    Infernal Machine
  • I have been a reader on the forums occasionally, First time poster.

    I have the V3 with the Parallax controller. I use 2.0.1 firmware and groundstation software. I also have the xBee setup to log data.
  • Sorry for late response. I've been absent for a LONG time! Anyway, I've had a similar problem which turned out to be a bad solder joint. Check all wires going from the ESC's to the power distribution harness - all bullets should have a strong mechanical attachment - you should not be able to twist or pull a connector off...
  • I will check that, but I feel that it may be a buggy flight controller. When I log data, the Z-accelerometer/gyro seem to be logging high values, like 12,000 when others are really low.
    Maybe I’ll post the logs.

    I would like to try to read the code to analyze just those sensors, then understand the math with the radio receiver.

    I plan of removing the FC and ESCs to troubleshoot the basic systems.

    Thanks!
  • I am planning on replacing my APM 2.6 F.C. on my Elev-8 first and then try replacing the receiver in order to solve my "No R/C" error. Here is a video I made when I rebuilt my Elev-8 after it crashed: https://youtube.com/watch?v=kanE9stMyyw

  • GlassKNees wrote: »
    I am planning on replacing my APM 2.6 F.C. on my Elev-8 first and then try replacing the receiver in order to solve my "No R/C" error. Here is a video I made when I rebuilt my Elev-8 after it crashed: https://youtube.com/watch?v=kanE9stMyyw

    Not sure that helps the OP as he has a Parallax Flight Controller.
    Infernal Machine
  • mcogs wrote: »
    I will check that, but I feel that it may be a buggy flight controller. When I log data, the Z-accelerometer/gyro seem to be logging high values, like 12,000 when others are really low.
    Maybe I’ll post the logs.

    I would like to try to read the code to analyze just those sensors, then understand the math with the radio receiver.

    I plan of removing the FC and ESCs to troubleshoot the basic systems.

    Thanks!

    I can send you a known working Flight Controller for testing. PM me your address.
    Infernal Machine
  • Uh, I was suggesting that he check solder connections as a bad connection has caused a couple of crashes. I added the bit about my APM flight controller "No R/C" problem as an aside - by the way, I solved the problem - I bought a new APM and just installed and configured it - the aircraft arms and flies as good as new.
  • Publison wrote: »
    mcogs wrote: »
    I will check that, but I feel that it may be a buggy flight controller. When I log data, the Z-accelerometer/gyro seem to be logging high values, like 12,000 when others are really low.
    Maybe I’ll post the logs.

    I would like to try to read the code to analyze just those sensors, then understand the math with the radio receiver.

    I plan of removing the FC and ESCs to troubleshoot the basic systems.

    Thanks!

    I can send you a known working Flight Controller for testing. PM me your address.

    Thanks Publison, life and the cold weather got in the way of doing any kind of troubleshooting. The hobbyist in me really wants to break down the FC to understand all the subsystems. I will probably revisit this in Feb/March.
  • mcogs wrote: »
    Publison wrote: »
    mcogs wrote: »
    I will check that, but I feel that it may be a buggy flight controller. When I log data, the Z-accelerometer/gyro seem to be logging high values, like 12,000 when others are really low.
    Maybe I’ll post the logs.

    I would like to try to read the code to analyze just those sensors, then understand the math with the radio receiver.

    I plan of removing the FC and ESCs to troubleshoot the basic systems.

    Thanks!

    I can send you a known working Flight Controller for testing. PM me your address.

    Thanks Publison, life and the cold weather got in the way of doing any kind of troubleshooting. The hobbyist in me really wants to break down the FC to understand all the subsystems. I will probably revisit this in Feb/March.

    We will be here to assist. Happy Holidays!
    Infernal Machine
Sign In or Register to comment.