Shop Learn
SX-Key software, Debian Buster and com port — Parallax Forums

SX-Key software, Debian Buster and com port

CableGuy67CableGuy67 Posts: 38
edited 2019-09-25 19:55 in Microcontrollers
I've managed to keep a working copy of the sx-key software up to Debian Stretch which I ran with wine version 1.8.7. I recently got a new T420 (well new to me) and have Debian Buster running on it. It's wine verson is 4.0.2. I can get the sx-key software v3.3.0 installed but I can't get it to recognize any com ports. I've stored the com1 and com2 with regedit and even created the links in the dosdevices directory (although I don't think you need to do that manually any more). Of course I've added myself to the dialout group as well. I just can't get /dev/ttyUSB0 mapped to com1. I don't think I'm missing anything and I know it did work in the past, so any tips would be super.


  • Well, I can find the port in terminal with a loopback setup on a db9 connector and the usb2serial I usually use with the sx-key. Although in terminal v1.93b (this but a slightly different version than shown it spits back whatever I send it in in one marked USB->COM adapters so perhaps that is the issue. I'll have to give it another test with my old laptop and see if that is different. I'm starting to think it may just be something hardwired into the sx-key software that just doesn't like the spoofed com port. I can see all the ones I setup in wine when I hit the COMs button up where the com port is selected.
    It's looking like I'll just have to create the hexfile with the sx-key software and transfer it to the chips using a linux program that can use the key to read and write.

  • Bah. The terminal output is exactly the same on the old machine. It's just the new version of wine that is doing something that the sx-key software just doesn't like.

    I guess I'll just have to hope my kid doesn't kill the old computer before I come up with an alternate way to program those old chips. It'll stink to lose the debugging features but whaddayagonnado...
  • Okay, just a follow up. By using the /1 switch as in:
    wine ./SXKey.exe /1
    the SX-Key software uses the numbered port and works as expected. You can't see any com ports in the software itself (nor choose another port) but that seems to be a pretty minor gripe for such old software. I thought I had tried that but I may have attached it wrong (or to the lnk menu item erroneously perhaps). Even better, once I call it this way it seems to write the usage correctly into the registry so that after that, I don't have to call it with the /1. I'm not sure if it means I have to hit "cancel" when the initial setup dialog shows when starting, but even so. I'm just glad it works.
  • Indeed you do have to hit "cancel" at the configuration dialog. Hitting okay removes the forced com number from the switch. Perhaps that is where I went wrong earlier and thought the switch didn't work. So, easy enough to fix if one accidentally hits okay. Just call it again with the switch and remember to hit cancel.
  • This is getting a bit one-sided, but for completion's sake.

    SXsim wouldn't run at first. I ran winetricks vb6run and it almost got me there. At least the right dlls were found after that. Then when I tried to launch it I got this.
    Component ‘MSCOMCTL.OCX’ or one if its dependencies not correctly registered: a file is missing or invalid:
    I got the file from microsoft here and just intalled it normally and let wine sort it out.
    Update for the Microsoft Visual Basic 6.0 Common Controls: mscomctl.ocx and comctl32.ocx

    Now even the sim button works. That I couldn't get working last time. Everything seems to be working just fine now. So, 5 years until Debian 11 to find a better solution. :P
  • WhitWhit Posts: 4,159

    Thanks for documenting what you are doing! Good news for SX-ers!
  • No problem at all Whit. I did run across one other bit of weirdness yesterday but I'm not sure what category of problem it is. At home, I have a second monitor that I always use. Since it is bigger (and a better distance from my aging eyes) I tend to toss my work stuff up onto it. When I went to the makerspace yesterday and was using only the laptop I couldn't get the software to open. I would get the first pop-up saying "its the first time" but the next window must have tried to open at a non-existent coordinate because it was closed from there. I had to hook my monitor back up at home to open (and move) all the windows back to the main laptop screen.
    Now, this seems like a window manager or wine problem to me. I guess it has to do with how everything is stored in registries (maybe in the user one at the wine root) or deeper in the main ones. It seems that every single window has locations stored so this could be an issue. Mostly though, it was just an annoyance this time. Just another thing to keep in mind.

Sign In or Register to comment.