forum subscription not working as expected

danieldaniel Posts: 231
edited 2004-08-05 - 21:29:59 in General Discussion
I'm beginning to be suspicious that the forum-level subscription is not working as expected.

I've know I'm not getting notified of new messages.

I'm not sure yet if it is just random, or if only one 'new' forum notification is sent until I visit the forum again.

I guess·I·am expecting a notification for every new forum message.

Daniel
daniel

Comments

  • edited 2004-07-26 - 01:16:50
    The forum level subscription will generate an email notification each time a new topic (thread) is created. The system will not generate an notification when additional posts are made to a thread unless you visit the thread. Once you visit the topic, the system resets a flag and the next post to the topic will generate a notification message. Essentially, the system tells you when new topics are posted, but doesn't flood your mailbox with post level notifications.
  • danieldaniel Posts: 231
    edited 2004-07-26 - 01:56:41
    You confirm that my expectation about forum notification is 'correct' as implemented.

    After I post this message, I'll mark all fora as read. Then, sometime tomorrow, when I go directly to the fora, for every new topic in them, I should find a have a notification in milbox for each of them.

    I'll let you know what I find.

    Then
    daniel
  • danieldaniel Posts: 231
    edited 2004-07-26 - 11:41:37
    It's 7:30am (GMT-5) locally.

    I have received 3 notifications since 9:56pm yesterday, to messages:

    f=13&m=171#m328
    f=5&m=315
    f=7&m=278#m314

    I'd guess that the second one is a forum notification.

    A guick look at the fora shows a larger number of replys to many nessages since 10:00pm yesterday; I would have expected notifications of each of those.

    In addition, it appears that Test Forum #327 and Parallax Support Forum #333 are new message threads since I marked all fora read last evening.

    HTH,
    Daniel
    daniel
  • Jim EwaldJim Ewald Posts: 681
    edited 2004-07-26 - 13:48:48
    The first and third items are new posts to a subscribed thread. The second item is a new thread. I will have to look at your subscriptions and correlate that back to what you observed overnight. It's not going to be a good day if the notification system is broken.

    ▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔


    Jim
    Parallax IT Dept.
  • danieldaniel Posts: 231
    edited 2004-07-26 - 13:57:51
    Jim,

    Hope you have a good day...

    If I can help exercise system for you, let me know.

    Daniel
    daniel
  • danieldaniel Posts: 231
    edited 2004-07-26 - 18:02:14
    FYI,

    I clicked 'mark all' for all fora at 10:28 am (GMT-5).

    I checked back at 1:39 pm (GMT-5).

    My email inbox had three notifications:

    f=7&m=367
    f=1&m=299#m363
    f=13&m=219#m352

    A quick survey of the fora however, showed that in messages that I suppose I should have been notified about:

    replies to existing threads:
    f=13, m354
    f=5, m353
    f=5, m359 and m361
    f=5, m362 and m365
    f=5, m356 and m369

    new threads:
    f=5, m366
    f=5, m357 and its reply m364
    f=5, m355 and its reply m360

    While I was typing this, I received notifications for messages m371, m372, m373, m374.


    I'll mark all fora as 'read' and check the fora again sometime tomorrow.


    Best Regards,
    Daniel
    daniel
  • danieldaniel Posts: 231
    edited 2004-07-27 - 17:15:03
    Hi,

    At about 1:15 pm (GMT-5) I checked my email.

    I had notiofications for only 6 messages:
    f=10&m=417
    f=3&m=391
    f=1&m=387
    f=13&m=382
    f=7&m=367#m377
    f=7&m=367#m375


    Based on the fora content, I expected a lot more.

    I subscribed to the new Sandbox forum, and marked all messages as read.

    Is there a notification problem? Is my expectation correct: that each NEW thread in a subscribed forum should generate a message?

    Should I cancel all forum subscriotions and later re-subscribe?

    Best Regards,
    Daniel
    daniel
  • JerryJerry Posts: 18
    edited 2004-07-27 - 21:45:01
    I have registered, now how do I subscribe to a forum?

    I must be missing something here.
  • Jim EwaldJim Ewald Posts: 681
    edited 2004-07-27 - 21:47:27
    From the main page, click any forum name to enter that forum. At the top of the list of topics there is a link, "Subscribe to this forum". Click on the link and you will be subscribed.

    ▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔


    Jim
    Parallax IT Dept.
  • danieldaniel Posts: 231
    edited 2004-07-27 - 22:10:31
    Jim,

    But does it (the forum notification system) work properly?

    I've not received any confirmation that it does, and the evidence I have is that it does not.

    Will you comment on this?

    Best Regards,
    Daniel
    daniel
  • Jim EwaldJim Ewald Posts: 681
    edited 2004-07-27 - 22:33:28
    Daniel,

    I cannot confim that the notification system is working properly. Based on your observations, it's difficult to define under what conditions the system will generate a notification. The documentation provided to us for this feature is not detailed enough to explain what is observed. So allow me to describe my understanding of how it is supposed to work.

    The forum level subscription seems to send an email when either a new topic is posted or a new messages has been posted to a thread that I have already read. It does not send an email on the second post to a thread if I have not visited the thread after the first notification email. As I understand this feature, you should not receive two notifications concerning a specific thread unless you have visted the thread between the receipt of the first email and the second.

    Thread level subscriptions should operate nearly the same. After one has subscribed to a thread, the next post to that thread will generate a notification. If you do not visit the thread, you will not receive any additional messages concerning posts in the subscribed thread. The notification will resume on the first post to the subscribed thread after you vist that thread, but you will again receive only one email regardless of the number of posts to the thread until next visit the thread.

    ▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔


    Jim
    Parallax IT Dept.
  • danieldaniel Posts: 231
    edited 2004-07-27 - 22:46:14
    Jim,

    > The forum level subscription seems to send an email when either
    > a new topic is posted or
    > a new messages has been posted to a thread that I have already read.

    My understanding of the what should happen in the second circumstance is aligned with yours--only one notification PER THREAD about replies to that thread.

    Your comments above (and perhaps the documentation is unhelpful in the matter) do not elaborate on the first situation. I'm expecting a notification FOR EACH NEW THREAD in the subscribed forum.

    It seems, however, that only the FIRST new thread in the forum generates a notice, and the system is forever silent about additional threads.


    a. Is the expectation that EACH NEW THREAD should deliver a notification correct, as you understand it?
    b. I'll mark all fora as read (as of July 27, 2004 6:46 PM (GMT -5)), and check for new results tomorrow.


    Best Regards,
    Daniel
    daniel
  • Jim EwaldJim Ewald Posts: 681
    edited 2004-07-27 - 23:01:55
    Here is an interesting observation. When one subscribes to a forum, there seems to be an implicit subscription to every thread in the forum. To demonstrate this, go to a forum for which you have no subscriptions (thread level or forum level). If you examine the subscription choices, you will see that you can subscribe to any of the topics.

    Now, go back to the list of topics and subscribe to the forum. Examine any of the threads and you will see that you now have the option to unsubscribe to each thread. When you go back to the list of threads and unsubscribe to the forum, you will note that each of the implicit subscriptions has been removed.

    I say that the thread subscriptions are implicit because they are not listed in your member profile as individual topic subscriptions.

    ▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔


    Jim
    Parallax IT Dept.
  • danieldaniel Posts: 231
    edited 2004-07-27 - 23:38:46
    On July 27, 2004 7:34 PM (GMT -5), reset all fora as read.

    Will check the list if subscribed forums/threads in the profile tomorrow.

    BTW, I had a quick glance at the dotNetBB site. If this is just a matter of a few SQL triggers and formatting and some ASP, doing nearly anything (from making notification work as desired, to pushing email in a listserv like fashion) should be straightforward. Is Parallax committed to using only standard release supported product form dotNetBB, or can you take liberties and roll your own?


    Daniel
    daniel
  • Jim EwaldJim Ewald Posts: 681
    edited 2004-07-27 - 23:46:05
    The dotNetbb product is written for the .Net platform. It's a fairly complex design, so modifications are not for the faint of heart. We have corrected a couple of errors and sent those back to dotNetbb for inclusion into the base product. The trouble with going on our own is all the work required to fold our customizations back into each subsequent release. At the very least, we can correct issues when we don't want to wait for the next version.

    BTW. I did receive an email when you made your last post. In fact that is how I have responded quickly on the last several posts.

    ▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔


    Jim
    Parallax IT Dept.
  • danieldaniel Posts: 231
    edited 2004-07-28 - 00:17:01
    I understand that "not for the faint of heart" is a different concept than "straightforward"; however, they are not necessarily antonyms.

    grinning,
    Daniel
    daniel
  • danieldaniel Posts: 231
    edited 2004-07-28 - 12:02:58
    Jim,
    I have not visited any (other) forum since July 27, 2004 7:34 PM (GMT -5), when I reset all fora as read.·

    In my mailbox this morning, I have notification of four (4) messages:
    ?f=1&m=497
    ?f=13&m=105#m498
    ?f=13&m=500
    ?f=7&m=367#m504

    When I go to the font page of the Control Panel, I see a fourteen (14) messages listed in the section titled "Subscribed Forums/Threads with New Posts".· Of these, it appears that the 2nd and maybe the 3rd from the botton are the same as two of the notifications I actually received.
    Attached is a screenshot of that list of messages.

    Does your mail log show that 14 notifications were actually sent to me, and thus were lost in the ether?

    If these are not recorded as having actually been sent, then I suppose were looking at a bug in the notification process.

    Feel free to access the info in my control panel if you wish--I can provide you with the password if you need to log on as me.

    I'll refrain from visiting any other fora so as to not distrube the evidence.

    Daniel
    daniel
  • danieldaniel Posts: 231
    edited 2004-07-28 - 22:05:31
    Jim,

    That backlog of undelivered notifications for my account continues to grow.



    Perhaps there is a problem with the newer TLD, my email is addressed to a .info domain.



    Or perhaps there is a PM (Private Messaging) requirement. 'Till now, I was running without PM and just now turned it on.



    Daniel
    daniel
  • Jim EwaldJim Ewald Posts: 681
    edited 2004-07-28 - 22:24:38
    All of the email that this site generated to you was delivered successfully. I counted 10 messages yesterday and another 5 for today. Clearly, that doesn't match the message totals.

    I noticed a report on the dotNetbb private forums that may have a great deal to do with what is observed here. It appears that replies to a thread are not always linked to the first post in the thread. It also appears that the notification mechanisim is watching the links from the first post. If the subsequent posts are not linked up correctly, the post notification never actually "sees" a change in the thread. Therefore, no email notification is generated.

    There is good news, in that the patch that corrects this issue should become available tomorrow. If all goes well, we would have the patch in place early Friday morning. Then we can gather a new set of observations and determine if the problem is fixed.


    ▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔


    Jim
    Parallax IT Dept.
  • danieldaniel Posts: 231
    edited 2004-07-28 - 23:06:04
    OK,

    Let me know when the patch is in place, and then I'll mark all fora as read and collect the notifications seperately from the rest of my email.

    If you can specifically identify the messages generated and let me know, I can account for them at my end. Perhaps some messages are being lost in transit, too.

    Daniel
    daniel
  • Jim EwaldJim Ewald Posts: 681
    edited 2004-07-28 - 23:20:10
    That sounds like a plan. I can scan the SMTP logs for traffic to you after we place the patch.

    On another item.. When I read your posts, it seems that the word 'forum' always appears as 'fora'.
    A) Do you see the same thing?
    B) If you do, are you typing in the word 'forum'?

    I'm just trying to see if the text is getting replaced somewhere along the line. That would be another "Bad Thing".

    Thanks for all your help.

    ▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔


    Jim
    Parallax IT Dept.
  • danieldaniel Posts: 231
    edited 2004-07-28 - 23:50:42
    Jim,

    Actually, it is a Good Thing.

    Where others might type "forums", I type "fora". It is (or rather was at one time) the preferred pluralization.

    Althought I type "fora", sometimes it gets rendered in text as something else; for which I blame the missing spell-checker and poor proofreading.


    Daniel
    daniel
  • Jim EwaldJim Ewald Posts: 681
    edited 2004-07-28 - 23:59:03
    Gramatical correctness is always appreciated here. (now where is that spell checker....)

    ▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔


    Jim
    Parallax IT Dept.
  • Jim EwaldJim Ewald Posts: 681
    edited 2004-07-30 - 00:27:28
    Daniel,

    The update we were hoping to recieve this morning has not materialized. I'll keep a watch on on the doNetbb site for the SP2 release.

    ▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔


    Jim
    Parallax IT Dept.
  • Jim EwaldJim Ewald Posts: 681
    edited 2004-07-31 - 02:14:26
    SP2 has been installed. Let's see if this fixes the intermittent email notification.

    ▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔


    Jim
    Parallax IT Dept.
  • danieldaniel Posts: 231
    edited 2004-07-31 - 11:51:14
    OK,

    I've marked all fora as read at July 31, 2004 7:51 AM (GMT -5).

    I'll preserve all notifications received, and then you and I can compare notes on Monday.

    Daniel
    daniel
  • danieldaniel Posts: 231
    edited 2004-08-01 - 20:45:47
    Jim,

    Bad news, I suspect.

    What does your SMPT logs show as actually sent to me since 31-JUL-2004 7:51 AM (GMT-5)?

    I have received exactly two notifications:

    ?f=13&m=778··· sent 01-AUG-2004 4:18, received 01-AUG-2004 04:18

    ?f=6&m=699#m775· sent 31-JUL-2004 23:04, received 31-JUL-2004 23:03

    A look at my Control Panel shows a number of messages· as pending notification. See attached file.

    I tried to attach the hmtl source of that control panel page so that you could look at the dotNetBB generated htlm, but the upload manager refuses to allow .txt or .zip files.· Apparently, the upload manager parses internal content as well as filename, and refused to upload the html even if I changed the file name.· THe attached file is html with the angle brackets replaced by square brackets.

    I suspect that (some of) the notifications are being flagged for transmission to me, as evidenced by the control panel list of them.· But (what i presume is a periodic) dotNetBB task that converts the database record into an actual email is broken somehow.

    Does the newer TLD cause a problem (e.g., my email is on a .info domain)?· Probably not, I would guess as I get an occasional message.




    I'll be fairly busy on next week,· It would be best for you to dialog with me directly via email about this--you can get my email address from the account.· If you want this dialog a part of this thread, please email me to notify me of a new message on this thread so that I can then respond.



    Daniel

    Post Edited (daniel) : 8/1/2004 8:49:20 PM GMT
    ddm
    35K
    daniel
  • danieldaniel Posts: 231
    edited 2004-08-05 - 21:09:46
    Jim,

    Just checking in on status of thread.

    Is e-mail (listserv) taking precedence over this? If so, that is good, as notification is a poor second to pushed messages.

    Of course, if the e-mail distribution is dependant on the same mechanism as notification, it seems that there is still a weakness somewhere.

    Daniel
    daniel
  • Jim EwaldJim Ewald Posts: 681
    edited 2004-08-05 - 21:29:59
    Hi Daniel,

    I agree that the last update did not correct the notification issue. The good news is that I have been working on email distribution. This process is unaffected by the issue with notifications because the email is generated from the same code that writes the new post to the database. We should have the first phase ready very soon.

    ▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔


    Jim
    Parallax IT Dept.
Sign In or Register to comment.