Flexgui on windows 10

Tried to install and run on windows 10. icon appears on the task bar, but no gui, nothing at all on screen. Anyone have this running on windows 10?

Comments

  • I run it since the beginning on Windows 10, no problems.

    Mike
  • Thats odd, Frank. I’m running it on Win10 without any issues. Are you running FlexGUI 4.0.x-beta?
  • @frank freedman : Windows 10 is the normal platform for flexgui, so it should work.

    Did you try an earlier version of flexgui (or spin2gui) at some point in the past? Perhaps an old config file is left over. It'd be worth trying to delete all old versions of flexgui/spin2gui and re-installing flexgui from the .zip file.
  • One more reason I would rather use Linux most of the time. (Heater, oh Heater, wherfore art thou Heater???) Originally downloaded it and uncompressed it in the downloads directory. Went to the lower flexgui directory and ran it. icon on task bar showed program, but nothing on the screen. But the it was on the task bar. This time, I moved the same directory to the main c:\ so the path would be c:\flexgui and #$%$# if it actually came up and seemed to work. No idea why the previous behavior. But I have had the same luck with the windows version of BST. Windows.........
  • FlexGui working as it should with top and two sub files. Thx for the help!
  • One more reason I would rather use Linux most of the time. (Heater, oh Heater, wherfore art thou Heater???) Originally downloaded it and uncompressed it in the downloads directory. Went to the lower flexgui directory and ran it. icon on task bar showed program, but nothing on the screen. But the it was on the task bar. This time, I moved the same directory to the main c:\ so the path would be c:\flexgui and #$%$# if it actually came up and seemed to work. No idea why the previous behavior. But I have had the same luck with the windows version of BST. Windows.........

    Flexgui works without problems on linux. You just have to compile fastspin and consorts, which is just a simple 'make' . And Flexgui is a TCL script, which you can just run :)
  • I created a folder under C: drive called ‘Propeller IDEs’ and unpacked the files into there.
  • I cannot get it to work. Looked at all the files and no exe type seen.
    This is the latest from github
    798 x 612 - 62K
  • You have to download the flexgui.zip file from https://github.com/totalspectrum/flexgui/releases/latest. That's where the compiled binary release for Windows is located.
  • Screwy as it may seem, maybe there is a default path issue which causes flexgui to act like it ran properly even leaving its icon on the task bar. When it was behaving as I initially commented, the thing was in a different directory. When I blew it and all with it away and reloaded, it was unzipped as instructed and placed in c:\flexgui directory. It has worked as advertised since that point. Just a guess on my part, I thiink I will leave working at this point as a leave well enough alone.

    This is what happened on my machine, pilot315 did not indicate the failure indications in the last post so my fix may or may not be of use. BST presented witht he same behavior, may try the directory fix with that next.
Sign In or Register to comment.