S3 troubleshoot

Hi I have a S3 unit which stopped working.
When i connect the battery D5 flickers in blue and D13 flickers in red.
Also after a second the back PCB heats up and a burnt smell appears.
Any idea whats the problem and how do I fix it?

Comments

  • @RomanYtek - contact Parallax Technical Support at...

    E-mail Tech Support: Contact technical support at support@parallax.com, please include a detailed description of your problem.

    or

    Phone Tech Support:
    Phone: 916-624-8333
    Toll-Free: 888 99-STAMP (888-997-8267) For callers in the USA only.
    Whit+

    "We keep moving forward, opening new doors, and doing new things, because we're curious and curiosity keeps leading us down new paths." - Walt Disney
  • ercoerco Posts: 19,456
    I have a Boe-Bot which also emits a burnt smell.



    "When you make a thing, a thing that is new, it is so complicated making it that it is bound to be ugly. But those that make it after you, they don’t have to worry about making it. And they can make it pretty, and so everybody can like it when others make it after you."

    - Pablo Picasso
  • “Slightly modified”
    And Mach 3 is just a bit faster than walking pace!

    Best BOE-Bot EVER!! 🤣🤣
    That's not an explosion! That's an unscheduled rapid disassembly!

    Looking for a way to have a silicon chip made.
  • “Slightly modified”
    And Mach 3 is just a bit faster than walking pace!

    Best BOE-Bot EVER!! 🤣🤣

    Amazing. By the way those Corning plates are collectors items.
Sign In or Register to comment.