XBee 5V/3.3V Adapter Board REV B + arduino mega + xbee zb doesn´t work?????

JuciJuci Posts: 3
edited 2016-03-06 - 17:03:37 in Accessories
Hello,

I am tried a basic project, which I need to control a led remotly. I have 2 xbee AT modules, 1 arduino mega 2560 and a led to do it. I liked the D18 and D19 ports of the arduino to DIN and DOUT of the xbee router respectvly. I have tested just the arduino without xbees and it works., I have tested the communication of the two xbee modules by X CTU and it is fine. However, when I try to command by XBEE coordenator a order to arduino by XBEE router , it doesn´t work. Have I used a wrong adapter? Or somebody have a solution?

Thank you,

Comments

  • The Arduino website states that a limitation of the SoftwareSerial Library is that not all Mega 2560 pins support change interrupts.
    You are using Serial1, so try using Serial3 which is 15 for RX and 14 for TX.
    Pin 15 is on the list for RX.
    https://www.arduino.cc/en/Reference/SoftwareSerial
  • Thanks for your answer. I tried these ports but It does't work the same way. I only have in my mind that the adapter which I am using is not compatible with arduino. Maybe, another one???
Sign In or Register to comment.