SimpleIDE error: "Download failed: -1"

I just installed SimpleIDE 1.1.2 and tried to run the Welcome project. The Build Status window says the build succeeded, but then this:
proploader.exe -r -I C:/Program Files (x86)/SimpleIDE/bin/../propeller-gcc/propeller-load/ -b activityboard -p COM3 Welcome.elf
Opening file 'Welcome.elf'
ERROR: Download failed: -1

Opening file 'Welcome.elf'
ERROR: Download failed: -1

I do have a working Propeller on COM3 (verified with PropTool). This is on Windows 10. I have tried restarting my computer.

Help?

Comments

  • The loader only outputs -1 for a failure so don't know what the issue is for that.

    What propeller are you using? Prop Mini or flip. For some reason it can't talk serially to the device.

    Mike
  • Thanks iseries. I was able to run the Welcome project on an official Parallax Propeller ProtoBoard. I guess my crappy homemade Propeller board just doesn't meet SimpleIDE's standards.

    It would be nice if the error code were a little more informative so I could determine if it's the chewing gum or the baling wire causing my problem.


    m
  • There is a more up to date version of the prop loader that you can download and copy it into the folder. It does give more detailed answers as to the upload failure.

    If it's your own design then it probably is a reset issue since that seems to be a common problem when building your own.

    Mike
Sign In or Register to comment.