[SOLVED]Eddie: Encoder Error in PD-Controller

Cs4SystemCs4System Posts: 1
edited June 26 in Robotics Vote Up0Vote Down
[edit]
Solved this one. The encodes were conectet the wrong way. so the counted negativ when they are moving forward. just change the oder of the conectors an retry ;)
[edit end]

Hey people,
im a student from Germany and Im working with the Eddie Robot. Im trying to get a ROS-System running to controll the Robot.
When i did the first testing with the Parallax serial Terminal the robot was not able to move the weels evenly.
When i sent the command "GOSPD 30 30" the montors move for a short time befor they stop realy heavy.
The next time i send the same command the "Encoder error" occurs.

I've got the blue 36positions encoders and firmeware 1.3 installed.

For the command "DIST" the encoders work perfectly.
sometimes the SPD command give the respons "0000 FFFF" witch should be nonsens aswell, right?

As i could see in the code of the firmware, the error is made in the PD-controller. Any ideas why?

btw: all other command as TRVL or GO produce the same error.

thanks for your help!


Sign In or Register to comment.