Shop Learn
Frustrating Servo Power problems — Parallax Forums

Frustrating Servo Power problems

I'm trying to use a Feedback 360 servo but the servo keeps randomly moving and I can't control it.

I'm thinking that it is signal noise so I shortened every wire I can, and checked every connection multiple times.
I have also tried 3 different power sources (even an Arduino) with the same result.

I have tried a micro servo and it works fine with any of the power supplies.
I also have a Parallax Continuous Rotation servo and it has the same problem as the 360.

I really want to get on with my project!
How do I solve this once and for all !



  • What board are you using to control the servo?

    Into which header is the servo plugged in?

    Could you post a photo of your setup?
  • I'm using the P2-ES connected to pin 16 (but I have tried many different pins to see it if made a difference...nope)

    Some days it actually works!! I have no idea why.

    Does the feedback line need to be connected to something if I'm not using feedback?
    Will it act as an antenna and introduce noise?

    I hooked everything back up for the picture. It might look like the neg line is touching pins on the P2-ES but it isn't. I moved it over so it was farther away.
    The pictured setup isn't working at all :-(
    You can see by the current draw that the servo isn't turning.

    3024 x 4032 - 2M
  • Have you connected the motor supply ground to the logic ground? It looks like your power supply is connected directly to the red and black servo wires but nothing is being done to make sure that the servo and microcontroller share a common ground. If that is the case then you will get some pretty random behavior.
  • VonSzarvasVonSzarvas Posts: 2,494
    edited 2019-10-21 08:07
    Yes, about the common GND... ensure the servo ground is connected to both the P2 GND and bench supply GND.

    Also... you probably need a 10K pulldown on the signal pin, unless you configured the smartpin to handle that.

  • Thanks guys !
    I will do both. It's sure to resolve the problems I've been having :-)

  • tomcrawfordtomcrawford Posts: 1,111
    edited 2019-10-21 16:46
    what program are you using?

    The control signal absolutely has to have a ground reference.

    Feedback signal doesn't need anything if you are not using it.
  • Do you have an oscilloscope you can stick on the signal line? Maybe your signal is being messed up.
  • thejthej Posts: 232
    edited 2019-10-21 21:01
    No oscilloscope :-(
    (but getting one has been on my mind...)

    I'm using TAQOZ in ROM with the "Extend" code added for clock freq changing and PWM.

    I needed something interactive so I can experiment with my project.
    If I was using the feedback line (I will eventually), I'm assuming that it would also need to connect to the same ground reference?

  • xanaduxanadu Posts: 3,339
    edited 2019-10-22 00:04
    The servo header doesn't share a common ground with the rest of the P2 board?

    Edit: Never mind me, I didn't zoom in.
  • thej wrote: »
    If I was using the feedback line (I will eventually), I'm assuming that it would also need to connect to the same ground reference?

    You bet. But if the control pin has the correct ground reference, the feedback pin will as well.

  • Hi thej,
    Did you solve the problem? I have same issue too. If you get a solution, please share with me.
  • I've had trouble powering DC motors (including hobby servos) using a bench power supply. There's something about the inductive load which messes up some power supplies. I'd suggest trying a good battery pack for power.

    What is the current setting of the power supply. I'd suggest at least two amps just to be sure that's not the issue. Servos have large current spikes when they start to move. Inadequate power supplies has been the cause of many of my servo troubles.
  • bayturbaytur Posts: 2
    edited 2020-04-17 19:08
    I was using two different ground pins on the Arduino. Now made one so solved the problem.
Sign In or Register to comment.