Simple IDE User Guide

Copyright @ 2012 John Steven Denson

The Simple IDE is designed for programming the Parallax Propeller.
This guide is not comprehensive. It describes using basic features.
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SimplelDE User Guide

Simple IDE Features

« Menu Bar with File, Project, Edit, Tools, Debug, and Help

¢ Tool Bar with most Menu Bar operations

» Project manager menu and area for project file settings

e Compiler area for setting build attributes

¢ Tabbed text editor with optional highlighting
e Source Browser finds declarations

e Project build status pane

e Build Status shows build progress

e Status bar shows compile size, brief messages, and progress bar

e Board type and COM port selector

May 26, 2012
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Project Manager
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| hello.side
hello.c

% ¥ »EB00
hello.c B3

ot QO

C=f=]E=]

8 #include <propeller.h>
9 #include <stdio.h>

int main(void)

12 4
13 int n =1;
14 while (1) { E
] is vaitcnt (CLKFREQ/5+CNT) ;
| 16 printf("Hello World %d\n", n):
17 N+ i
i8 }
19 return 0;
20}
Project Opbons | Compier | Linker | Buld St |

S [r—
Compiler Type C i ~

MemoryModel (€06 ]
Optimization i

Project Directory: C:/gcedev/propsideMyProjects/helio/

propelier-elf-gcc.exe -0 a.out -Os “mcog -1 . -Wall -fno-exceptions hello.c
propeller-elf-objdump -h a.0ut
Done. Build Succeeded!

Code Size 1,516 bytes (1,552 total)

Building ... done.

Use
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Starting the IDE the first time
Start-up "About" Splash

At first startup the SimpleIDE "About" window appears. This shows you the current
version which can be greater than the one shown below, a link to this user guide (or
web site containing it), a check-box to choose showing or disabling the window at
start-up, and an OK button.

\Ci SimplelDE 7=

PAALLAX 2

www.parallax.com

SimpleIDE Version 0.7.0
Copyright (C) 2012, Parallax, Inc.

Visit SimpleIDE for more information. Email bug reports to gecheta @
Show this window at startup.

If the "Show this window at startup" is checked, you will see this window on every
startup. You can disable this by clearing the check box.
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General Settings

' SimplelDE Properties

Folders | General | Highlight

General Settings

Editor Tab Space Count

Loader Delay

Reset Signal

Clear options for next startup. Clear and Exit

Some general property details may need to be changed for different boards. For
example, some USB serial devices do not have DTR for controlling Propeller reset
and should use RTS instead. You can change the Reset Signal from DTR to RTS if
necessary. in the properties "General" tab. This can be changed at any time.
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Hello World Demo

Traditionally, a "hello" demo is the first program to run with a tool set. A hello
program is included in the demo package, and that will be the first program to
compile, load, and run. Later we will use a blinker program to show starting a new
project.

SimpleIDE uses a separate loader and terminal program. The hello program run with
SimpleIDE demonstrates a weakness in this arrangement. That is, the program must
delay printing otherwise the output can be lost in transition.

A minimum hello program used in SimpleIDE will look like this.

[code] -
#include <stdio.h>
#include <propeller.h>

int main(void)
{ i

/* one second delay before printf */ \f\mwwﬁy #JMU ﬂkAH \mﬁtﬁxAﬂ
waitent (CLKFREQ+CNT) ; j
/* traditional hello message */
printf ("hello, world\n") ;
return 0;

}
[ /code]

The demo code included in the package runs a loop and prints the loop iteration.
Before running anything on Propeller, there are a few simple things to do. That is,
you need to configure a board type and a serial port.

Preparing the Serial Port

To use SimpleIDE with Propeller on a computer having only USB ports it may be
necessary to install an FTDI USB/VCP driver.

Windows FTDI USB/VCP Installation

Please follow directions described here
http://www.parallax.com/Accessori SBDrivers id Default.aspx
If that page is not found, please visit www.parallax.com page to find the USB drivers page.

Mac OSX FTDI USB/VCP Installation

FTDI drivers should be preinstalled for OSX. Simple IDE packages do not support other OS
versions.

Linux OS FTDI USB/VCP Installation
Linux users can install FTDI USB/VCP drivers using their package manager.

In other cases, if there are problems with the drivers, one can visit the FTDI driver
web page at http://www.ftdichi m/Drivers/VCP.htm and follow their instructions.

.h lof Uﬁ ianux version heve EHEE m:\.\G?T 9.&9?@.
\Sparp Sucgest Hying before  worry <y alout drivers
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T
The rescan button looks like this: Re

Some computers have serial ports like BlueTooth. BlueTooth serial port programming
is possible, but not recommended at this point.

Place the mouse cursor over the port name for "hover help". Make sure hover help
shows the port type such as "USB Serial ..." or "FT232 ..." and select a different port
if necessary. If a port is not found, connect a Propeller board and refresh,

SimpleIDE does not automatically detect and use the Propeller port at this time. It is
up to the user to specify the port.

Running the Hello Demo

1. Open the hello.side project using Menu->Project->0Open Project or the tool
button. [

2. Use Menu->Run Console F8 or click the blue play button: @

Run Console compiles, loads, and runs the program. The serial console will appear
after loading.

Helle

Helle Werld
Helleo World
Hello ¥Werld
Hello ¥World
Hello World
Hello Werld
Hello ¥World
Hello Werld
Hello Werld
Hello Werld
Helle Werld
Helleo ¥World
Hello Werld
Hello Werld
Hello ¥World
Hello ¥World
Hellpo Werld
Hello Werld
Hello World
Helle Werld
Helle Vierld

oo oW

[l
3]

Clear a— Enable w

Note that the terminal is not fast enough to catch the first few hello lines. This is
because of the transition from propeller-load loading the program, releasing the
serial port, and starting the terminal.
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2. Click the folder browse button to select a new folder.

3. Enter your project name. The name will be added to the folder path. When you
have a valid project name and path, the OK button will be enabled. You can't start a
new project in an existing folder.

When you press OK to finish the New Project dialog the folder/project name will be
created. A main program template will be added for your new project.

Option 2: Close All, Use an existing main file

If one has an existing main file it can also be used with SimpleIDE.

1. Close all open files.

S

3
2. Choose Menu->Project->Set Project to Current File «,.mu...m
3. Note that project manager only has the existing file listed.

4. Add other files to the project.

Option 3: Close All, start new.
1. Choose Menu->File->Close all to close all editors and the project.

2. Fill in new main program with code below (please do not copy/paste the [code]
tags)ly o + n2ech do e Mere? s colour diffecentadion m\.?ur °
3. Choose Menu->File->Save As to rename the "untitled" editor tab to

"blinker.c". m r

4. Choose Menu->Project->Set Project m.mww.

o

5. Select Memory Model LMM or COG from the project options.

Example Code

[code] .‘ . m

#include <propeller.h> s \ﬁhrﬂ,ﬁm an  easier .ﬂﬁw, |

\ unclesstmn & ..LQ?V o o Yhig
for ﬁ&@l&h wWho dont bnow
m. WTuﬁ+n$¥m ﬂ

int main(int arge, char* argv[])

{

int mask = Ox3fffffff;
DIRA = mask;
HoR ol ) N
OUTA "= DIRA;
waitent (CLKFREQ/2+CNT) ;
}
return 0;
}
[/code]

13
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IDE Controls

Many features of the IDE will be familiar to new users. Some need explanation.

File Menu

E New: Creates a new file called "untitled" in the tabbed editor space.
L./ Open: Opens an existing file in the tabbed editor space.

m Save: Saves the tab editor text to the filename in shown on the tab.
m Save As: Saves the current tabbed editor text to another filename.

x Close: Closes the currently visible tabbed editor.
Close All: Closes all files and projects.

™) print: Prints the current document to a selected printing device.
Previous file names: Lists the last 5 opened files.

#ﬂ Exit: Asks to save any unsaved files and exits the program.

Project Menu

=| New Project: Opens a dialog for creating a new project in "folder/name"
selected by user. Project name will be added to the folder by the program from
the user's project name. If the folder/name does not exist, it is created.

= Open Project: Opens an existing project file with extention .side

E Save and Close Project: projects are always saved before they are closed.

wmqu.w Set Project. The function of the set project button (F4 or Project->Set
Project) has been discussed in the example above. Please review that section if
you haven't already.

Previous project names: Lists the last 5 opened projects.

5 Properties. This will open the SimpleIDE properties menu which was discussed
in the first time use section.

Edit Menu

S Copy: Copies selected editor text to the clip-board.
=
u,u. Cut: Copies selected editor text to the clip-board and deletes text.

4.
.b Paste: Pastes text from clipboard to the editor at cursor.

“4, Find and Replace: Opens a dialog with find and replace tools that allows for
optional whole word and case sensitive find and replace.

Redo: Undoes the last undo.
w Undo: Reverses the last edit.
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Program Menu

o @ Run Console (F8): Build, load, and run program on Propeller RAM (or
external memory for XMM). It opens a serial port console terminal window.

° » Build (F9): Build program only.

o B4pum F11): Build and load program to Propeller EEPROM (and external flash
for XMM). Board types with SDLOAD or SDXMMC in their name will have program
saved to SD card first.

° [ Run (F10): Build, load, and run program on Propeller RAM (or external flash
for XMM). Board types with SDLOAD or SDXMMC in their name will have program
saved to SD card first.

Serial Port Control

R o

° E Serial Port: This is the drop-down box on the left of the rescan button.

It lets you choose the port to use where your board is attached. The example
above shows COM20 while this bullet shows COM®6 - it just demonstrates that any
port can be selected. If the mouse hovers over the control, the "hover help" may
tell you more information such as whether the port is a USB serial port or even
Bluetooth.

~3
o K& Rescan: You must click the rescan button every time you change physical
port hardware connections.

° C Port Reset: This red “power switch” button lets you reset the board.

® @ Serial Port Console: This is a "display" button. Press to show and connect
terminal window to the selected port. If pressed (square around the button), it is
connected and you can disconnect by pressing the button again.

17
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Project Manager

SimplelDE uses a project manager - note the tab circled in red below. This is not a
list of files based on the open file like found in the Propeller Tool. The project
manager defines what is built regardless of what is shown in the editor tabs.

DLCOE P B P
AN RS VDT I

BRSNS

EIERHI Al sade

=t aeisiveld)

imt = = 3

Proect Qg Coroaer e Tui s
BwdTee [ (HE -
Coaples Tige c i J2,

Maverp Hodel - =

ORI 433 v !

A SimplelIDE project is called a "side project" because SIDE is an abbreviation of
Simple IDE. The ways to start a side project are described above in Creating a New
Project.

It may be obvious to some, but it is still worth stating that a project consists of
several files. If files are not listed in the project, the project can’tt be built and run.
Some .h header files may not be listed, but they must exist in the project folder pr a
specified link for successful builds.

The minimum required file in the side project is the main .c file, For example, the
hello.side project must contain a file called hello.c as shown above. The hello.c file
must contain the "main" function, that is: int main(void) or some variation of that.
Any other files containing code being used by hello.c must be listed in the side
project.

Please note, that there is no issue using a main .c type file for projects that include
C++ in Propeller-GCC.
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Project File List Ralow

The project pane is blank if no project is set. If a project is mmm the project name
with .side will be displayed as in the hello.side example above. All projects are .side
projects. The first indented entry is the main program. It should have the main start-
up function as in the case of hello.c .

Often we want to have more than one file per project. The project manager lets us
add files, links to files, and paths for extra includes and libraries.

If you right-click on the hello.c file entry in the project file list (or any other entry in
the list), you will get a popup menu that gives you several options. Most menu items
are related to adding entries like files or links. The function of each popup menu item
is described below.

| SimgHesdE Cgesd prgsde WPyt neTol el e
File Proect Edt fech Progmm Hele

e B i8

24 Fie Capy
dd e Unk
Zdd nckide Path
&dd Ly Fle
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Proect (ptiors | Compler | Unkar Pusie Siakar

Bayd Troe *ﬂ.vﬂ 5

Corgies Tyge FI—

Marmor ¢ Ve L

Qo brizniion T Brw =

If you just want to see the contents of a file, left click on the file-name. The file will
open in the editor tabs if the entry is a file. Entries starting with -I and -L are path
specifiers, not files. Clicking the .side file does nothing.

¢ Add File Copy: Add a new file to the project. When you add a file to the project,
it must already exist somewhere on your computer. You can make a new file in
the editor and save-as for example. If you choose a file outside of the project
directory, the file will be copied to the directory. File names are added in
alphabetical order except the main project file,

¢ Add File Link: Add a link to an existing file to the project. When you add a link
to a file, the file must already exist. When you link to a file it will not be copied to
the project directory. A link will have the short file name and -> full path name
as shown above. _ Cr.m\vmw

¢ Add Include Path: Add an include path for .h header files not in the project
folder or tool-chain library folder. This adds a -1 path to the project.

21
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Project Options

The compiler pane lets you choose typical Propeller-GCC compile options.
These options are automatically saved in the .side project file.

‘:ﬂbrl\....‘ e
.._..v(hw TR PR I

[T e Y ———

lepAe Re BN % * AULO

w«:qa.un-xui ni
wwiee P
Corgder Tyre

ey y vode!

Cxywraanen,

~».-Board Type: The board type option selects the basic board type where the

~ program will be loaded. In many cases the board type doesn't matter for LMM or
COG programs. Some boards have non-standard system clock frequencies
though and must be properly selected. In all cases XMM type programs will need
an XMM capable board selected.

. *.wm_omm.‘ Board Types: This puzzle piece button will read all
C:\propgcc\propeller-load\*.cfg files and load the names into the Board Type
combo box. The selected hoard type is savad in the .side project file

° me S R T ?_ Board Type: This is the drop-down box on the left side of
the green puzzle piece. It lets you choose the board type to use with your
program. Board types with SDLOAD or SDXMMC are special and when selected
tell the IDE that certain functions will be performed.

*» Compiler Type: C compiles C programs and can compile very simple C++
programs such as the C++_toggle demo. C programs needing std namespace
and libraries, etc... will need to use the C++ compiler. Typially a full C++
program will need an external memory to be useful.

¢ Memory Model: Many programs use LMM, but some programs use COG or
XMMC. The C-VGA demo is a COG only program. To compile that, use the COG
memory mode. Some programs are too big for LMM and can be run on external
memory modes like XMMC. The included graphics demo can run on LMM, but it
can also run on XMMC with board type EEPROM selected (64KB or more EEPROM

23
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quotes) to compile correctly. Use that flag for building dry11. There are other
flags that can be added here when using libraries. One may need -1 <path-to-
library-headers> for using prebuilt libraries.

B il it okt Tk = Presgram = Mk
UEdE= B 88
Progect Menager |
hellzarde

helioe!

tat zein|word)

ot = = 1;

Oths Likes Qosow

» Math Lib: Must be checked if you are using float or double in your program. The

program will compile without this, but it will not run correctly unless the library is
included.

¢ Pthread Lib: Must be checked if you are using Pthreads for running multiple
threaded programs in one COG or many COGs. The number of threads available
is limited by memory. XMM/XMMC programs will run all threads on the main
program cog. LMM programs can run M*N threads on N COGS.

¢ Other Linker Options: This lets you add linker specific options. For example “-|
name” may be added for using a prebuilt library. One can also add special linker
scripts here if a board does not fit a built-in memory layout.
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EEPROM Board Types

The EEPROM board type is like the HUB board type except that it has a cache driver
defined for running XMMC memory model programs. With the EEPROM or similar
board types, you can load a program into the EEPROM and the program can fetch
code to run from the EEPROM device,

This mode is usable with single 32KB EEPROMs (using two 32KB EEPROMs will not
work), 64KB EEPROM, 128KB linear address space EEPROMs (24FC1025 parts do not
have a linear address space and will not work. 24LC1024 parts will work), and 256KB
EEPROM from ST.

Any set of 64KB+ EEPROM can be configured to add more code space to your
program (using two 32KB EEPROMs will not work). All devices should be the same

type.

The XMMC model is the only X* memory model that will work with EEPROM board
types. Other board types related to EEPROM that run XMMC programs are PROPBOE,
QUICKSTART, and ASC+.

External Flash Board Types

e External Flash board types like C3F and SSF will run XMMC memory model
programs from Flash memory.

e« C3F: C3F XMMC programs are stored in the on board 1MB SPI Flash. C3F is a
variant of the C3 board type that uses all of cache for program code (the C3 type
splits cache between Flash and SRAM storage and is less efficient).

» SSF: SSF is the SpinSocket-Flash board type that uses 2 Winbond W25Q*
QuadSPI parts for storing and running XMMC memory model code in. This is the
fastest practical external memory solution available for propeller because of low
cost (< $0.75 per MB), low pin count (10 pins for byte-wide solution), high
density (up to 32MB), and high performance.

External RAM Board Types

External RAM boards are generally boards that have external SRAM, SPI-SRAM, or SDRAM.
Boards having only SRAM will only boot stand-alone it the code can be loaded from SDCard or
some other non-volatile storage. SRAM only boards can be loaded by the PC and SimplelDE
using the serial loader protocol for testing.

e (C3: The C3 type allows using the XMM (or XMM-SPLIT) memory model store
program code in SPI Flash and data in a device like external SPI SRAM. The only
default board type that uses this model today is C3. It is possible for a cache
driver to be written for other boards that will use the XMM memory model. The
C3F board type will only use C3 Flash and only works with XMMC memory model
programs.

e DRACBLADE: This board has SRAM and SD card. It can be loaded by the IDE for
testing, but must be programmed using SDLOAD for stand-alone boot.
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Configuration Files

Board configuration files provide customization for Propeller-GCC board hardware.
When a Propeller-GCC program is loaded on the hardware, it is done with the
propeller-load loader program (see h
loader will scan the board type .cfg file to use with the noB_u__mn_ Propeller-GCC
program and patch properties to the program if necessary before loading.

Configuration Variable Patching

Numeric properties found in the .cfg file can be applied to a Propeller-GCC program
to let the program run on boards with different hardware connections. Any variable
can be defined. http: ropellergcc/ has more information.

As a simple example, one board can have an LED on pin 15 and another board can
have an LED on pin 20. The same code can run on boards using different .cfg files.

# file: ledl5.cfg

# LED pin 15 example
clkfreqg: 80000000
clkmode: XTALI1+PLL16X
baudrate: 115200
rxpin: 31
txpin: 30
ledpin: 15

$ file: Hm%gn\

# LED pin 15-€xample
clkfreg: 80000000
clkmode: XTAL1+PLL16X
baudrate: 115200
rxpin: 31
txpin: 30
ledpin: 20

707

The Propeller-GCC program that uses ledpin can look like this:

[code]
#include <propeller.h>
/* Config variables must be global.
* If a variable is patched it will not have the value -1.
x/
int _cfg ledpin = -1;
int main(void)
{
if(_cfg ledpin > -1) {

DIRA |[= (1 << _cfg ledpin);
while (1) {
waitent (CLKFREQ/2+CNT) ;
OUTA |= (1 << _cfg ledpin);

waitent (CLKFREQ/2+CNT) ;

}
while (1) ;
return 0;
}
[/code]
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