Something I did....

Yes, I accidently plugged the Propeller Plug into the PROPMINI upside down or backwards. Now, I get an error message in PROPBASIC.."ERROR in DOWNLOAD". So, the question is, did I ruin the PROPMINI, the Propeller Plug, or both? Yes, I am not happy with myself...

Phone call to Parallax on Monday, for new stuff?

Thanks...DenO

Comments

  • I’m not sure which one would be damaged. If you have another prop device that uses the propplug, you can test it with that device to see if the prop plug is ok. As for the mini, you will need a confirmed working plug to test it.

    That really bites.
  • Yes, it bites....I can't believe I did that....always so careful.
  • Hmmm... that usually does no harm to Propeller circuits; I've done it many times. Not with the Mini, but the serial connections to the Propeller on it are the same as on any other board.
  • Well, as it turns out, I apparently did not destroy anything. But, I'm not sure what I did to fix the download issue. As I mentioned, I would attempt a download to the PROPMINI, and the download would start, but then the download wall stop at "downloading to RAM". Then the next line said "ERROR download fail". As a last resort I shorted the "RESET" pin to ground, and tried again. This time the download worked...to the RAM and then to the EEPROM. Go figure...?

    Thanks to all for your help...
  • Cluso99Cluso99 Posts: 16,909
    edited 2020-11-15 - 03:57:23
    Sometimes it’s necessary to repower the prop and restart the pc. Seems the usb interface in the pc gets stuck.
  • Cluso99 wrote: »
    Sometimes it’s necessary to repower the prop and restart the pc. Seems the usb interface in the pc gets stuck.

    As far as I can tell each and every piece of electronic gear that has some form of cpu and software also has some kind of quirky behaviour. My Prop development setup has a power bar that everything connects to for dealing with the quirks. Surprising how often powering down and back up fixes things.
  • Yes, I have run into that situation before, using PROPBASIC. However, this time, even after several power downs of the PROP and disconnections of the USB, I was still getting the "ERROR DOWNLOADING EEPROM". So, finally, nothing to lose, I think....I power back up, and take a small screwdriver, and short between the RESET pin and the VSS pin on the PROPMINI, and bingo...were off and running.
    3072 x 4096 - 3M
    4096 x 3072 - 4M
  • denno wrote: »
    off and running.

    Thanks for posting photos of your project. I always like seeing what other forum members make and your thermostat looks fantastic inside and out.

  • I see you use pin 30 and 31.
    My experience tell me it was harder to reprogram the prop while using them.
    I guess you destroy temporary the rs232 communication plug, and do not work as expected.
    When force the rest pin, the prop stop use pin 30&31 for a moment, and the "normal" plug communication start.
    Once the soft is running fine, there is no trouble to use pin 30 and 31.



  • What sometimes helps is to put a small wait loop in front of the program before starting serial communication, then programming does not get interrupted thru output of the serial line.

    Mike
Sign In or Register to comment.