+ Reply to Thread
Results 1 to 6 of 6

Thread: micromega FPU user defined function call - FCALL

  1. #1

    Default micromega FPU user defined function call - FCALL

    I am trying to call a user defined function on a micromega fpu. A portion of my code is listed. I am using:

    Code:
    '-------------------- uM-FPU USER DEFINED FUNCTIONS ---------------------------
    INIT_REGS           CON     $00    ' user defined FPU function, initialize fpu registers
    PROCESS_ADC         CON     $01 ' 
    CALC_ADJUSTMENT     CON     $02 ' 
    ' =========================================================================
      PROGRAM Start
    ' =========================================================================
    Start:
    Fpu_Reset
    Fpu_Write FCALL, INIT_REGS
    Main:
    PAUSE 5000
    GOTO Main



    Is this the correct way to call user defined functions on a micromega fpu. I have already loaded the attached fpu code onto the fpu using the micromega v3 ide. I am trying to sort out if my hardware or software is buggy? Any ideas...?

    Post Edited (slcott) : 12/28/2009 8:22:28 PM GMT
    Attached Files Attached Files
    Last edited by ForumTools; 09-30-2010 at 12:30 PM. Reason: Forum Migration

  2. #2

    Default

    any help greatly appreciated.
    Last edited by ForumTools; 09-30-2010 at 12:30 PM. Reason: Forum Migration

  3. #3

    Default

    You might want to send a not to Cam Thompson. Are you presently able to communicate with the FPU? If that works, then the other stuff is, as my friend says, a small matter of programming. I haven't use the FPU in a long time and never did get into custom functions.
    Last edited by ForumTools; 09-30-2010 at 12:30 PM. Reason: Forum Migration

  4. #4

    Default

    does anyone else have any experience with micromega fpu hooking up to an sx chip?
    Last edited by ForumTools; 09-30-2010 at 12:30 PM. Reason: Forum Migration

  5. #5

    Default

    search for "micromega fpu". The bs2 forum has a lot of hits.
    Last edited by ForumTools; 09-30-2010 at 12:30 PM. Reason: Forum Migration

  6. #6

    Default

    You should go to the website: micromegacorp.com/sx.html in order to develop the SPI interface with the chip.
    I have successfully used this chip with an SX for quite a while.

    Dave
    Last edited by ForumTools; 09-30-2010 at 12:30 PM. Reason: Forum Migration

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts