Did my wifi module just die?

Things have been going well over the last month as I learn to use the wx wifi to control my project.

But, I think my wx module may have just died. I've been working all day no problems. Power has been cycled regularly as I test new code. Went to grab something to eat and when I next powered up, no wx module in my wifi list on my laptop.

I'm well aware of the "it just broke" claim, but I changed nothing circuit wise. Only power cycling and writing code.

I have tried the Leave A Network sample code to put the device back into AP mode. No luck.

I have connected the debug pin to my prop plug. All I get is garbage.

I should note that the ASC light is off, which is why I tried resetting to AP mode.

But the DO light is also flickering away on it's own, even when nothing but power is applied. It's a very random looking pattern. Hooking this up to my prop plug also produced garbage on the terminal.

I've searched the forums but found little.

The only thing I can think of trying is if it's possible the firmware got corrupted somehow. I'm wondering if it's possible to reflash this via the prop plug only, since I cannot connect via wifi and access the update firmware webpage. Are there detailed instructions somewhere?

Thanks in advance.

Brian

Comments

  • 10 Comments sorted by Date Added Votes
  • Best thing I can suggest is a complete shutdown, power off everything, and then power up after at least 10 seconds of no power.
    In science there is no authority. There is only experiment.
    Life is unpredictable. Eat dessert first.
  • Brian, I assume you've seen the tutorials http://learn.parallax.com/tutorials/language/propeller-c/parallax-wx-wi-fi-module-prop-c which show how to load the firmware.

    If something has gone awry with the WX module we are happy to replace it. Try loading the firmware along with kwinn's suggestions first.

    Ken Gracey
  • Well, it was powered off all night, so that didn't work.

    I've also tried the "ground pgm four times" to reset trick.

    I think it may have been my own fault. There was a loss of power to my breadboard right after downloading new code to the propeller. I didn't give it much thought 'till now as SimpleIDE said download successful, and the prop had started to run its program just fine. But it was the next power up that things went wrong.

    I want to try updating the firmware, but I cannot access the device via wifi at all, so doing so needs to be over serial. I have a prop plug. Just trying to find instructions on doing this over serial.

    Brian
  • Sky,
    Something similar happened to me.
    I solved it by doing the toggling via a program.
    Details below;
    The WX came up with an IP when I initially started it, and then somehow with my experimentation it slipped into a STA(no IP) mode with ASC led off.
    I did not help matters by toggling the WX board RES pin 4 times in 2 secs – that is why the ASC light was wrongly flashing.
    In my defence, I read the API and it says ;
    "In a situation where there is no wireless connection (STA mode with no IP address) the module can be forced to turn on its AP (SoftAP) interface by toggling its RES pin low/high four times within two seconds".
    However, I realised this API RES pin is not the RES pin on the WX board, but is actually the PGM pin on the WX board.
    So I tried toggling the correct WX pin, but I could not reset the WX by grounding the WX PGM pin 4 times in 2 secs using a button.
    To do this toggling more precisely, I wrote a trivial SPIN program to do the toggling through Prop Pin via a 10K resistor to the WX PGM pin – much to my surprise it worked first time and now I have a slow blink STA(with IP) mode and I can continue.
  • macrobeak, excellent idea. Easy to implement. Was very busy and couldn't try till just now. Unfortunately it didn't work. :(

    Next, to figure out how to upload firmware via serial...

    Brian
  • I had similar issues with mine right after I got it as well. If I remember right, I think I used a combination of a quickstart board (for usb to serial) and the Nodemcu flasher (https://github.com/nodemcu/nodemcu-flasher). I think i had to dig through the parallax firmware file to figure out the order of the files and their offsets. I did successfully flash the parallax firmware with serial though. It has worked fine since. Hope this helps!

    Bryan
  • VonSzarvasVonSzarvas Posts: 1,258
    edited September 18 Vote Up0Vote Down
    Skywise711 wrote: »
    Next, to figure out how to upload firmware via serial...

    Brian


    Hi !

    I've attached some files and instructions.

    Not sure if the included parallax-esp fw version is still the latest, but the instructions and esptool are good.

    Does this work for you ?




    Edit: Checked with the Parallax Store- the fw here is still the latest! You can replace the httpd.x file if Parallax releases a newer version here: https://www.parallax.com/downloads/parallax-wx-wi-fi-module-firmware-and-example-files


  • Skywise711Skywise711 Posts: 37
    edited September 18 Vote Up0Vote Down
    VonSzarvas, thanks for that file. Very well written and simple. This needs to be made part of the official documentation, for advanced users.

    Unfortunately, it did not work for me. I am getting errors.
    warning: espcomm_sync failed
    error: espcomm_open failed
    

    I tried a few other baud rates just in case 115200 was incorrect.

    The DI momentarily flashes a few times, probably each an attempt to communicate. I see nothing on the DO light.

    And, I have rechecked multiple times I am wired up correctly. I am using my own breadboard.

    So, it looks like I borked my module. :(

    Oh well, stuff happens. But learning a bit how to update the firmware is useful as eventually I want to do this anyway with my own custom code.

    Brian
  • Although you might be right, your error message could also occur if the wx module didn't get into programming mode.

    Might be worth a try to powercycle the wx module once all the connections are made, and just before sending the esptool command.
  • What I'm going to do is order some of the espressif wifi modules and wire them up directly on my breadboard, then flash them with the parallax code. I was planning to do this in the future anyway towards learning to customize them. This mishap just pushes that plan sooner a bit. Heck, maybe I can repair my parallax board while I'm at it.

    Brian
Sign In or Register to comment.