The Javelin Stamp IDE and other things

Hello, I just got a Brand new, never used, Javelin Stamp. I am programming on a Professional Development Board with a Rev. D USBto232 Adapter. I ran the example program in the Javelin Stamp Manual, and received an error "No Javelin Stamps Found". I am on Windows 10. Thank you all in advance!


  • Did you download the FTDI drivers?

    Install the drivers BEFORE plugging in the USB cable to the adapter. You may have to reboot after installing the driver.
  • When you select Project>Identify what version does it display?
  • I tried two Javelin chips on a Javelin Demo board and Professional Development board. The first identifies as $33 Firmware and will not pass connection or program. Tried with JavelinIDE 2.0.3 and 2.0, (the earliest I could find on the 2001 Parallax CD). The next one identifies as $50 Firmware and works fine with both boards and both IDE's.

    I can't find an earlier IDE. Even DOS based.What is strange is that the $33 chip came on the Javelin Demo board, so it must have worked with some software at one time. I do not have the CD that came with the kit.
  • Using USB-RS232 Rev B and WIN 10.
  • I was using a USBto232 Rev.D and Win 10. My Javelin is on a PDB as well. When I hit the program button, the error said "No Javelin Stamps Found". Does you adapter work on a BS2? I have a Rev.B as well, but it does not work with a BS2, so I got a newer one. might I resolve this by using adapters as outdated as the Javelin is?
  • In the middle of packing to move, can't test at the moment, sorry.
  • My drivers have been installed for a long time. Maybe I should try and find 2001 drivers.
  • Anybody here doing this on Windows 10 successfully?
Sign In or Register to comment.