MacBS2 = what I'm doing wrong.

Hi everyone,

9 years ago I started an adventure with my Boe-Bot. Then, I became a father and bla, bla, bla... the boe-bot got missed in my cave.

Today I unpacked everything again and started to revive my bot. I updated the MacBS2 software and SerialtoUSB drivers and managed to load some old code into it. Everything worked smooth; the boe-bot got back and alive. I then started to code a new file:

'{$STAMP BS2}
'{$PBASIC 2.5}

DEBUG “Hello, I’m back”
END


And did not succeeded in having the MacBS2 uploading it into the bot. The program high lights in red - Hello - stating that it is an undefined symbol.


What I'm doing wrong? (I still have a professional development board to play with....)

Cheers

Comments

  • 3 Comments sorted by Date Added Votes
  • Milevithius,

    Your Mac is using a feature called "Smart Quotes and Dashes", which changes the input of a quoted string to include the "curly quotes", which MacBS2 does not recognize.

    Check this webpage out for a remedy:

    iclarified.com/38772/how-to-disable-curly-quotes-in-mac-os-x-mavericks

    dgately
    Livermore, CA (50 miles SE of San Francisco)
  • Great catch dgately, not to many people are familiar with Smart Quotes and Dashes.
  • ASKME wrote: »
    Great catch dgately, not to many people are familiar with Smart Quotes and Dashes.

    +1!!!

    Mac-related, time-sensitive offer HERE. :)

    "When you make a thing, a thing that is new, it is so complicated making it that it is bound to be ugly. But those that make it after you, they don’t have to worry about making it. And they can make it pretty, and so everybody can like it when others make it after you."

    - Pablo Picasso
Sign In or Register to comment.