new prop stops at 86%

13»

Comments

  • Heater. wrote: »
    Publison,

    I find the Propeller documentation to be quite OK.

    But:

    It does lack any mention of decoupling caps or XTAL caps. It does not have a practical working reference schematic for the Prop. As this thread and many others before clearly show.

    It lacks a formal definition of Spin and the Spin byte codes. Kind of fundamental as the later are built into the chip.

    It lacks a definition of the protocol required to program a Propeller.

    These things are not a problem for those using a Parallax Prop board and using the Prop Tool but really, it's not complete yet.

    Points taken, and agree.

    Infernal Machine
  • Before swapping Props, add the freaking decoupling caps! Do it NOW! If their lack is what's causing Prop burnout, you don't want to ruin another one.

    -Phil

    +1


    Infernal Machine
  • 1. *If* the bypass caps are really needful to keep from killing chips (and I haven't heard anyone from Parallax say they are), then I think Parallax is truly remiss. The standard connection diagram in the data sheet doesn't show them and the Propellor Education Kit (Labs: Fundamentals) doesn't have you install them until after you've powered up the board and run a program.

    2. johnproko, if you were on the Arduino forum, you would have been ignored (that is, no one would have responded further) after you didn't post pictures and code on about your second comment.
    Re-inventing the wheel is not a waste of time if, when you are done, you understand why it is round.
  • Phil Pilgrim (PhiPi)Phil Pilgrim (PhiPi) Posts: 22,341
    edited 2015-12-08 - 20:53:38
    *If* the bypass caps are really needful to keep from killing chips (and I haven't heard anyone from Parallax say they are), then I think Parallax is truly remiss.
    The evidence dates back quite a few years. Here's a 2007 post by Paul Baker, when he was working for Parallax:


    Here are other posts that address the same issue:


    -Phil
    “Perfection is achieved not when there is nothing more to add, but when there is nothing left to take away. -Antoine de Saint-Exupery
  • I don't know if those decoupling caps are 100% required. But getting a solid power and ground to any digital logic is first order of the day. Or any circuit for that matter.

    The theory and practical details of how to do that are often beyond the beginner, and regarded as "black magic" by many who have been doing it for years.

    So yes, there should be a working reference schematic somewhere in the data sheet, perhaps even a PCB layout as you see in many data sheets.

    Having said that, given those simple precautions a Prop is a pretty tough chip. Hard to kill compared to many others.







  • Not having decoupling caps close to the Prop won't "kill" the Prop, i.e. destroy it. But it won't operate properly, either. Whatever the docs say or don't say, they must be there. I have personal and direct experience with this.
    Platåberget
  • Heater. wrote: »
    You are right Loopy, throwing incorrect information into the pot does not help either :)

    We are all keen to help as best we can.

    Or should we all refrain from responding, knowing that someone who knows better than us will, who also doesn't because he's thinking the same? Resulting in no help at all !



    Tacitly, you imply that you personally love to muddle rather than mentor.

    Help for the original poster is Parallax's implict prime purpose for providing forum space.

    Please respect it.
    Hwang Xian Shen, Puddleby-on-the-Marsh.
    All things considered, I can live and thrive without Microsoft products. LINUX is just fine.
  • Cluso99Cluso99 Posts: 14,978
    edited 2015-12-13 - 08:20:52
    I am quoting problems as I read this thread so some may be answered but I would like to be complete.

    First - the xtal should be ~18pF load. No capacitors should be placed from the xtal to gnd ! This is contrary to most crystal circuits because the capacitance is within the prop chip. 8MHz will work provided you change _clkmode = xtal1 + pll8x and _xinfreq = 8_000_000. Your clock frequency will then be 8*8=64MHz. Be careful to calculate baud (btw it's baud not baud rate) correctly!

    Looks like you are likely using 7805 and perhaps 78xx 3V3 versions. These are old regulators and require specific capacitors to prevent oscillation on the output voltage. Also they will drop significant voltage across the regulator IC. You cannot have 1000uF on the output of these regulators! They pretty much demand something in the order of 47uF Tantalums and 0.1uF IIRC (see the datasheet).

    Now for the Prop. There is no bypass on the power/ground pins. You need at least 0.1uF between both sets of 3V3 & GND pairs, one on each side of the prop.

    Personally, using a 6V battery you should just connect straight to the 3V3 regulator (remove the 5V regulator). When using a battery a 100uF capacitor or less would be better on the input to the regulator. You need tantalums of ~47uF IIRC on both the input and output of the regulator, with 0.1uF on both too preferably (I am going from memory here - haven't used 78xx regulators for 20+ years! An LDO would be better such as LM1117-3V3.

    BTW Parallax have lot of info for beginners. But that info is not really meant for untrained people to build their own circuits without help. There are lots of professional boards for this, just like Arduino and others.
    On this forum, lots of beginners have been helped here to design boards, or to get breadboards working. But it does require answers from the OP (original poster). In this case that didn't happen for some time. We have tried to help but we are not mind readers - well at least I am not ;)

    For a little background...

    When the prop boots, the internal RC oscillator is used. Hence no need for a crystal for this. This RC oscillator varies significantly between chips, and also varies with temperature and voltage. The boot program caters for this big variation by using a special protocol to communicate serially. An EEPROM is also not required. If an EEPROM is used, then it must have a pullup resistor on the SDA pin - typically 4K7 to 10K. A pullup on SCL is optional due to the way the bootloader works in accessing the eeprom.

    If you don't have a crystal, then basically the serial comms to a PC is not going to work!!! This is because the RC oscillator is way to inaccurate for reliable comms. Note also, if using the standard FullDuplexSerial or similar Objects, these are set to use an external crystal. You have to specifically set your program to use the internal oscillator - I have never done this so not sure of the precise procedure. But to flash a LED does not require an external crystal.

    BOE should be connected to ground.

    When you want to use serial after a download, it is best to put in a delay before stating the serial object. A delay of 5s minimum should be set with "waitcnt (cnt + clkfreq*5)". This will allow you to switch from the downloader to the terminal program. Once you get used to this, you can reduce the value.

    I hope this helps. BTW I didn't see a posting of your code. I do expect you will find it all has to do with the power supply and bypassing.
    My Prop boards: P8XBlade2, RamBlade, CpuBlade, TriBlade
    Prop OS (also see Sphinx, PropDos, PropCmd, Spinix)
    Website: www.clusos.com
    Prop Tools (Index) , Emulators (Index) , ZiCog (Z80)
  • Chris SavageChris Savage Parallax Engineering Posts: 14,406
    Another thing to consider is that on a breadboard connection reliability is always a possibility on top of capacitance. It would be easier to work with one Propeller chip at a time. But it would be easy to confirm normal operation of the chip itself if you have an existing dev board you could plug the chip into such as the PPDB, Propeller Demo Board, Prop RPM, etc.
    Chris Savage | Engineering Tech | Main Office: (916) 624-8333 | Direct to Tech Support: (888) 997-8267 | Website | Twitter | Google+
Sign In or Register to comment.